summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2007-06-22 15:20:20 +0000
committerPatrick McLean <chutzpah@gentoo.org>2007-06-22 15:20:20 +0000
commita6f6acffc895ddf7acb050abeb561b50970a3dd3 (patch)
treebba9b00f8df06dafaf8cc3a2c156828227aa8fb9 /sys-fs/ntfs3g/ntfs3g-1.616.ebuild
parentregenerate pcap.c with newer pyrex for python-2.5 compatibility (diff)
downloadgentoo-2-a6f6acffc895ddf7acb050abeb561b50970a3dd3.tar.gz
gentoo-2-a6f6acffc895ddf7acb050abeb561b50970a3dd3.tar.bz2
gentoo-2-a6f6acffc895ddf7acb050abeb561b50970a3dd3.zip
Version bump, clean out some older versions.
(Portage version: 2.1.3_rc4)
Diffstat (limited to 'sys-fs/ntfs3g/ntfs3g-1.616.ebuild')
-rw-r--r--sys-fs/ntfs3g/ntfs3g-1.616.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/sys-fs/ntfs3g/ntfs3g-1.616.ebuild b/sys-fs/ntfs3g/ntfs3g-1.616.ebuild
new file mode 100644
index 000000000000..dca36f4e2349
--- /dev/null
+++ b/sys-fs/ntfs3g/ntfs3g-1.616.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ntfs3g/ntfs3g-1.616.ebuild,v 1.1 2007/06/22 15:20:20 chutzpah Exp $
+
+MY_PN="${PN/3g/-3g}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Open source read-write NTFS driver that runs under FUSE"
+HOMEPAGE="http://www.ntfs-3g.org"
+SRC_URI="http://www.ntfs-3g.org/${MY_P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="suid"
+
+RDEPEND=">=sys-fs/fuse-2.6.3"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ econf --disable-ldconfig
+ emake
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+ dodoc AUTHORS ChangeLog CREDITS NEWS README
+
+ use suid && fperms u+s /usr/bin/${MY_PN}
+}
+
+pkg_postinst() {
+ if use suid; then
+ ewarn
+ ewarn "You have chosen to install ${PN} with the binary setuid root. This"
+ ewarn "means that if there any undetected vulnerabilities in the binary,"
+ ewarn "then local users may be able to gain root access on your machine."
+ ewarn
+ fi
+}