summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-04-06 19:58:29 +0000
committerMike Frysinger <vapier@gentoo.org>2011-04-06 19:58:29 +0000
commit5645a7211f1fd262242c5cf7aa0c238cdfae4938 (patch)
tree0e0a9c66077dcefd0c1c123cea864f2a7d7dfd3f /sys-fs/mtd-utils
parentFix deprecation warnings. (diff)
downloadgentoo-2-5645a7211f1fd262242c5cf7aa0c238cdfae4938.tar.gz
gentoo-2-5645a7211f1fd262242c5cf7aa0c238cdfae4938.tar.bz2
gentoo-2-5645a7211f1fd262242c5cf7aa0c238cdfae4938.zip
add support for upstream tagged releases
Diffstat (limited to 'sys-fs/mtd-utils')
-rw-r--r--sys-fs/mtd-utils/mtd-utils-99999999.ebuild14
1 files changed, 11 insertions, 3 deletions
diff --git a/sys-fs/mtd-utils/mtd-utils-99999999.ebuild b/sys-fs/mtd-utils/mtd-utils-99999999.ebuild
index a72f74ddbc4f..5c50164df3c2 100644
--- a/sys-fs/mtd-utils/mtd-utils-99999999.ebuild
+++ b/sys-fs/mtd-utils/mtd-utils-99999999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/mtd-utils/mtd-utils-99999999.ebuild,v 1.5 2010/09/12 08:39:50 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/mtd-utils/mtd-utils-99999999.ebuild,v 1.6 2011/04/06 19:58:29 vapier Exp $
EAPI="3"
@@ -11,8 +11,13 @@ if [[ ${PV} == "99999999" ]] ; then
SRC_URI=""
#KEYWORDS=""
else
- MY_PV="${PV}-02ae0aac87576d07202a62d11294ea55b56f450b"
- SRC_URI="mirror://gentoo/${PN}-snapshot-${MY_PV}.tar.xz"
+ if [[ ${PV} == *.*.* ]] ; then
+ MY_PV="${PV}-*"
+ SRC_URI="http://git.infradead.org/mtd-utils.git/snapshot/v${PV}.tar.gz -> ${P}.tar.gz"
+ else
+ MY_PV="${PV}-02ae0aac87576d07202a62d11294ea55b56f450b"
+ SRC_URI="mirror://gentoo/${PN}-snapshot-${MY_PV}.tar.xz"
+ fi
KEYWORDS="~amd64 ~arm ~mips ~ppc ~x86"
fi
@@ -33,6 +38,7 @@ RDEPEND="!sys-fs/mtd
DEPEND="${RDEPEND}
xattr? ( sys-apps/acl )"
+# Diff snapshots have diff versions encoded into their dirnames
S=${WORKDIR}/${PN}
makeopts() {
@@ -41,10 +47,12 @@ makeopts() {
}
src_compile() {
+ cd "${S}"*
emake $(makeopts) || die
}
src_install() {
+ cd "${S}"*
emake $(makeopts) install DESTDIR="${D}" || die
dodoc *.txt
newdoc mkfs.ubifs/README README.mkfs.ubifs