summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2013-01-24 23:56:00 +0000
committerAnthony G. Basile <blueness@gentoo.org>2013-01-24 23:56:00 +0000
commit87e9b03aa63b988da3983c33fb33e8f4a25ea60e (patch)
treeb36c15dbaafb44fb5d90bdcaf37f6055c7e94016 /sys-fs/eudev
parentAdd glew dep - 448596 (diff)
downloadgentoo-2-87e9b03aa63b988da3983c33fb33e8f4a25ea60e.tar.gz
gentoo-2-87e9b03aa63b988da3983c33fb33e8f4a25ea60e.tar.bz2
gentoo-2-87e9b03aa63b988da3983c33fb33e8f4a25ea60e.zip
Fix typo that could break uclibc
(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'sys-fs/eudev')
-rw-r--r--sys-fs/eudev/ChangeLog8
-rw-r--r--sys-fs/eudev/eudev-1_beta2-r1.ebuild (renamed from sys-fs/eudev/eudev-1_beta2.ebuild)5
-rw-r--r--sys-fs/eudev/files/eudev-fix-typo-util.c.patch28
3 files changed, 39 insertions, 2 deletions
diff --git a/sys-fs/eudev/ChangeLog b/sys-fs/eudev/ChangeLog
index 44886e65168e..9b96012b13ef 100644
--- a/sys-fs/eudev/ChangeLog
+++ b/sys-fs/eudev/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-fs/eudev
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/eudev/ChangeLog,v 1.18 2013/01/24 20:22:57 axs Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/eudev/ChangeLog,v 1.19 2013/01/24 23:56:00 blueness Exp $
+
+*eudev-1_beta2-r1 (24 Jan 2013)
+
+ 24 Jan 2013; Anthony G. Basile <blueness@gentoo.org> +eudev-1_beta2-r1.ebuild,
+ +files/eudev-fix-typo-util.c.patch, -eudev-1_beta2.ebuild:
+ Fix typo that could break uclibc
24 Jan 2013; Ian Stakenvicius <axs@gentoo.org> eudev-1_beta2.ebuild,
eudev-9999.ebuild:
diff --git a/sys-fs/eudev/eudev-1_beta2.ebuild b/sys-fs/eudev/eudev-1_beta2-r1.ebuild
index 77882571e8e0..5e66e4c700d6 100644
--- a/sys-fs/eudev/eudev-1_beta2.ebuild
+++ b/sys-fs/eudev/eudev-1_beta2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/eudev/eudev-1_beta2.ebuild,v 1.5 2013/01/24 20:22:57 axs Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/eudev/eudev-1_beta2-r1.ebuild,v 1.1 2013/01/24 23:56:00 blueness Exp $
EAPI=4
@@ -113,6 +113,9 @@ src_prepare()
-i rules/*.rules \
|| die "failed to change group dialout to uucp"
+ # Fix a typo found after 1_beta2 was rolled out
+ epatch "${FILESDIR}/${PN}-fix-typo-util.c.patch"
+
epatch_user
if [[ ! -e configure ]]
diff --git a/sys-fs/eudev/files/eudev-fix-typo-util.c.patch b/sys-fs/eudev/files/eudev-fix-typo-util.c.patch
new file mode 100644
index 000000000000..371471e17733
--- /dev/null
+++ b/sys-fs/eudev/files/eudev-fix-typo-util.c.patch
@@ -0,0 +1,28 @@
+From 82f60023e3d4b33624c85a149915b411b504e426 Mon Sep 17 00:00:00 2001
+From: "Anthony G. Basile" <blueness@gentoo.org>
+Date: Wed, 23 Jan 2013 20:16:57 -0500
+Subject: [PATCH] src/libudev/util.c: fix typo introduce at commit 1ebf647
+
+The first argument of fcntl should be 'fd', the file descriptor.
+
+Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
+---
+ src/libudev/util.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/libudev/util.c b/src/libudev/util.c
+index 1d57a01..d3982b9 100644
+--- a/src/libudev/util.c
++++ b/src/libudev/util.c
+@@ -4586,7 +4586,7 @@ int fopen_temporary(const char *path, FILE **_f, char **_temp_path) {
+ fd = mkostemp(t, O_WRONLY|O_CLOEXEC);
+ #else
+ fd = mkstemp(t);
+- fcntl(t, F_SETFD, FD_CLOEXEC);
++ fcntl(fd, F_SETFD, FD_CLOEXEC);
+ #endif
+ if (fd < 0) {
+ free(t);
+--
+1.7.12.4
+