summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-04-06 17:23:53 +0000
committerMichał Górny <mgorny@gentoo.org>2015-04-06 17:23:53 +0000
commitb1d625249ea8949ce5919ea48e00bc31b0295c56 (patch)
tree7354afffa298ac0ca0596511dab7de8d67c3e228 /sys-fs/duperemove
parentAdd ruby22. (diff)
downloadgentoo-2-b1d625249ea8949ce5919ea48e00bc31b0295c56.tar.gz
gentoo-2-b1d625249ea8949ce5919ea48e00bc31b0295c56.tar.bz2
gentoo-2-b1d625249ea8949ce5919ea48e00bc31b0295c56.zip
Add myself to maintainers. Version bump. Fix passing CC, CFLAGS & LDFLAGS to the build system. Add missing dependency on libgcrypt.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'sys-fs/duperemove')
-rw-r--r--sys-fs/duperemove/ChangeLog10
-rw-r--r--sys-fs/duperemove/duperemove-0.09.2.ebuild36
-rw-r--r--sys-fs/duperemove/metadata.xml4
3 files changed, 48 insertions, 2 deletions
diff --git a/sys-fs/duperemove/ChangeLog b/sys-fs/duperemove/ChangeLog
index 2f7aa6d16511..dffb114a25e9 100644
--- a/sys-fs/duperemove/ChangeLog
+++ b/sys-fs/duperemove/ChangeLog
@@ -1,10 +1,16 @@
# ChangeLog for sys-fs/duperemove
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/duperemove/ChangeLog,v 1.1 2015/03/25 00:15:43 rich0 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/duperemove/ChangeLog,v 1.2 2015/04/06 17:23:53 mgorny Exp $
+
+*duperemove-0.09.2 (06 Apr 2015)
+
+ 06 Apr 2015; Michał Górny <mgorny@gentoo.org> +duperemove-0.09.2.ebuild,
+ metadata.xml:
+ Add myself to maintainers. Version bump. Fix passing CC, CFLAGS & LDFLAGS to
+ the build system. Add missing dependency on libgcrypt.
*duperemove-0.09.1 (25 Mar 2015)
25 Mar 2015; Richard Freeman <rich0@gentoo.org> +duperemove-0.09.1.ebuild,
+metadata.xml:
Add duperemove to repository.
-
diff --git a/sys-fs/duperemove/duperemove-0.09.2.ebuild b/sys-fs/duperemove/duperemove-0.09.2.ebuild
new file mode 100644
index 000000000000..93cfd1d44747
--- /dev/null
+++ b/sys-fs/duperemove/duperemove-0.09.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/duperemove/duperemove-0.09.2.ebuild,v 1.1 2015/04/06 17:23:53 mgorny Exp $
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Btrfs deduplication utility"
+HOMEPAGE="https://github.com/markfasheh/duperemove"
+SRC_URI="https://github.com/markfasheh/duperemove/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="dev-libs/glib:2=
+ dev-libs/libgcrypt:0="
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ # https://github.com/markfasheh/duperemove/issues/53#issuecomment-89796552
+ sed -i -e '/glib2_mutex_unlock/s:mutex_lock:mutex_unlock:' duperemove.c || die
+}
+
+src_compile() {
+ # CC & CFLAGS are set via = so need to override them
+ # LIBRARY_FLAGS are set via += so need to pass them via env
+ export LIBRARY_FLAGS="${LDFLAGS}"
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS} -Wall"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="/usr" install
+}
diff --git a/sys-fs/duperemove/metadata.xml b/sys-fs/duperemove/metadata.xml
index 30decb67dfbc..718f7dbb14e1 100644
--- a/sys-fs/duperemove/metadata.xml
+++ b/sys-fs/duperemove/metadata.xml
@@ -4,5 +4,9 @@
<maintainer>
<email>rich0@gentoo.org</email>
</maintainer>
+<maintainer>
+ <email>mgorny@gentoo.org</email>
+ <name>Michał Górny</name>
+</maintainer>
<longdescription>Btrfs deduplication utility.</longdescription>
</pkgmetadata>