summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2003-12-21 15:54:00 +0000
committerMartin Holzer <mholzer@gentoo.org>2003-12-21 15:54:00 +0000
commit32576bebb4613129221f586e7515245033a1eae8 (patch)
tree70c9ed6cceb736c97695368df1608f2e38e1e8b7 /sys-fs/dosfstools/dosfstools-2.10.ebuild
parentVersion bumped. (diff)
downloadgentoo-2-32576bebb4613129221f586e7515245033a1eae8.tar.gz
gentoo-2-32576bebb4613129221f586e7515245033a1eae8.tar.bz2
gentoo-2-32576bebb4613129221f586e7515245033a1eae8.zip
Version bumped.
Diffstat (limited to 'sys-fs/dosfstools/dosfstools-2.10.ebuild')
-rw-r--r--sys-fs/dosfstools/dosfstools-2.10.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/sys-fs/dosfstools/dosfstools-2.10.ebuild b/sys-fs/dosfstools/dosfstools-2.10.ebuild
new file mode 100644
index 000000000000..e174e1df7fb9
--- /dev/null
+++ b/sys-fs/dosfstools/dosfstools-2.10.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/dosfstools/dosfstools-2.10.ebuild,v 1.1 2003/12/21 15:53:31 mholzer Exp $
+
+inherit eutils
+
+DESCRIPTION="dos filesystem tools"
+SRC_URI="ftp://ftp.uni-erlangen.de/pub/Linux/LOCAL/dosfstools/${P}.src.tar.gz"
+HOMEPAGE="ftp://ftp.uni-erlangen.de/pub/Linux/LOCAL/dosfstools/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa"
+
+DEPEND="virtual/glibc"
+
+src_unpack() {
+ unpack ${A} ; cd ${S}
+ epatch ${FILESDIR}/errno.patch
+ sed -i "s:PREFIX\ \=:PREFIX\ \=\ \/usr:" Makefile
+ sed -i "s:\/usr\/man:\/share\/man:" Makefile
+
+ # Bug: 34785 hardened-gcc transparently adds -fPIC so we must filter
+ # that away because this package cant cope. (Nov 30 2003 -solar)
+ has_version 'sys-devel/hardened-gcc' && \
+ sed -i -e "s:^DEBUGFLAGS.*:DEBUGFLAGS=-yet_exec:g" Makefile
+}
+
+src_compile() {
+ # this package does *not* play well with optimisations
+ # please dont change to: make OPTFLAGS="${CFLAGS}"
+ make || die
+}
+
+src_install() {
+ make PREFIX=${D}/usr install || die
+ dodoc CHANGES TODO
+ newdoc dosfsck/README README.dosfsck
+ newdoc dosfsck/CHANGES CHANGES.dosfsck
+ newdoc dosfsck/COPYING COPYING.dosfsck
+ newdoc mkdosfs/README README.mkdosfs
+ newdoc mkdosfs/ChangeLog ChangeLog.mkdosfs
+}