summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2010-11-01 20:32:50 +0000
committerLars Wendler <polynomial-c@gentoo.org>2010-11-01 20:32:50 +0000
commite42abe5af812de82f9227de1b8deac8c80e45aa5 (patch)
tree6f1b55375685168772cc17f0110a6480de20f55d /sys-fs/ddrescue/ddrescue-1.13.ebuild
parentDelete older ebuilds. (diff)
downloadgentoo-2-e42abe5af812de82f9227de1b8deac8c80e45aa5.tar.gz
gentoo-2-e42abe5af812de82f9227de1b8deac8c80e45aa5.tar.bz2
gentoo-2-e42abe5af812de82f9227de1b8deac8c80e45aa5.zip
Version bump.
(Portage version: 2.2.0_alpha3/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs/ddrescue/ddrescue-1.13.ebuild')
-rw-r--r--sys-fs/ddrescue/ddrescue-1.13.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/sys-fs/ddrescue/ddrescue-1.13.ebuild b/sys-fs/ddrescue/ddrescue-1.13.ebuild
new file mode 100644
index 000000000000..dcd5ffdba98f
--- /dev/null
+++ b/sys-fs/ddrescue/ddrescue-1.13.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ddrescue/ddrescue-1.13.ebuild,v 1.1 2010/11/01 20:32:50 polynomial-c Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="Copies data from one file or block device to another with read-error recovery"
+HOMEPAGE="http://www.gnu.org/software/ddrescue/ddrescue.html"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_compile() {
+ # not a normal configure script
+ ./configure \
+ --prefix=/usr \
+ CC="$(tc-getCC)" \
+ CXX="$(tc-getCXX)" \
+ CPPFLAGS="${CPPFLAGS}" \
+ CFLAGS="${CFLAGS}" \
+ CXXFLAGS="${CXXFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ || die "configure failed"
+ emake || die "emake failed"
+}
+
+src_test() {
+ ./testsuite/check.sh "${S}"/testsuite || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install install-man || die "make install failed"
+ dodoc ChangeLog README NEWS AUTHORS
+}