summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2012-08-28 03:23:06 +0000
committerTim Harder <radhermit@gentoo.org>2012-08-28 03:23:06 +0000
commite4abdfd635cfcd3631a7c92d04bdb24b5e80e3c0 (patch)
treea4e40af2fbeb59f9d9b4bfa32b6f860a1c97a94b /sys-fs/dd-rescue
parentsys-apps/chpax: removed from tree. Bug #365825 (diff)
downloadgentoo-2-e4abdfd635cfcd3631a7c92d04bdb24b5e80e3c0.tar.gz
gentoo-2-e4abdfd635cfcd3631a7c92d04bdb24b5e80e3c0.tar.bz2
gentoo-2-e4abdfd635cfcd3631a7c92d04bdb24b5e80e3c0.zip
Version bump.
(Portage version: 2.2.0_alpha123/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs/dd-rescue')
-rw-r--r--sys-fs/dd-rescue/ChangeLog7
-rw-r--r--sys-fs/dd-rescue/dd-rescue-1.28.ebuild45
2 files changed, 51 insertions, 1 deletions
diff --git a/sys-fs/dd-rescue/ChangeLog b/sys-fs/dd-rescue/ChangeLog
index 9a7385b04f4c..1608d960b0a1 100644
--- a/sys-fs/dd-rescue/ChangeLog
+++ b/sys-fs/dd-rescue/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-fs/dd-rescue
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/dd-rescue/ChangeLog,v 1.25 2012/08/10 13:54:08 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/dd-rescue/ChangeLog,v 1.26 2012/08/28 03:23:06 radhermit Exp $
+
+*dd-rescue-1.28 (28 Aug 2012)
+
+ 28 Aug 2012; Tim Harder <radhermit@gentoo.org> +dd-rescue-1.28.ebuild:
+ Version bump.
10 Aug 2012; Johannes Huber <johu@gentoo.org> dd-rescue-1.25.ebuild:
Stable for x86, wrt bug #422209
diff --git a/sys-fs/dd-rescue/dd-rescue-1.28.ebuild b/sys-fs/dd-rescue/dd-rescue-1.28.ebuild
new file mode 100644
index 000000000000..e21a80363114
--- /dev/null
+++ b/sys-fs/dd-rescue/dd-rescue-1.28.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/dd-rescue/dd-rescue-1.28.ebuild,v 1.1 2012/08/28 03:23:06 radhermit Exp $
+
+EAPI=4
+
+inherit toolchain-funcs flag-o-matic
+
+MY_PN=${PN/-/_}
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Similar to dd but can copy from source with errors"
+HOMEPAGE="http://www.garloff.de/kurt/linux/ddrescue/"
+SRC_URI="http://www.garloff.de/kurt/linux/ddrescue/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="static kernel_linux elibc_glibc"
+
+S=${WORKDIR}/${MY_PN}
+
+src_compile() {
+ use static && append-ldflags -static
+
+ # Passing LDFLAGS together with CFLAGS is not often a good idea, but
+ # in this case it makes it possible to avoid patching; after all it
+ # only builds the progrma whole, not with object files.
+ #
+ # The falloc target creates a dd_rescue binary that uses the
+ # fallocate() function, present in Kernel 2.6.23 and later and GLIBC
+ # 2.10 and later. If somebody can think of a better way to
+ # optionally use it, suggestions are welcome.
+ emake RPM_OPT_FLAGS="${CFLAGS} ${LDFLAGS}" CC="$(tc-getCC)" \
+ $(use kernel_linux && use elibc_glibc && echo "falloc")
+}
+
+src_install() {
+ # easier to install by hand than trying to make sense of the
+ # Makefile.
+ into /
+ dobin dd_rescue
+
+ dodoc README.dd_rescue
+}