summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2007-01-10 17:52:46 +0000
committerAlon Bar-Lev <alonbl@gentoo.org>2007-01-10 17:52:46 +0000
commit20ef1d65dd228a1e61ea1ba347892b526b1c0488 (patch)
tree190ff27b04ec35e369cd4bcefbf749b3410d6b07 /sys-fs/dazuko
parentDependency update: dev-util/guile -> dev-scheme/guile. (diff)
downloadgentoo-2-20ef1d65dd228a1e61ea1ba347892b526b1c0488.tar.gz
gentoo-2-20ef1d65dd228a1e61ea1ba347892b526b1c0488.tar.bz2
gentoo-2-20ef1d65dd228a1e61ea1ba347892b526b1c0488.zip
Skip test if not root, bug#159876
(Portage version: 2.1.1-r2)
Diffstat (limited to 'sys-fs/dazuko')
-rw-r--r--sys-fs/dazuko/ChangeLog7
-rw-r--r--sys-fs/dazuko/dazuko-2.3.2-r3.ebuild12
2 files changed, 15 insertions, 4 deletions
diff --git a/sys-fs/dazuko/ChangeLog b/sys-fs/dazuko/ChangeLog
index f355ce1a4169..a3be336d1733 100644
--- a/sys-fs/dazuko/ChangeLog
+++ b/sys-fs/dazuko/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-fs/dazuko
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/dazuko/ChangeLog,v 1.16 2006/12/25 18:12:06 alonbl Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/dazuko/ChangeLog,v 1.17 2007/01/10 17:52:46 alonbl Exp $
+
+ 10 Jan 2007; Alon Bar-Lev <alonbl@gentoo.org> dazuko-2.3.2-r3.ebuild:
+ Skip test if not root, bug#159876
*dazuko-2.3.2-r3 (25 Dec 2006)
diff --git a/sys-fs/dazuko/dazuko-2.3.2-r3.ebuild b/sys-fs/dazuko/dazuko-2.3.2-r3.ebuild
index 96bc829468d9..835fbc0230d5 100644
--- a/sys-fs/dazuko/dazuko-2.3.2-r3.ebuild
+++ b/sys-fs/dazuko/dazuko-2.3.2-r3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/dazuko/dazuko-2.3.2-r3.ebuild,v 1.1 2006/12/25 18:12:06 alonbl Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/dazuko/dazuko-2.3.2-r3.ebuild,v 1.2 2007/01/10 17:52:46 alonbl Exp $
inherit linux-mod toolchain-funcs flag-o-matic
DESCRIPTION="Linux kernel module and interface providing file access control"
@@ -79,6 +79,14 @@ src_install() {
dodoc README.trusted
}
+src_test() {
+ if [ "${EUID}" != 0 ]; then
+ ewarn "Cannot test while not root"
+ else
+ emake test || die "Test failed"
+ fi
+}
+
pkg_postinst() {
[ "${KERNEL}" = "linux" ] && linux-mod_pkg_postinst