summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2006-12-09 18:41:37 +0000
committerAlon Bar-Lev <alonbl@gentoo.org>2006-12-09 18:41:37 +0000
commit03a2d7b86d307dc34367b449cd418222a5f32635 (patch)
tree3d16b36e1e87284368d6d66397da08d6be69a3d0 /sys-fs/dazuko
parentVersion bump. (diff)
downloadgentoo-2-03a2d7b86d307dc34367b449cd418222a5f32635.tar.gz
gentoo-2-03a2d7b86d307dc34367b449cd418222a5f32635.tar.bz2
gentoo-2-03a2d7b86d307dc34367b449cd418222a5f32635.zip
2.6.19 support
(Portage version: 2.1.1-r2)
Diffstat (limited to 'sys-fs/dazuko')
-rw-r--r--sys-fs/dazuko/ChangeLog8
-rw-r--r--sys-fs/dazuko/dazuko-2.3.2-r1.ebuild60
-rw-r--r--sys-fs/dazuko/files/digest-dazuko-2.3.2-r16
3 files changed, 73 insertions, 1 deletions
diff --git a/sys-fs/dazuko/ChangeLog b/sys-fs/dazuko/ChangeLog
index 36348b8e735a..da17c65d9924 100644
--- a/sys-fs/dazuko/ChangeLog
+++ b/sys-fs/dazuko/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-fs/dazuko
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/dazuko/ChangeLog,v 1.10 2006/12/02 16:02:44 alonbl Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/dazuko/ChangeLog,v 1.11 2006/12/09 18:41:37 alonbl Exp $
+
+*dazuko-2.3.2-r1 (09 Dec 2006)
+
+ 09 Dec 2006; Alon Bar-Lev <alonbl@gentoo.org>
+ +dazuko-2.3.2-r1.ebuild:
+ 2.6.19 support
02 Dec 2006; Alon Bar-Lev <alonbl@gentoo.org> dazuko-2.3.2.ebuild:
KBUILD_OUTPUT awareness, closes bug#156892, thanks to Zhang Le
diff --git a/sys-fs/dazuko/dazuko-2.3.2-r1.ebuild b/sys-fs/dazuko/dazuko-2.3.2-r1.ebuild
new file mode 100644
index 000000000000..36c230fbab9d
--- /dev/null
+++ b/sys-fs/dazuko/dazuko-2.3.2-r1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/dazuko/dazuko-2.3.2-r1.ebuild,v 1.1 2006/12/09 18:41:37 alonbl Exp $
+
+inherit linux-mod
+
+DESCRIPTION="Linux kernel module and interface providing file access control"
+MY_P="${P/_/-}" # for -preN versions
+SRC_URI="http://www.dazuko.org/files/${MY_P}.tar.gz
+ mirror://gentoo/${P}-linux-2.6.19.patch.bz2"
+HOMEPAGE="http://www.dazuko.org"
+LICENSE="GPL-2 BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+DEPEND=">=virtual/linux-sources-2.2"
+S="${WORKDIR}/${MY_P}"
+
+# kernel settings
+CONFIG_CHECK="SECURITY_CAPABILITIES"
+MODULE_NAMES="dazuko(misc:)"
+BUILD_TARGETS="dummy_rule"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${PN}-2.3.1-suspend2.patch"
+
+ if kernel_is 2 6 19; then
+ epatch "${WORKDIR}/${P}-linux-2.6.19.patch"
+ fi
+}
+
+src_compile() {
+ ./configure \
+ --without-dep \
+ --kernelsrcdir="${KERNEL_DIR}" \
+ --kernelobjdir="${KBUILD_OUTPUT}" \
+ || die "configure failed"
+ convert_to_m Makefile
+ linux-mod_src_compile
+
+ cd library
+ emake || die
+ cd ..
+}
+
+src_install() {
+ linux-mod_src_install
+
+ dolib.a library/libdazuko.a
+ insinto /usr/include
+ doins dazukoio.h
+
+ dodoc COPYING
+ dodoc README
+ dodoc README.linux26
+ dodoc README.trusted
+}
+
diff --git a/sys-fs/dazuko/files/digest-dazuko-2.3.2-r1 b/sys-fs/dazuko/files/digest-dazuko-2.3.2-r1
new file mode 100644
index 000000000000..fee1e7bfde35
--- /dev/null
+++ b/sys-fs/dazuko/files/digest-dazuko-2.3.2-r1
@@ -0,0 +1,6 @@
+MD5 e82799830e44dc2b5dfc9d355bcc5b2e dazuko-2.3.2-linux-2.6.19.patch.bz2 4706
+RMD160 09a635922d364f73e6f32787397e3657d2ec8087 dazuko-2.3.2-linux-2.6.19.patch.bz2 4706
+SHA256 239c514ddb4345d758706c50c286b125d3e35e476931bec0909bdf15c80c8d06 dazuko-2.3.2-linux-2.6.19.patch.bz2 4706
+MD5 bb32e24ad60a31dbfc419d3341287f68 dazuko-2.3.2.tar.gz 177134
+RMD160 57fd3dd45a61609a18829467966657ef658ed500 dazuko-2.3.2.tar.gz 177134
+SHA256 b396fc344cf1bad0d7dfb6675573a8ca189f34867fe1256c7f31c8ec9aab45bb dazuko-2.3.2.tar.gz 177134