summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2007-10-11 20:26:57 +0000
committerAlon Bar-Lev <alonbl@gentoo.org>2007-10-11 20:26:57 +0000
commitda47ee7a1569a687a4cb25d5c898d40a18a82e17 (patch)
tree697070cea357e2a7c5209003a86d94f481aed74f /sys-fs/dazuko/dazuko-2.3.4.ebuild
parentapp-editors/mlview: update gtksourceview deps (see bug #195366) (diff)
downloadgentoo-2-da47ee7a1569a687a4cb25d5c898d40a18a82e17.tar.gz
gentoo-2-da47ee7a1569a687a4cb25d5c898d40a18a82e17.tar.bz2
gentoo-2-da47ee7a1569a687a4cb25d5c898d40a18a82e17.zip
Version bump
(Portage version: 2.1.3.12)
Diffstat (limited to 'sys-fs/dazuko/dazuko-2.3.4.ebuild')
-rw-r--r--sys-fs/dazuko/dazuko-2.3.4.ebuild88
1 files changed, 88 insertions, 0 deletions
diff --git a/sys-fs/dazuko/dazuko-2.3.4.ebuild b/sys-fs/dazuko/dazuko-2.3.4.ebuild
new file mode 100644
index 000000000000..25be3d54e87b
--- /dev/null
+++ b/sys-fs/dazuko/dazuko-2.3.4.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/dazuko/dazuko-2.3.4.ebuild,v 1.1 2007/10/11 20:26:56 alonbl Exp $
+
+inherit linux-mod toolchain-funcs flag-o-matic
+
+DESCRIPTION="Linux kernel module and interface providing file access control"
+MY_P="${P/_/-}" # for -preN versions
+SRC_URI="http://www.dazuko.org/files/${MY_P}.tar.gz"
+HOMEPAGE="http://www.dazuko.org"
+LICENSE="GPL-2 BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+DEPEND="kernel_linux? ( >=virtual/linux-sources-2.2 )"
+RDEPEND=${DEPEND}
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ [ "${KERNEL}" = "linux" ] && linux-mod_pkg_setup
+ # kernel settings
+ if [ "${KERNEL}" = "linux" ] && kernel_is le 2 4; then
+ BUILD_TARGETS="all"
+ else
+ CONFIG_CHECK="SECURITY_CAPABILITIES"
+ BUILD_TARGETS="dummy_rule"
+ fi
+ MODULE_NAMES="dazuko(misc:)"
+}
+
+src_compile() {
+ if [ "${KERNEL}" = "FreeBSD" ]; then
+ KERNEL_DIR=/usr/src/sys
+ KBUILD_OUTPUT=/boot/modules
+ MAKE=make
+ fi
+ ./configure \
+ --without-dep \
+ --kernelsrcdir="${KERNEL_DIR}" \
+ --kernelobjdir="${KBUILD_OUTPUT}" \
+ || die "configure failed"
+
+ if [ "${KERNEL}" = "linux" ]; then
+ convert_to_m Makefile
+ linux-mod_src_compile
+ else
+ emake CC="$(tc-getCC)" LD="$(tc-getLD)" LDFLAGS="$(raw-ldflags)" || die
+ fi
+
+ emake -C library CC="$(tc-getCC)" || die
+}
+
+src_install() {
+ if [ "${KERNEL}" = "linux" ]; then
+ linux-mod_src_install
+ else
+ insinto /boot/modules
+ doins "${S}"/dazuko.kld
+ exeinto /boot/modules
+ doexe "${S}"/dazuko.ko
+ fi
+
+ dolib.a library/libdazuko.a
+ insinto /usr/include
+ doins dazukoio.h
+ doins dazuko_events.h
+
+ dodoc COPYING
+ dodoc README
+ dodoc README.linux26
+ dodoc README.trusted
+}
+
+src_test() {
+ if [ "${EUID}" != 0 ]; then
+ ewarn "Cannot test while not root"
+ else
+ emake test || die "Test failed"
+ fi
+}
+
+pkg_postinst() {
+ [ "${KERNEL}" = "linux" ] && linux-mod_pkg_postinst
+}
+
+pkg_postrm() {
+ [ "${KERNEL}" = "linux" ] && linux-mod_pkg_postrm
+}