summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2010-09-20 20:16:27 +0000
committerJeroen Roovers <jer@gentoo.org>2010-09-20 20:16:27 +0000
commit209751b4e56c570ec4c8df4cadb98b098c72e83d (patch)
tree6d41f9fbe5817ceddb11a7af3f67ab3ea969fd49 /sys-fs/copyfs
parentStable on amd64 wrt bug #337328 (diff)
downloadgentoo-2-209751b4e56c570ec4c8df4cadb98b098c72e83d.tar.gz
gentoo-2-209751b4e56c570ec4c8df4cadb98b098c72e83d.tar.bz2
gentoo-2-209751b4e56c570ec4c8df4cadb98b098c72e83d.zip
Version bump. Respect LDFLAGS (bug #336538), CC, CFLAGS. Set RDEPEND.
(Portage version: 2.2_rc84/cvs/Linux i686)
Diffstat (limited to 'sys-fs/copyfs')
-rw-r--r--sys-fs/copyfs/ChangeLog10
-rw-r--r--sys-fs/copyfs/copyfs-1.0.1.ebuild44
-rw-r--r--sys-fs/copyfs/files/copyfs-1.0-unlink.patch1
-rw-r--r--sys-fs/copyfs/files/copyfs-1.0.1-gentoo.patch46
4 files changed, 98 insertions, 3 deletions
diff --git a/sys-fs/copyfs/ChangeLog b/sys-fs/copyfs/ChangeLog
index c3da06b8ed41..6d7c2ee6148d 100644
--- a/sys-fs/copyfs/ChangeLog
+++ b/sys-fs/copyfs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-fs/copyfs
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/copyfs/ChangeLog,v 1.5 2007/07/02 15:32:49 peper Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/copyfs/ChangeLog,v 1.6 2010/09/20 20:16:26 jer Exp $
+
+*copyfs-1.0.1 (20 Sep 2010)
+
+ 20 Sep 2010; Jeroen Roovers <jer@gentoo.org> +copyfs-1.0.1.ebuild,
+ +files/copyfs-1.0.1-gentoo.patch, files/copyfs-1.0-unlink.patch:
+ Version bump. Respect LDFLAGS (bug #336538), CC, CFLAGS. Set RDEPEND.
02 Jul 2007; Piotr Jaroszyński <peper@gentoo.org> copyfs-1.0.ebuild:
(QA) RESTRICT clean up.
diff --git a/sys-fs/copyfs/copyfs-1.0.1.ebuild b/sys-fs/copyfs/copyfs-1.0.1.ebuild
new file mode 100644
index 000000000000..fb2ff9197065
--- /dev/null
+++ b/sys-fs/copyfs/copyfs-1.0.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/copyfs/copyfs-1.0.1.ebuild,v 1.1 2010/09/20 20:16:26 jer Exp $
+
+EAPI="2"
+
+inherit autotools eutils toolchain-funcs
+
+DESCRIPTION="fuse-based filesystem for maintaining configuration files"
+HOMEPAGE="http://invaders.mars-attacks.org/~boklm/copyfs/"
+SRC_URI="${HOMEPAGE}/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ppc"
+IUSE=""
+
+DEPEND=">=sys-fs/fuse-2.0
+ sys-apps/attr"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ # this patch fixes sandbox violations
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+
+ # this patch adds support for cleaning up the versions directory
+ # the patch is experimental at best, but it's better than your
+ # versions directory filling up with unused files
+ #
+ # patch by stuart@gentoo.org
+ epatch "${FILESDIR}"/${PN}-1.0-unlink.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf --bindir="${D}/usr/bin" --mandir="${D}/usr/share/man"
+}
+
+src_compile() {
+ emake CC=$(tc-getCC) || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+}
diff --git a/sys-fs/copyfs/files/copyfs-1.0-unlink.patch b/sys-fs/copyfs/files/copyfs-1.0-unlink.patch
index 9e6614f54271..f4ee28fae148 100644
--- a/sys-fs/copyfs/files/copyfs-1.0-unlink.patch
+++ b/sys-fs/copyfs/files/copyfs-1.0-unlink.patch
@@ -1,4 +1,3 @@
-Only in copyfs-1.0: Makefile
diff -u --recursive copyfs-1.0-orig/cache.c copyfs-1.0/cache.c
--- copyfs-1.0-orig/cache.c 2004-12-10 13:34:08.000000000 +0000
+++ copyfs-1.0/cache.c 2004-12-18 20:30:17.945445677 +0000
diff --git a/sys-fs/copyfs/files/copyfs-1.0.1-gentoo.patch b/sys-fs/copyfs/files/copyfs-1.0.1-gentoo.patch
new file mode 100644
index 000000000000..f0ddfab94af4
--- /dev/null
+++ b/sys-fs/copyfs/files/copyfs-1.0.1-gentoo.patch
@@ -0,0 +1,46 @@
+--- a/ea.c
++++ b/ea.c
+@@ -1,10 +1,11 @@
+ #include <sys/types.h>
+ #include <sys/stat.h>
+-#include <attr/xattr.h>
++#include <sys/xattr.h>
+ #include <string.h>
+ #include <stdlib.h>
+ #include <stdio.h>
+ #include <fuse.h>
++#include <sys/errno.h>
+
+ #include "helper.h"
+ #include "structs.h"
+--- a/interface.c
++++ b/interface.c
+@@ -23,7 +23,7 @@
+ #include <errno.h>
+ #include <sys/stat.h>
+ #include <stdlib.h>
+-#include <attr/xattr.h>
++#include <sys/xattr.h>
+ #include <sys/time.h>
+ #include <time.h>
+
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -27,7 +27,7 @@
+ OBJ = $(SRC:.c=.o)
+
+ CC = gcc
+-CFLAGS = -Wall -ansi -W -std=c99 -g -ggdb -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64
++CFLAGS += -Wall -ansi -W -std=c99 -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64
+ LIBS = -lfuse
+
+ all: $(TARGET)
+@@ -54,7 +54,7 @@
+ rm -rf /tmp/copyfs-dist
+
+ $(TARGET): $(OBJ)
+- gcc -o $(TARGET) $(OBJ) $(LIBS)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $(TARGET) $(OBJ) $(LIBS)
+
+ # Dependencies (use gcc -MM -D_FILE_OFFSET_BITS=64 *.c to regenerate)
+