summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-03-16 21:23:59 +0000
committerMike Frysinger <vapier@gentoo.org>2015-03-16 21:23:59 +0000
commit24eaa2d85fae1779b1dffd363126751d144e7716 (patch)
tree80e2eb43771870cb1a0ddc5e7d16d56d0454c55f /sys-firmware/ipxe
parentUse new toolchain helpers for selecting the bfd linker #438058 by Alexandre R... (diff)
downloadgentoo-2-24eaa2d85fae1779b1dffd363126751d144e7716.tar.gz
gentoo-2-24eaa2d85fae1779b1dffd363126751d144e7716.tar.bz2
gentoo-2-24eaa2d85fae1779b1dffd363126751d144e7716.zip
Use new toolchain helpers for selecting the bfd linker #438058 by Alexandre Rostovtsev.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
Diffstat (limited to 'sys-firmware/ipxe')
-rw-r--r--sys-firmware/ipxe/ChangeLog7
-rw-r--r--sys-firmware/ipxe/ipxe-1.0.0_p20130624.ebuild8
-rw-r--r--sys-firmware/ipxe/ipxe-1.0.0_p20130925.ebuild12
3 files changed, 12 insertions, 15 deletions
diff --git a/sys-firmware/ipxe/ChangeLog b/sys-firmware/ipxe/ChangeLog
index 186f13ca03fa..cada7e102167 100644
--- a/sys-firmware/ipxe/ChangeLog
+++ b/sys-firmware/ipxe/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-firmware/ipxe
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-firmware/ipxe/ChangeLog,v 1.19 2015/03/16 19:27:11 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-firmware/ipxe/ChangeLog,v 1.20 2015/03/16 21:23:59 vapier Exp $
+
+ 16 Mar 2015; Mike Frysinger <vapier@gentoo.org> ipxe-1.0.0_p20130624.ebuild,
+ ipxe-1.0.0_p20130925.ebuild:
+ Use new toolchain helpers for selecting the bfd linker #438058 by Alexandre
+ Rostovtsev.
16 Mar 2015; Mike Frysinger <vapier@gentoo.org> ipxe-1.0.0_p20130925.ebuild:
Switch to new tc-getOBJDUMP and fix quoting in ipxemake helper.
diff --git a/sys-firmware/ipxe/ipxe-1.0.0_p20130624.ebuild b/sys-firmware/ipxe/ipxe-1.0.0_p20130624.ebuild
index 61588a5fea5a..9ef8437a49a0 100644
--- a/sys-firmware/ipxe/ipxe-1.0.0_p20130624.ebuild
+++ b/sys-firmware/ipxe/ipxe-1.0.0_p20130624.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-firmware/ipxe/ipxe-1.0.0_p20130624.ebuild,v 1.7 2013/09/06 16:11:44 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-firmware/ipxe/ipxe-1.0.0_p20130624.ebuild,v 1.8 2015/03/16 21:23:59 vapier Exp $
EAPI=5
@@ -30,9 +30,7 @@ RDEPEND=""
S="${WORKDIR}/ipxe-${GIT_SHORT}/src"
pkg_setup() {
- local myld=$(tc-getLD)
-
- ${myld} -v | grep -q "GNU gold" && \
+ tc-ld-is-gold && \
ewarn "gold linker unable to handle 16-bit code using ld.bfd. bug #438058"
}
diff --git a/sys-firmware/ipxe/ipxe-1.0.0_p20130925.ebuild b/sys-firmware/ipxe/ipxe-1.0.0_p20130925.ebuild
index 1d1762d04b81..1a0f3ef4cb9e 100644
--- a/sys-firmware/ipxe/ipxe-1.0.0_p20130925.ebuild
+++ b/sys-firmware/ipxe/ipxe-1.0.0_p20130925.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-firmware/ipxe/ipxe-1.0.0_p20130925.ebuild,v 1.5 2015/03/16 19:27:11 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-firmware/ipxe/ipxe-1.0.0_p20130925.ebuild,v 1.6 2015/03/16 21:23:59 vapier Exp $
EAPI=5
@@ -29,13 +29,6 @@ RDEPEND=""
S="${WORKDIR}/ipxe-${GIT_SHORT}/src"
-pkg_setup() {
- local myld=$(tc-getLD)
-
- ${myld} -v | grep -q "GNU gold" && \
- ewarn "gold linker unable to handle 16-bit code using ld.bfd. bug #438058"
-}
-
src_prepare() {
epatch "${FILESDIR}"/${P}-git-version.patch #482804
@@ -53,11 +46,12 @@ EOF
}
src_compile() {
+ tc-ld-disable-gold
ipxemake() {
# Q='' makes the build verbose since that's what everyone loves now
emake Q='' \
CC="$(tc-getCC)" \
- LD="$(tc-getLD).bfd" \
+ LD="$(tc-getLD)" \
AR="$(tc-getAR)" \
OBJCOPY="$(tc-getOBJCOPY)" \
RANLIB="$(tc-getRANLIB)" \