summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-12-05 08:10:16 +0000
committerMike Frysinger <vapier@gentoo.org>2004-12-05 08:10:16 +0000
commitf13c3ddfe93afe38c5cf25b7330105cdee074f1b (patch)
treef12622e10a970761ce897a81b988cc2460133560 /sys-devel
parentAdded note about sparc SMP borkate. (Manifest recommit) (diff)
downloadgentoo-2-f13c3ddfe93afe38c5cf25b7330105cdee074f1b.tar.gz
gentoo-2-f13c3ddfe93afe38c5cf25b7330105cdee074f1b.tar.bz2
gentoo-2-f13c3ddfe93afe38c5cf25b7330105cdee074f1b.zip
Err, we want to handle GCC_SPECS, not GCC_CONFIG. Also make sure duplicate paths arent duplicated in LDPATH now that gcc is exporting multiple spec files per ebuild.
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gcc-config/ChangeLog10
-rw-r--r--sys-devel/gcc-config/files/digest-gcc-config-1.3.7-r5 (renamed from sys-devel/gcc-config/files/digest-gcc-config-1.3.7-r4)0
-rwxr-xr-xsys-devel/gcc-config/files/gcc-config-1.3.715
-rw-r--r--sys-devel/gcc-config/gcc-config-1.3.7-r5.ebuild (renamed from sys-devel/gcc-config/gcc-config-1.3.7-r4.ebuild)2
4 files changed, 16 insertions, 11 deletions
diff --git a/sys-devel/gcc-config/ChangeLog b/sys-devel/gcc-config/ChangeLog
index 934dda12e09d..df560ee6c3ae 100644
--- a/sys-devel/gcc-config/ChangeLog
+++ b/sys-devel/gcc-config/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-devel/gcc-config
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/ChangeLog,v 1.67 2004/12/03 21:39:59 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/ChangeLog,v 1.68 2004/12/05 08:10:16 vapier Exp $
+
+*gcc-config-1.3.7-r5 (05 Dec 2004)
+
+ 05 Dec 2004; Mike Frysinger <vapier@gentoo.org> files/gcc-config-1.3.7,
+ -gcc-config-1.3.7-r4.ebuild, +gcc-config-1.3.7-r5.ebuild:
+ Err, we want to handle GCC_SPECS, not GCC_CONFIG. Also make sure duplicate
+ paths arent duplicated in LDPATH now that gcc is exporting multiple spec
+ files per ebuild.
*gcc-config-1.3.7-r4 (03 Dec 2004)
diff --git a/sys-devel/gcc-config/files/digest-gcc-config-1.3.7-r4 b/sys-devel/gcc-config/files/digest-gcc-config-1.3.7-r5
index e69de29bb2d1..e69de29bb2d1 100644
--- a/sys-devel/gcc-config/files/digest-gcc-config-1.3.7-r4
+++ b/sys-devel/gcc-config/files/digest-gcc-config-1.3.7-r5
diff --git a/sys-devel/gcc-config/files/gcc-config-1.3.7 b/sys-devel/gcc-config/files/gcc-config-1.3.7
index 604fc92b3b32..32f133ef408a 100755
--- a/sys-devel/gcc-config/files/gcc-config-1.3.7
+++ b/sys-devel/gcc-config/files/gcc-config-1.3.7
@@ -1,7 +1,7 @@
#!/bin/bash
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/files/gcc-config-1.3.7,v 1.7 2004/12/03 21:39:59 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/files/gcc-config-1.3.7,v 1.8 2004/12/05 08:10:16 vapier Exp $
# Author: Martin Schlemmer <azarah@gentoo.org>
trap ":" INT QUIT TSTP
@@ -131,6 +131,7 @@ switch_profile() {
GCC_PROFILES="${GCC_ENV_D}/${CC_COMP} ${GCC_PROFILES}"
# Extract all LDPATH's for our CHOST
+ MY_LDPATH=""
for x in ${GCC_PROFILES}
do
if [ -f "${x}" ]
@@ -143,14 +144,9 @@ switch_profile() {
local sub_ldpath=
for sub_ldpath in ${LDPATH}
do
- if [ -z "${MY_LDPATH}" ]
+ if [ -d "${sub_ldpath}" ]
then
- if [ -d "${sub_ldpath}" ]
- then
- MY_LDPATH="${sub_ldpath}"
- fi
- else
- if [ -d "${sub_ldpath}" ]
+ if [ "${MY_LDPATH/:${sub_ldpath}}" = "${MY_LDPATH}" ]
then
MY_LDPATH="${MY_LDPATH}:${sub_ldpath}"
fi
@@ -159,10 +155,11 @@ switch_profile() {
export IFS="${old_IFS}"
fi
done
+ MY_LDPATH="${MY_LDPATH:1}" # trim leading :
fi
# Setup things properly again for this profile
- unset GCC_CONFIG
+ unset GCC_SPECS
source "${GCC_ENV_D}/${CC_COMP}"
OLD_CC_COMP=$(get_current_profile)
diff --git a/sys-devel/gcc-config/gcc-config-1.3.7-r4.ebuild b/sys-devel/gcc-config/gcc-config-1.3.7-r5.ebuild
index 53ce2fc26e30..80c442502d7b 100644
--- a/sys-devel/gcc-config/gcc-config-1.3.7-r4.ebuild
+++ b/sys-devel/gcc-config/gcc-config-1.3.7-r5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/gcc-config-1.3.7-r4.ebuild,v 1.2 2004/12/04 06:55:09 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/gcc-config-1.3.7-r5.ebuild,v 1.1 2004/12/05 08:10:16 vapier Exp $
inherit toolchain-funcs