summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-09-23 21:49:54 +0000
committerMike Frysinger <vapier@gentoo.org>2010-09-23 21:49:54 +0000
commitcae402d635374ed2fc19c09f39d206b07874c665 (patch)
tree6bd49197c524b61845c78bc3cb301954ad5b0932 /sys-devel
parentadd ~arm, bug #334841 (diff)
downloadgentoo-2-cae402d635374ed2fc19c09f39d206b07874c665.tar.gz
gentoo-2-cae402d635374ed2fc19c09f39d206b07874c665.tar.bz2
gentoo-2-cae402d635374ed2fc19c09f39d206b07874c665.zip
Version bump #338448 by Samuli Suominen.
(Portage version: 2.2_rc86/cvs/Linux x86_64)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/libtool/ChangeLog7
-rw-r--r--sys-devel/libtool/libtool-2.4.ebuild65
2 files changed, 71 insertions, 1 deletions
diff --git a/sys-devel/libtool/ChangeLog b/sys-devel/libtool/ChangeLog
index 3a9ac87738ac..547fc4133e10 100644
--- a/sys-devel/libtool/ChangeLog
+++ b/sys-devel/libtool/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/libtool
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/libtool/ChangeLog,v 1.172 2010/07/06 12:43:51 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/libtool/ChangeLog,v 1.173 2010/09/23 21:49:54 vapier Exp $
+
+*libtool-2.4 (23 Sep 2010)
+
+ 23 Sep 2010; Mike Frysinger <vapier@gentoo.org> +libtool-2.4.ebuild:
+ Version bump #338448 by Samuli Suominen.
06 Jul 2010; Mike Frysinger <vapier@gentoo.org> libtool-2.2.10.ebuild:
Force newer version of autoconf #327079 by Matt Turner.
diff --git a/sys-devel/libtool/libtool-2.4.ebuild b/sys-devel/libtool/libtool-2.4.ebuild
new file mode 100644
index 000000000000..573926e0465e
--- /dev/null
+++ b/sys-devel/libtool/libtool-2.4.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/libtool/libtool-2.4.ebuild,v 1.1 2010/09/23 21:49:54 vapier Exp $
+
+EAPI="3"
+
+LIBTOOLIZE="true" #225559
+inherit eutils autotools multilib
+
+DESCRIPTION="A shared library tool for developers"
+HOMEPAGE="http://www.gnu.org/software/libtool/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="2"
+#KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE="vanilla"
+
+RDEPEND="sys-devel/gnuconfig
+ >=sys-devel/autoconf-2.62
+ >=sys-devel/automake-1.10.1
+ !=sys-devel/automake-1.10
+ !=sys-devel/libtool-2*:1.5"
+DEPEND="${RDEPEND}
+ >=sys-devel/binutils-2.20
+ || ( app-arch/xz-utils app-arch/lzma-utils )"
+
+src_prepare() {
+ if ! use vanilla ; then
+ epunt_cxx
+ cd libltdl/m4
+ epatch "${FILESDIR}"/1.5.20/${PN}-1.5.20-use-linux-version-in-fbsd.patch #109105
+ cd ..
+ AT_NOELIBTOOLIZE=yes eautoreconf
+ cd ..
+ AT_NOELIBTOOLIZE=yes eautoreconf
+ fi
+}
+
+src_configure() {
+ # the libtool script uses bash code in it and at configure time, tries
+ # to find a bash shell. if /bin/sh is bash, it uses that. this can
+ # cause problems for people who switch /bin/sh on the fly to other
+ # shells, so just force libtool to use /bin/bash all the time.
+ export CONFIG_SHELL=/bin/bash
+
+ default
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog* NEWS README THANKS TODO doc/PLATFORMS
+
+ for x in $(find "${D}" -name config.guess -o -name config.sub) ; do
+ rm -f "${x}" ; ln -sf /usr/share/gnuconfig/${x##*/} "${x}"
+ done
+}
+
+pkg_preinst() {
+ preserve_old_lib /usr/$(get_libdir)/libltdl.so.3
+}
+
+pkg_postinst() {
+ preserve_old_lib_notify /usr/$(get_libdir)/libltdl.so.3
+}