summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Coie <rac@gentoo.org>2003-04-27 22:49:21 +0000
committerRobert Coie <rac@gentoo.org>2003-04-27 22:49:21 +0000
commitbbaca134832dae11b164c0a091d1babf6e618962 (patch)
tree011e9db325a258f9acf5452f3d23d253334e3e8f /sys-devel
parentThanks vapier, fixed ebuild up so it is correct. (diff)
downloadgentoo-2-bbaca134832dae11b164c0a091d1babf6e618962.tar.gz
gentoo-2-bbaca134832dae11b164c0a091d1babf6e618962.tar.bz2
gentoo-2-bbaca134832dae11b164c0a091d1babf6e618962.zip
initial import from bug 4191
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/makepp/ChangeLog9
-rw-r--r--sys-devel/makepp/Manifest4
-rw-r--r--sys-devel/makepp/files/digest-makepp-1.181
-rw-r--r--sys-devel/makepp/files/makepp-1.18-install.patch69
-rw-r--r--sys-devel/makepp/makepp-1.18.ebuild34
5 files changed, 117 insertions, 0 deletions
diff --git a/sys-devel/makepp/ChangeLog b/sys-devel/makepp/ChangeLog
new file mode 100644
index 000000000000..96c6509b23cc
--- /dev/null
+++ b/sys-devel/makepp/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for sys-devel/makepp
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/makepp/ChangeLog,v 1.1 2003/04/27 22:49:19 rac Exp $
+
+*makepp-1.18 (27 Apr 2003)
+
+ 27 Apr 2003; <rac@gentoo.org> makepp-1.18.ebuild:
+ Initial import, requested in bug 4191
+
diff --git a/sys-devel/makepp/Manifest b/sys-devel/makepp/Manifest
new file mode 100644
index 000000000000..e3b8e2161d90
--- /dev/null
+++ b/sys-devel/makepp/Manifest
@@ -0,0 +1,4 @@
+MD5 34b8b9fd1cdbb752a55b3e1e7d06731d makepp-1.18.ebuild 1015
+MD5 bc57a180b17f86dcb80567e65611a0eb ChangeLog 332
+MD5 654d2795cdd9a6ae279129f7d191cae3 files/makepp-1.18-install.patch 2499
+MD5 083fda7b26387aa8eb168a509be56113 files/digest-makepp-1.18 63
diff --git a/sys-devel/makepp/files/digest-makepp-1.18 b/sys-devel/makepp/files/digest-makepp-1.18
new file mode 100644
index 000000000000..b211b9b56555
--- /dev/null
+++ b/sys-devel/makepp/files/digest-makepp-1.18
@@ -0,0 +1 @@
+MD5 0ab4fee5c74482d21bcbf8da3a292b1f makepp-1.18.tar.gz 236990
diff --git a/sys-devel/makepp/files/makepp-1.18-install.patch b/sys-devel/makepp/files/makepp-1.18-install.patch
new file mode 100644
index 000000000000..7d90e2166223
--- /dev/null
+++ b/sys-devel/makepp/files/makepp-1.18-install.patch
@@ -0,0 +1,69 @@
+--- install.pl.orig 2003-02-18 13:15:15.000000000 -0800
++++ install.pl 2003-02-18 13:49:10.000000000 -0800
+@@ -31,9 +31,24 @@
+ #
+ # Now figure out where everything goes:
+ #
+-$prefix = "/usr/local";
++$prefix = shift(@ARGV) ||
++ read_with_prompt( "
++You can specify a prefix directory that will simplify defaults for
++further questions.
++
++What should be the prefix directory [$prefix]? ") ||
++ "/usr/local";
++
++$inst_prefix = shift(@ARGV) ||
++ read_with_prompt( "
++You can specify an install prefix that is prefixed to the runtime
++prefix for the install phase only. This is useful when installing
++into staging directories for packaging systems.
+
+-$bindir = shift(@_) ||
++What should the install prefix be []? ") ||
++ "";
++
++$bindir = shift(@ARGV) ||
+ read_with_prompt("
+ Makepp needs to know where you want to install it and its data files.
+ makepp is written in perl, but there is no particular reason to install
+@@ -43,10 +58,7 @@
+ Where should the makepp executable be installed [$prefix/bin]? ") ||
+ "$prefix/bin";
+
+-$bindir =~ m@(.*)/bin@ and $prefix = $1;
+- # See if a prefix was specified.
+-
+-$datadir = shift @_ || read_with_prompt("
++$datadir = shift @ARGV || read_with_prompt("
+ Makepp has a number of library files that it needs to install somewhere. Some
+ of these are perl modules, but they can't be used by other perl programs, so
+ there's no point in installing them in the perl modules hierarchy; they are
+@@ -55,14 +67,24 @@
+ Where should the library files be installed [$prefix/share/makepp]? ") ||
+ "$prefix/share/makepp";
+
+-$htmldir = shift @_ || read_with_prompt("
++$htmldir = shift @ARGV || read_with_prompt("
+ Where should the HTML documentation be installed?
+ Enter \"none\" if you do not want any documentation installed.
+ HTML documentation directory [$prefix/share/makepp/html]: ") ||
+ "$prefix/share/makepp/html";
+
+-substitute_file("makepp", $bindir, 0755);
+-substitute_file("recursive_makepp", $datadir, 0644);
++substitute_file("makepp", "$inst_prefix/$bindir", 0755);
++substitute_file("recursive_makepp", "$inst_prefix/$datadir", 0644);
++
++if( $inst_prefix ) {
++ $bindir = join( '/', $inst_prefix, $bindir );
++ $datadir = join( '/', $inst_prefix, $datadir );
++ $htmldir = join( '/', $inst_prefix, $htmldir );
++}
++
++print STDERR "bindir now $bindir\n";
++print STDERR "datadir now $datadir\n";
++print STDERR "htmldir now $htmldir\n";
+
+ make_dir("$datadir/Signature");
+ foreach $module (qw(FileInfo FileInfo_makepp MakeEvent Glob Makefile Makesubs Rule
diff --git a/sys-devel/makepp/makepp-1.18.ebuild b/sys-devel/makepp/makepp-1.18.ebuild
new file mode 100644
index 000000000000..41dd9a68a2a3
--- /dev/null
+++ b/sys-devel/makepp/makepp-1.18.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/makepp/makepp-1.18.ebuild,v 1.1 2003/04/27 22:49:19 rac Exp $
+
+DESCRIPTION="GNU make replacement"
+HOMEPAGE="http://makepp.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+IUSE=""
+DEPEND=">=dev-lang/perl-5.6.0"
+
+inherit eutils
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}; epatch ${FILESDIR}/${P}-install.patch
+ # There is a sandbox violation in this test.
+ # In future versions, this ebuild should try to find
+ # a better way of avoiding this, but the current version
+ # appears to have garbage NUL characters all over the test files,
+ # making them complicated to edit.
+ # Robert Coie <rac@gentoo.org> 2002.02.18
+ rm ${S}/makepp_tests/include.test
+}
+
+src_compile() {
+ make test || die
+}
+
+src_install() {
+ perl install.pl /usr ${D} /usr/bin /usr/share/makepp /usr/share/doc/makepp
+}