summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-01-15 01:23:07 +0000
committerMike Frysinger <vapier@gentoo.org>2005-01-15 01:23:07 +0000
commitac692e4f6a15080797d9667f433abf479820151d (patch)
tree47623d5a0030192f0c9f04761b83e507d4f5ec1d /sys-devel
parenttouch die messages and debug output (diff)
downloadgentoo-2-ac692e4f6a15080797d9667f433abf479820151d.tar.gz
gentoo-2-ac692e4f6a15080797d9667f433abf479820151d.tar.bz2
gentoo-2-ac692e4f6a15080797d9667f433abf479820151d.zip
get rid of the broken spec patch for sure and clean up CTARGET usage
(Portage version: 2.0.51-r12)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gcc/files/3.3.4/gcc-3.3.4-spec-env.patch24
-rw-r--r--sys-devel/gcc/files/3.4.1/gcc-3.4.1-spec-env.patch23
-rw-r--r--sys-devel/gcc/gcc-3.3.4-r2.ebuild4
-rw-r--r--sys-devel/gcc/gcc-3.3.5-r1.ebuild11
-rw-r--r--sys-devel/gcc/gcc-3.4.1-r3.ebuild4
-rw-r--r--sys-devel/gcc/gcc-3.4.3-r1.ebuild13
-rw-r--r--sys-devel/gcc/gcc-3.4.3.20050110.ebuild13
-rw-r--r--sys-devel/gcc/gcc-3.4.3.ebuild6
8 files changed, 24 insertions, 74 deletions
diff --git a/sys-devel/gcc/files/3.3.4/gcc-3.3.4-spec-env.patch b/sys-devel/gcc/files/3.3.4/gcc-3.3.4-spec-env.patch
deleted file mode 100644
index 3cf3171d54d5..000000000000
--- a/sys-devel/gcc/files/3.3.4/gcc-3.3.4-spec-env.patch
+++ /dev/null
@@ -1,24 +0,0 @@
---- gcc-3.3.4.orig/gcc/gcc.c 2004-09-19 19:41:03.943656776 +0000
-+++ gcc-3.3.4/gcc/gcc.c 2004-09-19 19:43:16.165555992 +0000
-@@ -6421,6 +6421,21 @@
-
- /* Process any user specified specs in the order given on the command
- line. */
-+
-+ GET_ENVIRONMENT (specs_file, "GCC_SPECS");
-+ if (specs_file)
-+ {
-+ struct user_specs *user = (struct user_specs *)
-+ xmalloc (sizeof (struct user_specs));
-+
-+ user->next = (struct user_specs *) 0;
-+ user->filename = specs_file;
-+ if (user_specs_tail)
-+ user_specs_tail->next = user;
-+ else
-+ user_specs_head = user;
-+ user_specs_tail = user;
-+ }
- for (uptr = user_specs_head; uptr; uptr = uptr->next)
- {
- char *filename = find_a_file (&startfile_prefixes, uptr->filename,
diff --git a/sys-devel/gcc/files/3.4.1/gcc-3.4.1-spec-env.patch b/sys-devel/gcc/files/3.4.1/gcc-3.4.1-spec-env.patch
deleted file mode 100644
index bd1283ce1ca0..000000000000
--- a/sys-devel/gcc/files/3.4.1/gcc-3.4.1-spec-env.patch
+++ /dev/null
@@ -1,23 +0,0 @@
---- gcc-3.4.1.orig/gcc/gcc.c 2004-09-19 19:56:59.264425944 +0000
-+++ gcc-3.4.1/gcc/gcc.c 2004-09-19 20:01:19.101924640 +0000
-@@ -6421,6 +6421,20 @@
-
- /* Process any user specified specs in the order given on the command
- line. */
-+
-+ GET_ENVIRONMENT (specs_file, "GCC_SPECS");
-+ if (specs_file)
-+ {
-+ struct user_specs *user = xmalloc (sizeof (struct user_specs));
-+
-+ user->next = (struct user_specs *) 0;
-+ user->filename = specs_file;
-+ if (user_specs_tail)
-+ user_specs_tail->next = user;
-+ else
-+ user_specs_head = user;
-+ user_specs_tail = user;
-+ }
- for (uptr = user_specs_head; uptr; uptr = uptr->next)
- {
- char *filename = find_a_file (&startfile_prefixes, uptr->filename,
diff --git a/sys-devel/gcc/gcc-3.3.4-r2.ebuild b/sys-devel/gcc/gcc-3.3.4-r2.ebuild
index 3b08bf9f9efe..2253fb7e9c00 100644
--- a/sys-devel/gcc/gcc-3.3.4-r2.ebuild
+++ b/sys-devel/gcc/gcc-3.3.4-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.3.4-r2.ebuild,v 1.13 2005/01/11 13:22:08 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.3.4-r2.ebuild,v 1.14 2005/01/15 01:23:07 vapier Exp $
inherit eutils flag-o-matic libtool gnuconfig versionator
@@ -399,7 +399,7 @@ src_unpack() {
# http://gcc.gnu.org/bugzilla/show_bug.cgi?id=14992 (May 3 2004)
sed -i -e s/HAVE_LD_AS_NEEDED/USE_LD_AS_NEEDED/g ${S}/gcc/config.in
- epatch ${FILESDIR}/3.3.4/gcc-3.3.4-spec-env.patch
+ epatch ${FILESDIR}/gcc-spec-env.patch
cd ${S}
# Fixup libtool to correctly generate .la files with portage
diff --git a/sys-devel/gcc/gcc-3.3.5-r1.ebuild b/sys-devel/gcc/gcc-3.3.5-r1.ebuild
index d02fc91824cd..0807c9d9129a 100644
--- a/sys-devel/gcc/gcc-3.3.5-r1.ebuild
+++ b/sys-devel/gcc/gcc-3.3.5-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.3.5-r1.ebuild,v 1.9 2005/01/11 15:03:21 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.3.5-r1.ebuild,v 1.10 2005/01/15 01:23:07 vapier Exp $
DESCRIPTION="The GNU Compiler Collection. Includes C/C++, java compilers, pie+ssp extensions, Haj Ten Brugge runtime bounds checking"
@@ -67,7 +67,7 @@ SPLIT_SPECS="${SPLIT_SPECS:="true"}"
#GENTOO_PATCH_EXCLUDE=""
#PIEPATCH_EXCLUDE=""
-inherit eutils flag-o-matic libtool gnuconfig toolchain
+inherit toolchain
src_unpack() {
gcc_src_unpack
@@ -85,12 +85,11 @@ src_unpack() {
# 3.3.5 to not compile on some configurations.
epatch ${FILESDIR}/3.3.5/gcc-3.3.5-ffecom_gfrt_basictype-prototype.patch
- einfo "Applying CTARGET based patches: ${CTARGET}"
- case "${CTARGET}" in
- powerpc*-*)
+ case $(tc-arch ${CTARGET}) in
+ ppc)
epatch ${FILESDIR}/3.3.3/gcc333_pre20040408-stack-size.patch
;;
- arm-*)
+ arm)
epatch ${FILESDIR}/3.3.3/gcc333-debian-arm-getoff.patch
epatch ${FILESDIR}/3.3.3/gcc333-debian-arm-ldm.patch
;;
diff --git a/sys-devel/gcc/gcc-3.4.1-r3.ebuild b/sys-devel/gcc/gcc-3.4.1-r3.ebuild
index 390cd01606e2..4386b6118a8f 100644
--- a/sys-devel/gcc/gcc-3.4.1-r3.ebuild
+++ b/sys-devel/gcc/gcc-3.4.1-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.4.1-r3.ebuild,v 1.14 2005/01/11 13:22:08 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.4.1-r3.ebuild,v 1.15 2005/01/15 01:23:07 vapier Exp $
IUSE="static nls bootstrap build multilib gcj gtk fortran objc hardened uclibc n32 n64 emul-linux-x86"
@@ -503,7 +503,7 @@ src_unpack() {
# misc patches that havent made it into a patch tarball yet
epatch ${FILESDIR}/3.4.0/gcc34-reiser4-fix.patch
- epatch ${FILESDIR}/3.4.1/gcc-3.4.1-spec-env.patch
+ epatch ${FILESDIR}/gcc-spec-env.patch
# MIPS is screwed screwed thing - but it's cool!
# I had to add ABI variable, because during bootstrap
diff --git a/sys-devel/gcc/gcc-3.4.3-r1.ebuild b/sys-devel/gcc/gcc-3.4.3-r1.ebuild
index f7e4fe9ea5e6..334909e13977 100644
--- a/sys-devel/gcc/gcc-3.4.3-r1.ebuild
+++ b/sys-devel/gcc/gcc-3.4.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.4.3-r1.ebuild,v 1.15 2005/01/11 13:22:08 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.4.3-r1.ebuild,v 1.16 2005/01/15 01:23:07 vapier Exp $
DESCRIPTION="The GNU Compiler Collection. Includes C/C++, java compilers, pie+ssp extensions, Haj Ten Brugge runtime bounds checking"
@@ -65,12 +65,12 @@ PIE_GLIBC_UNSUPPORTED="hppa"
# whether we should split out specs files for multiple {PIE,SSP}-by-default
# and vanilla configurations.
-SPLIT_SPECS="${SPLIT_SPECS:="true"}"
+SPLIT_SPECS=${SPLIT_SPECS:-true}
#GENTOO_PATCH_EXCLUDE=""
#PIEPATCH_EXCLUDE=""
-inherit eutils flag-o-matic libtool gnuconfig toolchain
+inherit toolchain
src_unpack() {
gcc_src_unpack
@@ -104,9 +104,8 @@ src_unpack() {
epatch ${FILESDIR}/3.4.3/gcc-3.4.3-cross-compile.patch
# If mips, and we DON'T want multilib, then rig gcc to only use n32 OR n64
- einfo "Applying CTARGET based patches: ${CTARGET}"
- case "${CTARGET}" in
- mips*-*)
+ case $(tc-arch ${CTARGET}) in
+ mips)
# If mips, and we DON'T want multilib, then rig gcc to only use n32 OR n64
if use !multilib; then
use n32 && epatch ${FILESDIR}/3.4.1/gcc-3.4.1-mips-n32only.patch
@@ -134,7 +133,7 @@ src_unpack() {
epatch ${FILESDIR}/3.4.2/gcc-3.4.2-mips-ip28_cache_barriers.patch
fi
;;
- x86_64-*)
+ amd64)
if use multilib; then
epatch ${FILESDIR}/3.4.1/gcc-3.4.1-glibc-is-native.patch
cd ${S}/libstdc++-v3
diff --git a/sys-devel/gcc/gcc-3.4.3.20050110.ebuild b/sys-devel/gcc/gcc-3.4.3.20050110.ebuild
index 5a655f9ac9c5..b79d520ff3e5 100644
--- a/sys-devel/gcc/gcc-3.4.3.20050110.ebuild
+++ b/sys-devel/gcc/gcc-3.4.3.20050110.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.4.3.20050110.ebuild,v 1.2 2005/01/11 13:22:08 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.4.3.20050110.ebuild,v 1.3 2005/01/15 01:23:07 vapier Exp $
DESCRIPTION="The GNU Compiler Collection. Includes C/C++, java compilers, pie+ssp extensions, Haj Ten Brugge runtime bounds checking"
@@ -65,12 +65,12 @@ PIE_GLIBC_UNSUPPORTED="hppa"
# whether we should split out specs files for multiple {PIE,SSP}-by-default
# and vanilla configurations.
-SPLIT_SPECS="${SPLIT_SPECS:="true"}"
+SPLIT_SPECS=${SPLIT_SPECS:=true}
#GENTOO_PATCH_EXCLUDE=""
#PIEPATCH_EXCLUDE=""
-inherit eutils flag-o-matic libtool gnuconfig toolchain
+inherit toolchain
src_unpack() {
gcc_src_unpack
@@ -104,9 +104,8 @@ src_unpack() {
epatch ${FILESDIR}/3.4.3/gcc-3.4.3-cross-compile.patch
# If mips, and we DON'T want multilib, then rig gcc to only use n32 OR n64
- einfo "Applying CTARGET based patches: ${CTARGET}"
- case "${CTARGET}" in
- mips*-*)
+ case $(tc-arch ${CTARGET}) in
+ mips)
# If mips, and we DON'T want multilib, then rig gcc to only use n32 OR n64
if use !multilib; then
use n32 && epatch ${FILESDIR}/3.4.1/gcc-3.4.1-mips-n32only.patch
@@ -134,7 +133,7 @@ src_unpack() {
epatch ${FILESDIR}/3.4.2/gcc-3.4.2-mips-ip28_cache_barriers.patch
fi
;;
- x86_64-*)
+ amd64)
if use multilib; then
epatch ${FILESDIR}/3.4.1/gcc-3.4.1-glibc-is-native.patch
cd ${S}/libstdc++-v3
diff --git a/sys-devel/gcc/gcc-3.4.3.ebuild b/sys-devel/gcc/gcc-3.4.3.ebuild
index ee09a341ae72..d07f96e8b051 100644
--- a/sys-devel/gcc/gcc-3.4.3.ebuild
+++ b/sys-devel/gcc/gcc-3.4.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.4.3.ebuild,v 1.17 2005/01/11 13:22:08 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.4.3.ebuild,v 1.18 2005/01/15 01:23:07 vapier Exp $
DESCRIPTION="The GNU Compiler Collection. Includes C/C++, java compilers, pie+ssp extensions, Haj Ten Brugge runtime bounds checking"
@@ -56,9 +56,9 @@ ETYPE="gcc-compiler"
HARDENED_GCC_WORKS="x86 sparc amd64"
#HARDENED_PIE_WORKS="mips ppc"
#HARDENED_SSP_WORKS=""
-SPLIT_SPECS="${SPLIT_SPECS:="true"}"
+SPLIT_SPECS=${SPLIT_SPECS:-true}
-inherit eutils flag-o-matic libtool gnuconfig toolchain
+inherit toolchain
gcc_do_filter_flags() {
strip-flags