summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2012-06-14 16:22:07 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2012-06-14 16:22:07 +0000
commita7d305c42097572028d768c9f5ef272dbe027406 (patch)
tree608e4e9e2e5fc231db6376921388b2a70129c7dd /sys-devel
parentdev-java/tomcat-native: version bump (diff)
downloadgentoo-2-a7d305c42097572028d768c9f5ef272dbe027406.tar.gz
gentoo-2-a7d305c42097572028d768c9f5ef272dbe027406.tar.bz2
gentoo-2-a7d305c42097572028d768c9f5ef272dbe027406.zip
Fix Ivy bridge processors detection with -march=native
(Portage version: 2.2.0_alpha110/cvs/Linux x86_64)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/llvm/ChangeLog6
-rw-r--r--sys-devel/llvm/files/llvm-3.1-ivybridge_support.patch13
-rw-r--r--sys-devel/llvm/llvm-3.1.ebuild3
3 files changed, 20 insertions, 2 deletions
diff --git a/sys-devel/llvm/ChangeLog b/sys-devel/llvm/ChangeLog
index 3b8f14ef11b0..d415c14ff5d4 100644
--- a/sys-devel/llvm/ChangeLog
+++ b/sys-devel/llvm/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-devel/llvm
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/ChangeLog,v 1.83 2012/06/12 17:48:20 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/ChangeLog,v 1.84 2012/06/14 16:22:07 voyageur Exp $
+
+ 14 Jun 2012; Bernard Cafarelli <voyageur@gentoo.org> llvm-3.1.ebuild,
+ +files/llvm-3.1-ivybridge_support.patch:
+ Fix Ivy bridge processors detection with -march=native
12 Jun 2012; Fabian Groffen <grobian@gentoo.org> llvm-3.1.ebuild:
Marked ~x64-macos
diff --git a/sys-devel/llvm/files/llvm-3.1-ivybridge_support.patch b/sys-devel/llvm/files/llvm-3.1-ivybridge_support.patch
new file mode 100644
index 000000000000..a03ec422467c
--- /dev/null
+++ b/sys-devel/llvm/files/llvm-3.1-ivybridge_support.patch
@@ -0,0 +1,13 @@
+--- llvm/trunk/lib/Support/Host.cpp 2012/04/23 22:22:46 155401
++++ llvm/trunk/lib/Support/Host.cpp 2012/04/23 22:41:39 155402
+@@ -230,6 +230,10 @@
+ case 45:
+ return "corei7-avx";
+
++ // Ivy Bridge:
++ case 58:
++ return "core-avx-i";
++
+ case 28: // Intel Atom processor. All processors are manufactured using
+ // the 45 nm process
+ return "atom";
diff --git a/sys-devel/llvm/llvm-3.1.ebuild b/sys-devel/llvm/llvm-3.1.ebuild
index 1c08e0a02988..bf134d783499 100644
--- a/sys-devel/llvm/llvm-3.1.ebuild
+++ b/sys-devel/llvm/llvm-3.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-3.1.ebuild,v 1.5 2012/06/12 17:48:20 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-3.1.ebuild,v 1.6 2012/06/14 16:22:07 voyageur Exp $
EAPI="4"
PYTHON_DEPEND="2"
@@ -97,6 +97,7 @@ src_prepare() {
epatch "${FILESDIR}"/${PN}-2.6-commandguide-nops.patch
epatch "${FILESDIR}"/${PN}-2.9-nodoctargz.patch
epatch "${FILESDIR}"/${PN}-3.0-PPC_macro.patch
+ epatch "${FILESDIR}"/${P}-ivybridge_support.patch
# User patches
epatch_user