summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2010-04-28 08:40:06 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2010-04-28 08:40:06 +0000
commita6871be16691b1a520b4eab885b33aae2da0aed4 (patch)
treee872efdd70ff5bb95eca93921ca3c63dc5ae3893 /sys-devel
parentForce python2 fixing bug #312245 (diff)
downloadgentoo-2-a6871be16691b1a520b4eab885b33aae2da0aed4.tar.gz
gentoo-2-a6871be16691b1a520b4eab885b33aae2da0aed4.tar.bz2
gentoo-2-a6871be16691b1a520b4eab885b33aae2da0aed4.zip
GCC 4.5 support for 2.6, bug #317467
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/clang/ChangeLog6
-rw-r--r--sys-devel/clang/clang-2.6-r3.ebuild4
-rw-r--r--sys-devel/clang/files/clang-2.6-gcc45.patch20
3 files changed, 28 insertions, 2 deletions
diff --git a/sys-devel/clang/ChangeLog b/sys-devel/clang/ChangeLog
index 15ae80a41a8d..c9e22c89e832 100644
--- a/sys-devel/clang/ChangeLog
+++ b/sys-devel/clang/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-devel/clang
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/clang/ChangeLog,v 1.12 2010/04/27 12:08:55 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/clang/ChangeLog,v 1.13 2010/04/28 08:40:06 voyageur Exp $
+
+ 28 Apr 2010; Bernard Cafarelli <voyageur@gentoo.org> clang-2.6-r3.ebuild,
+ +files/clang-2.6-gcc45.patch:
+ GCC 4.5 support for 2.6, bug #317467
*clang-2.7 (27 Apr 2010)
diff --git a/sys-devel/clang/clang-2.6-r3.ebuild b/sys-devel/clang/clang-2.6-r3.ebuild
index 919cd9dc6c73..ded55814727f 100644
--- a/sys-devel/clang/clang-2.6-r3.ebuild
+++ b/sys-devel/clang/clang-2.6-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/clang/clang-2.6-r3.ebuild,v 1.1 2010/04/26 21:46:54 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/clang/clang-2.6-r3.ebuild,v 1.2 2010/04/28 08:40:06 voyageur Exp $
EAPI=2
@@ -62,6 +62,8 @@ src_prepare() {
# Do not force -O3 -fomit-frame-pointer on users, from llvm ebuild
epatch "${FILESDIR}"/llvm-2.6-cflags.patch
+ # GCC 4.5 support, bug #317467
+ epatch "${FILESDIR}"/${P}-gcc45.patch
}
src_configure() {
diff --git a/sys-devel/clang/files/clang-2.6-gcc45.patch b/sys-devel/clang/files/clang-2.6-gcc45.patch
new file mode 100644
index 000000000000..b9f000a498f7
--- /dev/null
+++ b/sys-devel/clang/files/clang-2.6-gcc45.patch
@@ -0,0 +1,20 @@
+--- llvm-2.6/tools/clang/lib/CodeGen/CGObjCGNU.cpp.bak 2010-04-27 15:07:20.000000000 +0300
++++ llvm-2.6/tools/clang/lib/CodeGen/CGObjCGNU.cpp 2010-04-27 15:08:26.000000000 +0300
+@@ -1170,7 +1170,7 @@
+ Elements.push_back(llvm::ConstantInt::get(LongTy, RuntimeVersion));
+ }
+ // sizeof(ModuleTy)
+- llvm::TargetData td = llvm::TargetData::TargetData(&TheModule);
++ llvm::TargetData td = llvm::TargetData(&TheModule);
+ Elements.push_back(llvm::ConstantInt::get(LongTy,
+ td.getTypeSizeInBits(ModuleTy)/8));
+ //FIXME: Should be the path to the file where this module was declared
+@@ -1320,7 +1320,7 @@
+ CGF.EmitBlock(TryHandler);
+
+ // Get the correct versions of the exception handling intrinsics
+- llvm::TargetData td = llvm::TargetData::TargetData(&TheModule);
++ llvm::TargetData td = llvm::TargetData(&TheModule);
+ int PointerWidth = td.getTypeSizeInBits(PtrTy);
+ assert((PointerWidth == 32 || PointerWidth == 64) &&
+ "Can't yet handle exceptions if pointers are not 32 or 64 bits");