summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2002-11-07 19:53:56 +0000
committerMartin Schlemmer <azarah@gentoo.org>2002-11-07 19:53:56 +0000
commit465855352abe0ca62c6cd041e8115ea6602976fe (patch)
tree0a74d42fac36ddb7792670452700d45fe21aa64f /sys-devel
parentremoved ld.so depend (diff)
downloadgentoo-2-465855352abe0ca62c6cd041e8115ea6602976fe.tar.gz
gentoo-2-465855352abe0ca62c6cd041e8115ea6602976fe.tar.bz2
gentoo-2-465855352abe0ca62c6cd041e8115ea6602976fe.zip
fix to only install with ARCH=x86
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/ld.so/ChangeLog8
-rw-r--r--sys-devel/ld.so/files/digest-ld.so-1.9.11-r31
-rw-r--r--sys-devel/ld.so/ld.so-1.9.11-r3.ebuild44
3 files changed, 52 insertions, 1 deletions
diff --git a/sys-devel/ld.so/ChangeLog b/sys-devel/ld.so/ChangeLog
index aa7c92e180aa..b0b6470b32ec 100644
--- a/sys-devel/ld.so/ChangeLog
+++ b/sys-devel/ld.so/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-devel/ld.so
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/ld.so/ChangeLog,v 1.1 2002/02/01 21:53:38 gbevin Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/ld.so/ChangeLog,v 1.2 2002/11/07 19:53:56 azarah Exp $
+
+*ld.so-1.9.11-r3 (7 Nov 2002)
+
+ 7 Nov 2002; Martin Schlemmer <azarah@gentoo.org> :
+
+ Fix ld.so to install only for ARCH=x86, and be a stub for all the rest.
*ld.so-1.9.11-r2 (1 Feb 2002)
diff --git a/sys-devel/ld.so/files/digest-ld.so-1.9.11-r3 b/sys-devel/ld.so/files/digest-ld.so-1.9.11-r3
new file mode 100644
index 000000000000..6cfe0e596f07
--- /dev/null
+++ b/sys-devel/ld.so/files/digest-ld.so-1.9.11-r3
@@ -0,0 +1 @@
+MD5 419b97871a0c5127aceddbd13ccb25c2 ld.so-1.9.11.tar.gz 358278
diff --git a/sys-devel/ld.so/ld.so-1.9.11-r3.ebuild b/sys-devel/ld.so/ld.so-1.9.11-r3.ebuild
new file mode 100644
index 000000000000..2f26e238d898
--- /dev/null
+++ b/sys-devel/ld.so/ld.so-1.9.11-r3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/ld.so/ld.so-1.9.11-r3.ebuild,v 1.1 2002/11/07 19:53:56 azarah Exp $
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="Linux dynamic loader & linker"
+SRC_URI="x86? ( ftp://ftp.ods.com/pub/linux/${P}.tar.gz )"
+HOMEPAGE="http://freshmeat.net/projects/ld.so/"
+
+RDEPEND="sys-libs/lib-compat"
+
+LICENSE="LD.SO"
+SLOT="0"
+KEYWORDS="x86 ppc sparc sparc64 alpha"
+
+src_unpack() {
+
+ if [ "${ARCH}" = "x86" ]
+ then
+ unpack ${A}
+
+ cd ${S}
+ cp instldso.sh instldso.orig
+ sed -e "s:usr/man:usr/share/man:g" \
+ instldso.orig > instldso.sh
+ fi
+}
+
+src_install() {
+
+ if [ "${ARCH}" = "x86" ]
+ then
+ PREFIX=${D} ./instldso.sh --force
+
+ # Remove stuff that comes with glibc
+ rm -rf ${D}/sbin ${D}/usr/bin
+ rm ${D}/usr/share/man/man8/ldconfig*
+
+ preplib /
+
+ dodoc COPYRIGHT README ld-so/example/README*
+ fi
+}
+