summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2015-01-23 13:22:11 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2015-01-23 13:22:11 +0000
commit3db7bd7a9742f0bb0d793153c2276a1d0b68a9bb (patch)
tree6fd461819d1ccd4d24f8cdb24f40f903f7570c55 /sys-devel
parentStable for all wrt bug #535154 (diff)
downloadgentoo-2-3db7bd7a9742f0bb0d793153c2276a1d0b68a9bb.tar.gz
gentoo-2-3db7bd7a9742f0bb0d793153c2276a1d0b68a9bb.tar.bz2
gentoo-2-3db7bd7a9742f0bb0d793153c2276a1d0b68a9bb.zip
Disable warnings as errors for Ocaml tests, bug #537308
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key C74525F2)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/llvm/ChangeLog6
-rw-r--r--sys-devel/llvm/llvm-3.5.1.ebuild4
-rw-r--r--sys-devel/llvm/llvm-9999.ebuild6
3 files changed, 12 insertions, 4 deletions
diff --git a/sys-devel/llvm/ChangeLog b/sys-devel/llvm/ChangeLog
index 41b5668d3fd9..d18bf3c73424 100644
--- a/sys-devel/llvm/ChangeLog
+++ b/sys-devel/llvm/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-devel/llvm
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/ChangeLog,v 1.220 2015/01/21 14:59:19 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/ChangeLog,v 1.221 2015/01/23 13:22:11 voyageur Exp $
+
+ 23 Jan 2015; Bernard Cafarelli <voyageur@gentoo.org> llvm-3.5.1.ebuild,
+ llvm-9999.ebuild:
+ Disable warnings as errors for Ocaml tests, bug #537308
21 Jan 2015; Bernard Cafarelli <voyageur@gentoo.org> llvm-3.5.1.ebuild:
Fix installation with USE=-doc
diff --git a/sys-devel/llvm/llvm-3.5.1.ebuild b/sys-devel/llvm/llvm-3.5.1.ebuild
index 540bf02035c2..827c230dadc1 100644
--- a/sys-devel/llvm/llvm-3.5.1.ebuild
+++ b/sys-devel/llvm/llvm-3.5.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-3.5.1.ebuild,v 1.2 2015/01/21 14:59:19 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-3.5.1.ebuild,v 1.3 2015/01/23 13:22:11 voyageur Exp $
EAPI=5
@@ -146,6 +146,8 @@ src_prepare() {
epatch "${FILESDIR}"/${PN}-3.2-nodoctargz.patch
epatch "${FILESDIR}"/${PN}-3.5-gcc-4.9.patch
epatch "${FILESDIR}"/${PN}-3.5-gentoo-install.patch
+ # Make ocaml warnings non-fatal, bug #537308
+ sed -e "/RUN/s/-warn-error A//" -i test/Bindings/Ocaml/*ml || die
if use clang; then
# Automatically select active system GCC's libraries, bugs #406163 and #417913
diff --git a/sys-devel/llvm/llvm-9999.ebuild b/sys-devel/llvm/llvm-9999.ebuild
index 3c745c0010ed..6623689d905c 100644
--- a/sys-devel/llvm/llvm-9999.ebuild
+++ b/sys-devel/llvm/llvm-9999.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-9999.ebuild,v 1.96 2014/12/31 10:37:36 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-9999.ebuild,v 1.97 2015/01/23 13:22:11 voyageur Exp $
EAPI=5
@@ -146,6 +146,8 @@ src_prepare() {
epatch "${FILESDIR}"/${PN}-3.2-nodoctargz.patch
epatch "${FILESDIR}"/${PN}-3.5-gcc-4.9.patch
epatch "${FILESDIR}"/${PN}-3.6-gentoo-install.patch
+ # Make ocaml warnings non-fatal, bug #537308
+ sed -e "/RUN/s/-warn-error A//" -i test/Bindings/Ocaml/*ml || die
if use clang; then
# Automatically select active system GCC's libraries, bugs #406163 and #417913