summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2011-11-05 16:50:13 +0000
committerFabian Groffen <grobian@gentoo.org>2011-11-05 16:50:13 +0000
commit3c0d61769b67ddfa22d4f54f1c73672fb3a8905b (patch)
tree4e3fa22a5d18da2b0a32a2580a9c797cf92aae5d /sys-devel
parentFix copyright headers and add ChangeLog entry, not sure what went wrong here (diff)
downloadgentoo-2-3c0d61769b67ddfa22d4f54f1c73672fb3a8905b.tar.gz
gentoo-2-3c0d61769b67ddfa22d4f54f1c73672fb3a8905b.tar.bz2
gentoo-2-3c0d61769b67ddfa22d4f54f1c73672fb3a8905b.zip
Bump to version from Developer Tools 4.2
(Portage version: 2.2.01.19572-prefix/cvs/Darwin i386)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gdb-apple/ChangeLog7
-rw-r--r--sys-devel/gdb-apple/gdb-apple-1708.ebuild74
2 files changed, 80 insertions, 1 deletions
diff --git a/sys-devel/gdb-apple/ChangeLog b/sys-devel/gdb-apple/ChangeLog
index f15f21db0faa..1c54f0c96c73 100644
--- a/sys-devel/gdb-apple/ChangeLog
+++ b/sys-devel/gdb-apple/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/gdb-apple
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb-apple/ChangeLog,v 1.16 2011/10/16 10:17:17 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb-apple/ChangeLog,v 1.17 2011/11/05 16:50:13 grobian Exp $
+
+*gdb-apple-1708 (05 Nov 2011)
+
+ 05 Nov 2011; Fabian Groffen <grobian@gentoo.org> +gdb-apple-1708.ebuild:
+ Bump to version from Developer Tools 4.2
16 Oct 2011; Fabian Groffen <grobian@gentoo.org> gdb-apple-768-r1.ebuild,
gdb-apple-1461.ebuild, gdb-apple-1518.ebuild, gdb-apple-1346.ebuild,
diff --git a/sys-devel/gdb-apple/gdb-apple-1708.ebuild b/sys-devel/gdb-apple/gdb-apple-1708.ebuild
new file mode 100644
index 000000000000..27fbf6912c09
--- /dev/null
+++ b/sys-devel/gdb-apple/gdb-apple-1708.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb-apple/gdb-apple-1708.ebuild,v 1.1 2011/11/05 16:50:13 grobian Exp $
+
+EAPI="3"
+
+inherit eutils flag-o-matic
+
+APPLE_PV=${PV}
+DESCRIPTION="Apple branch of the GNU Debugger, Developer Tools 4.2"
+HOMEPAGE="http://sources.redhat.com/gdb/"
+SRC_URI="http://www.opensource.apple.com/darwinsource/tarballs/other/gdb-${APPLE_PV}.tar.gz"
+
+LICENSE="APSL-2 GPL-2"
+SLOT="0"
+
+KEYWORDS="~ppc-macos ~x64-macos ~x86-macos"
+
+IUSE="nls"
+
+RDEPEND=">=sys-libs/ncurses-5.2-r2
+ =dev-db/sqlite-3*"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+S=${WORKDIR}/gdb-${APPLE_PV}/src
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-no-global-gdbinit.patch
+ epatch "${FILESDIR}"/${PN}-768-texinfo.patch
+ epatch "${FILESDIR}"/${PN}-1518-darwin8-9.patch
+ epatch "${FILESDIR}"/${PN}-1705-darwin8-10.patch
+ [[ ${CHOST} == *-darwin8 ]] && epatch "${FILESDIR}"/${PN}-1518-darwin8.patch
+}
+
+src_configure() {
+ replace-flags -O? -O2
+ econf \
+ --disable-werror \
+ --disable-debug-symbols-framework \
+ $(use_enable nls) \
+ || die
+}
+
+src_compile() {
+ # unable to work around parallel make issue
+ emake -j2 || die
+}
+
+src_install() {
+ emake -j2 DESTDIR="${D}" libdir=/nukeme includedir=/nukeme install || die
+ rm -R "${D}"/nukeme || die
+ rm -Rf "${ED}"/usr/${CHOST} || die
+ mv "${ED}"/usr/bin/gdb "${ED}"/
+ rm -f "${ED}"/usr/bin/*
+ mv "${ED}"/gdb "${ED}"/usr/bin/
+}
+
+pkg_postinst() {
+ if [[ ${CHOST} == *-darwin* && ${CHOST#*-darwin} -ge 9 ]] ; then
+ ewarn "Due to increased security measures in 10.5 and up, gdb is"
+ ewarn "not able to get a mach task port when installed by Prefix"
+ ewarn "Portage, unprivileged. To make gdb fully functional you'll"
+ ewarn "have to perform the following steps:"
+ ewarn " % sudo chgrp procmod ${EPREFIX}/usr/bin/gdb"
+ ewarn " % sudo chmod g+s ${EPREFIX}/usr/bin/gdb"
+ fi
+ if use x86-macos || use x64-macos ; then
+ einfo "FSF gdb works on Intel-based OSX platforms, sometimes even"
+ einfo "better than gdb-apple. You can consider installing FSF gdb"
+ einfo "instead of gdb-apple, since the FSF version is surely more"
+ einfo "advanced than this old 6.8 version modified by Apple."
+ fi
+}