summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-06-04 03:42:42 +0000
committerMike Frysinger <vapier@gentoo.org>2005-06-04 03:42:42 +0000
commit3707e05e8ecfeb50d0d845eefe2625f9117f5af7 (patch)
treee130f939ebb473bb71164b6ec71a9da1bae0b57c /sys-devel
parentDont abort if user has a known broken glibc wrt to static compilation #94879. (diff)
downloadgentoo-2-3707e05e8ecfeb50d0d845eefe2625f9117f5af7.tar.gz
gentoo-2-3707e05e8ecfeb50d0d845eefe2625f9117f5af7.tar.bz2
gentoo-2-3707e05e8ecfeb50d0d845eefe2625f9117f5af7.zip
add back in stupid libstdc++-v3 for now
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gcc/gcc-3.3.6.ebuild5
-rw-r--r--sys-devel/gcc/gcc-3.4.4.ebuild5
2 files changed, 6 insertions, 4 deletions
diff --git a/sys-devel/gcc/gcc-3.3.6.ebuild b/sys-devel/gcc/gcc-3.3.6.ebuild
index ec424e917f72..6d7f29381b5a 100644
--- a/sys-devel/gcc/gcc-3.3.6.ebuild
+++ b/sys-devel/gcc/gcc-3.3.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.3.6.ebuild,v 1.7 2005/06/02 23:53:45 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.3.6.ebuild,v 1.8 2005/06/04 03:42:42 vapier Exp $
MAN_VER=""
PATCH_VER="1.2"
@@ -34,7 +34,8 @@ inherit toolchain eutils
DESCRIPTION="The GNU Compiler Collection. Includes C/C++, java compilers, pie+ssp extensions, Haj Ten Brugge runtime bounds checking"
-KEYWORDS="-* ~alpha ~amd64 ~hppa ~x86"
+# ia64 - broken static handling; USE=static emerge busybox
+KEYWORDS="-* ~alpha ~amd64 ~hppa -ia64 ~x86"
# NOTE: we SHOULD be using at least binutils 2.15.90.0.1 everywhere for proper
# .eh_frame ld optimisation and symbol visibility support, but it hasnt been
diff --git a/sys-devel/gcc/gcc-3.4.4.ebuild b/sys-devel/gcc/gcc-3.4.4.ebuild
index 88339e770dbd..531015724905 100644
--- a/sys-devel/gcc/gcc-3.4.4.ebuild
+++ b/sys-devel/gcc/gcc-3.4.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.4.4.ebuild,v 1.8 2005/06/02 23:54:17 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.4.4.ebuild,v 1.9 2005/06/04 03:42:42 vapier Exp $
MAN_VER=""
PATCH_VER="1.2"
@@ -69,7 +69,8 @@ DEPEND="${RDEPEND}
>=sys-devel/bison-1.875
>=sys-devel/binutils-2.14.90.0.8-r1
amd64? ( >=sys-devel/binutils-2.15.90.0.1.1-r1 )"
-PDEPEND="sys-devel/gcc-config"
+PDEPEND="sys-devel/gcc-config
+ !nocxx? ( !mips? ( !ia64? ( !elibc_uclibc? ( !build? ( || ( sys-libs/libstdc++-v3 =sys-devel/gcc-3.3* ) ) ) ) ) )"
src_unpack() {
gcc_src_unpack