summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-04-14 01:24:08 +0000
committerMike Frysinger <vapier@gentoo.org>2012-04-14 01:24:08 +0000
commit326feb0f1d77228e301020f2513d4469d77784f8 (patch)
tree232cacd2225db2f756d4762c92f3ca67a0c24373 /sys-devel
parentRemove old (diff)
downloadgentoo-2-326feb0f1d77228e301020f2513d4469d77784f8.tar.gz
gentoo-2-326feb0f1d77228e301020f2513d4469d77784f8.tar.bz2
gentoo-2-326feb0f1d77228e301020f2513d4469d77784f8.zip
Version bump.
(Portage version: 2.2.0_alpha100/cvs/Linux x86_64)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gcc-config/ChangeLog7
-rw-r--r--sys-devel/gcc-config/gcc-config-1.7.ebuild47
2 files changed, 53 insertions, 1 deletions
diff --git a/sys-devel/gcc-config/ChangeLog b/sys-devel/gcc-config/ChangeLog
index 64d2efdfb614..aeb6978c907d 100644
--- a/sys-devel/gcc-config/ChangeLog
+++ b/sys-devel/gcc-config/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/gcc-config
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/ChangeLog,v 1.208 2012/03/23 18:04:19 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/ChangeLog,v 1.209 2012/04/14 01:24:08 vapier Exp $
+
+*gcc-config-1.7 (14 Apr 2012)
+
+ 14 Apr 2012; Mike Frysinger <vapier@gentoo.org> +gcc-config-1.7.ebuild:
+ Version bump.
23 Mar 2012; Mike Frysinger <vapier@gentoo.org> gcc-config-1.6.ebuild:
Update HOMEPAGE to git repo.
diff --git a/sys-devel/gcc-config/gcc-config-1.7.ebuild b/sys-devel/gcc-config/gcc-config-1.7.ebuild
new file mode 100644
index 000000000000..9b1f41000700
--- /dev/null
+++ b/sys-devel/gcc-config/gcc-config-1.7.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/gcc-config-1.7.ebuild,v 1.1 2012/04/14 01:24:08 vapier Exp $
+
+inherit unpacker toolchain-funcs multilib
+
+DESCRIPTION="utility to manage compilers"
+HOMEPAGE="http://git.overlays.gentoo.org/gitweb/?p=proj/gcc-config.git"
+SRC_URI="mirror://gentoo/${P}.tar.xz
+ http://dev.gentoo.org/~vapier/dist/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE=""
+
+src_compile() {
+ emake CC="$(tc-getCC)" || die
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ PV="${PV}" \
+ SUBLIBDIR="$(get_libdir)" \
+ install || die
+}
+
+pkg_postinst() {
+ # Scrub eselect-compiler remains
+ rm -f "${ROOT}"/etc/env.d/05compiler &
+
+ # Make sure old versions dont exist #79062
+ rm -f "${ROOT}"/usr/sbin/gcc-config &
+
+ # We not longer use the /usr/include/g++-v3 hacks, as
+ # it is not needed ...
+ rm -f "${ROOT}"/usr/include/g++{,-v3} &
+
+ # Do we have a valid multi ver setup ?
+ local x
+ for x in $(gcc-config -C -l 2>/dev/null | awk '$NF == "*" { print $2 }') ; do
+ gcc-config ${x}
+ done
+
+ wait
+}