summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2011-02-26 06:10:05 +0000
committerRyan Hill <dirtyepic@gentoo.org>2011-02-26 06:10:05 +0000
commit282c303a100d0a8fa35d521c0c6e038c6862f72c (patch)
tree547f0fcc97b1483c34f839bc83bdbca140b0bc74 /sys-devel
parentAccept non-alnum ssid (bug #356337) (diff)
downloadgentoo-2-282c303a100d0a8fa35d521c0c6e038c6862f72c.tar.gz
gentoo-2-282c303a100d0a8fa35d521c0c6e038c6862f72c.tar.bz2
gentoo-2-282c303a100d0a8fa35d521c0c6e038c6862f72c.zip
Bump versions.
(Portage version: 2.2.0_alpha25/cvs/Linux x86_64)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/kgcc64/ChangeLog11
-rw-r--r--sys-devel/kgcc64/kgcc64-4.3.5.ebuild48
-rw-r--r--sys-devel/kgcc64/kgcc64-4.4.5.ebuild (renamed from sys-devel/kgcc64/kgcc64-4.3.1.ebuild)9
-rw-r--r--sys-devel/kgcc64/kgcc64-4.5.2.ebuild (renamed from sys-devel/kgcc64/kgcc64-4.3.2.ebuild)7
4 files changed, 67 insertions, 8 deletions
diff --git a/sys-devel/kgcc64/ChangeLog b/sys-devel/kgcc64/ChangeLog
index 8752206e9ad4..37ea4e0e949c 100644
--- a/sys-devel/kgcc64/ChangeLog
+++ b/sys-devel/kgcc64/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for sys-devel/kgcc64
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/kgcc64/ChangeLog,v 1.32 2011/02/06 11:36:05 leio Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/kgcc64/ChangeLog,v 1.33 2011/02/26 06:10:05 dirtyepic Exp $
+
+*kgcc64-4.5.2 (26 Feb 2011)
+*kgcc64-4.4.5 (26 Feb 2011)
+*kgcc64-4.3.5 (26 Feb 2011)
+
+ 26 Feb 2011; Ryan Hill <dirtyepic@gentoo.org> -kgcc64-4.3.1.ebuild,
+ -kgcc64-4.3.2.ebuild, +kgcc64-4.3.5.ebuild, +kgcc64-4.4.5.ebuild,
+ +kgcc64-4.5.2.ebuild:
+ Bump versions.
06 Feb 2011; Mart Raudsepp <leio@gentoo.org> kgcc64-3.4.6.ebuild,
kgcc64-4.1.2.ebuild:
diff --git a/sys-devel/kgcc64/kgcc64-4.3.5.ebuild b/sys-devel/kgcc64/kgcc64-4.3.5.ebuild
new file mode 100644
index 000000000000..1a15ea8a7e19
--- /dev/null
+++ b/sys-devel/kgcc64/kgcc64-4.3.5.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/kgcc64/kgcc64-4.3.5.ebuild,v 1.1 2011/02/26 06:10:05 dirtyepic Exp $
+
+case ${CHOST} in
+ hppa*) CTARGET=hppa64-${CHOST#*-};;
+ mips*) CTARGET=${CHOST/mips/mips64};;
+ powerpc*) CTARGET=${CHOST/powerpc/powerpc64};;
+ s390*) CTARGET=${CHOST/s390/s390x};;
+ sparc*) CTARGET=${CHOST/sparc/sparc64};;
+ i?86*) CTARGET=x86_64-${CHOST#*-};;
+esac
+export CTARGET
+TOOLCHAIN_ALLOWED_LANGS="c"
+GCC_TARGET_NO_MULTILIB=true
+
+PATCH_VER="1.1"
+ETYPE="gcc-compiler"
+GCC_FILESDIR=${FILESDIR/${PN}/gcc}
+
+inherit toolchain eutils
+
+DESCRIPTION="64bit kernel compiler"
+
+# Works on mips and sparc; all other archs, refer to bug #228115
+KEYWORDS="-hppa ~mips ~sparc"
+
+# unlike every other target, hppa has not unified the 32/64 bit
+# ports in binutils yet
+DEPEND="hppa? ( sys-devel/binutils-hppa64 )
+ !sys-devel/gcc-hppa64
+ !sys-devel/gcc-mips64
+ !sys-devel/gcc-powerpc64
+ !sys-devel/gcc-sparc64"
+
+pkg_postinst() {
+ toolchain_pkg_postinst
+
+ cd "${ROOT}"/usr/bin
+ local x
+ for x in gcc cpp ; do
+ cat <<-EOF >${CTARGET%%-*}-linux-${x}
+ #!/bin/sh
+ exec ${CTARGET}-${x} "\$@"
+ EOF
+ chmod a+rx ${CTARGET%%-*}-linux-${x}
+ done
+}
diff --git a/sys-devel/kgcc64/kgcc64-4.3.1.ebuild b/sys-devel/kgcc64/kgcc64-4.4.5.ebuild
index 223825b1218e..dc23c61f8652 100644
--- a/sys-devel/kgcc64/kgcc64-4.3.1.ebuild
+++ b/sys-devel/kgcc64/kgcc64-4.4.5.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/kgcc64/kgcc64-4.3.1.ebuild,v 1.5 2010/07/17 16:23:10 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/kgcc64/kgcc64-4.4.5.ebuild,v 1.1 2011/02/26 06:10:05 dirtyepic Exp $
case ${CHOST} in
hppa*) CTARGET=hppa64-${CHOST#*-};;
@@ -14,7 +14,7 @@ export CTARGET
TOOLCHAIN_ALLOWED_LANGS="c"
GCC_TARGET_NO_MULTILIB=true
-PATCH_VER="1.0"
+PATCH_VER="1.2"
ETYPE="gcc-compiler"
GCC_FILESDIR=${FILESDIR/${PN}/gcc}
@@ -22,7 +22,8 @@ inherit toolchain eutils
DESCRIPTION="64bit kernel compiler"
-KEYWORDS="-hppa" #228115
+# Works on mips and sparc; all other archs, refer to bug #228115
+KEYWORDS="~hppa ~sparc"
# unlike every other target, hppa has not unified the 32/64 bit
# ports in binutils yet
diff --git a/sys-devel/kgcc64/kgcc64-4.3.2.ebuild b/sys-devel/kgcc64/kgcc64-4.5.2.ebuild
index 2a153e11f700..d82e1449f390 100644
--- a/sys-devel/kgcc64/kgcc64-4.3.2.ebuild
+++ b/sys-devel/kgcc64/kgcc64-4.5.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/kgcc64/kgcc64-4.3.2.ebuild,v 1.3 2010/07/17 16:23:10 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/kgcc64/kgcc64-4.5.2.ebuild,v 1.1 2011/02/26 06:10:05 dirtyepic Exp $
case ${CHOST} in
hppa*) CTARGET=hppa64-${CHOST#*-};;
@@ -22,7 +22,8 @@ inherit toolchain eutils
DESCRIPTION="64bit kernel compiler"
-KEYWORDS="-hppa" #228115
+# Works on mips and sparc; all other archs, refer to bug #228115
+KEYWORDS="~hppa ~sparc"
# unlike every other target, hppa has not unified the 32/64 bit
# ports in binutils yet