summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2011-11-09 22:55:22 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2011-11-09 22:55:22 +0000
commit135dab2929a5c0af9f8cb3aaa6d85234fefd0156 (patch)
treea1b7293072a73cb3c96c3f78ff0fcf74ce382682 /sys-devel
parentUpdate rc, some more ebuild cleanups (diff)
downloadgentoo-2-135dab2929a5c0af9f8cb3aaa6d85234fefd0156.tar.gz
gentoo-2-135dab2929a5c0af9f8cb3aaa6d85234fefd0156.tar.bz2
gentoo-2-135dab2929a5c0af9f8cb3aaa6d85234fefd0156.zip
Update rc ebuild and cxx_include_root patch, some more ebuild cleanups
(Portage version: 2.2.0_alpha72/cvs/Linux x86_64)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/clang/ChangeLog9
-rw-r--r--sys-devel/clang/clang-3.0_rc3.ebuild (renamed from sys-devel/clang/clang-3.0_rc1.ebuild)13
-rw-r--r--sys-devel/clang/clang-9999.ebuild3
-rw-r--r--sys-devel/clang/files/clang-3.0-fix_cxx_include_root.patch42
4 files changed, 33 insertions, 34 deletions
diff --git a/sys-devel/clang/ChangeLog b/sys-devel/clang/ChangeLog
index 1f64a43ae591..05b1a38f9697 100644
--- a/sys-devel/clang/ChangeLog
+++ b/sys-devel/clang/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-devel/clang
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/clang/ChangeLog,v 1.44 2011/11/09 15:11:48 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/clang/ChangeLog,v 1.45 2011/11/09 22:55:22 voyageur Exp $
+
+*clang-3.0_rc3 (09 Nov 2011)
+
+ 09 Nov 2011; Bernard Cafarelli <voyageur@gentoo.org> -clang-3.0_rc1.ebuild,
+ +clang-3.0_rc3.ebuild, files/clang-3.0-fix_cxx_include_root.patch,
+ clang-9999.ebuild:
+ Update rc ebuild and cxx_include_root patch, some more ebuild cleanups
*clang-3.0_rc1 (09 Nov 2011)
diff --git a/sys-devel/clang/clang-3.0_rc1.ebuild b/sys-devel/clang/clang-3.0_rc3.ebuild
index 0fee9d7f749a..157b91f2d89f 100644
--- a/sys-devel/clang/clang-3.0_rc1.ebuild
+++ b/sys-devel/clang/clang-3.0_rc3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/clang/clang-3.0_rc1.ebuild,v 1.1 2011/11/09 15:11:48 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/clang/clang-3.0_rc3.ebuild,v 1.1 2011/11/09 22:55:22 voyageur Exp $
EAPI=3
@@ -12,25 +12,22 @@ inherit eutils multilib python
DESCRIPTION="C language family frontend for LLVM"
HOMEPAGE="http://clang.llvm.org/"
# Fetching LLVM as well: see http://llvm.org/bugs/show_bug.cgi?id=4840
-SRC_URI="http://llvm.org/pre-releases/${PV/_rc*}/${PV/3.0_}/sources/llvm-${PV/_}.src.tar.gz
- http://llvm.org/pre-releases/${PV/_rc*}/${PV/3.0_}/sources/${P/_}.src.tar.gz"
+SRC_URI="http://llvm.org/pre-releases/${PV/_rc*}/${PV/3.0_}/llvm-${PV/_}.src.tar.gz
+ http://llvm.org/pre-releases/${PV/_rc*}/${PV/3.0_}/${P/_}.src.tar.gz"
LICENSE="UoI-NCSA"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
IUSE="debug multitarget +static-analyzer +system-cxx-headers test"
-# Note: for LTO support, clang will depend on binutils with gold plugins, and LLVM built after that - http://llvm.org/docs/GoldPlugin.html
DEPEND="static-analyzer? ( dev-lang/perl )"
RDEPEND="~sys-devel/llvm-${PV}[multitarget=]"
-S="${WORKDIR}/llvm-${PV/_}"
+S=${WORKDIR}/llvm-${PV/_}.src
src_prepare() {
- # Leftover in rc1, remove for real release
rm -f "${S}"/tools/clang
-
- mv "${WORKDIR}"/clang-${PV/_} "${S}"/tools/clang || die "clang source directory not found"
+ mv "${WORKDIR}"/clang-${PV/_}.src "${S}"/tools/clang || die "clang source directory move failed"
# Same as llvm doc patches
epatch "${FILESDIR}"/${PN}-2.7-fixdoc.patch
diff --git a/sys-devel/clang/clang-9999.ebuild b/sys-devel/clang/clang-9999.ebuild
index 2d0a787fb792..54834c843b83 100644
--- a/sys-devel/clang/clang-9999.ebuild
+++ b/sys-devel/clang/clang-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/clang/clang-9999.ebuild,v 1.18 2011/11/09 15:11:48 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/clang/clang-9999.ebuild,v 1.19 2011/11/09 22:55:22 voyageur Exp $
EAPI=3
@@ -19,7 +19,6 @@ SLOT="0"
KEYWORDS=""
IUSE="debug multitarget +static-analyzer +system-cxx-headers test"
-# Note: for LTO support, clang will depend on binutils with gold plugins, and LLVM built after that - http://llvm.org/docs/GoldPlugin.html
DEPEND="static-analyzer? ( dev-lang/perl )"
RDEPEND="~sys-devel/llvm-${PV}[multitarget=]"
diff --git a/sys-devel/clang/files/clang-3.0-fix_cxx_include_root.patch b/sys-devel/clang/files/clang-3.0-fix_cxx_include_root.patch
index e0baab13affe..e1beff3f1615 100644
--- a/sys-devel/clang/files/clang-3.0-fix_cxx_include_root.patch
+++ b/sys-devel/clang/files/clang-3.0-fix_cxx_include_root.patch
@@ -1,25 +1,21 @@
Bug #387309
---- llvm/tools/clang/lib/Driver/ToolChains.cpp.orig 2011-10-16 19:27:45.505711873 +0200
-+++ llvm/tools/clang/lib/Driver/ToolChains.cpp 2011-10-16 19:30:22.810705290 +0200
-@@ -1563,15 +1563,16 @@
- // and this function would return
- // CXX_GCC_ROOT/lib/gcc/CXX_INCLUDE_ARCH/CXX_GCC_VER
- if (CxxIncludeRoot != "") {
-- // This is of the form /foo/bar/include/c++/4.5.2/
-+ // This is of the form /usr/lib/gcc/<ARCH>/<Version>/include/g++-v4
- if (CxxIncludeRoot.back() == '/')
- llvm::sys::path::remove_filename(CxxIncludeRoot); // remove the /
-+ llvm::sys::path::remove_filename(CxxIncludeRoot); // remove the g++-v4
-+ llvm::sys::path::remove_filename(CxxIncludeRoot); // remove the include
- StringRef Version = llvm::sys::path::filename(CxxIncludeRoot);
- llvm::sys::path::remove_filename(CxxIncludeRoot); // remove the version
-- llvm::sys::path::remove_filename(CxxIncludeRoot); // remove the c++
-- llvm::sys::path::remove_filename(CxxIncludeRoot); // remove the include
-+ llvm::sys::path::remove_filename(CxxIncludeRoot); // remove the ARCH
- GccInstallPath = CxxIncludeRoot.str();
-- GccInstallPath.append("/lib/gcc/");
-+ GccInstallPath.append("/");
- GccInstallPath.append(CXX_INCLUDE_ARCH);
- GccInstallPath.append("/");
- GccInstallPath.append(Version);
+--- llvm/tools/clang/lib/Driver/ToolChains.cpp.orig 2011-11-09 23:10:04.000000000 +0100
++++ llvm/tools/clang/lib/Driver/ToolChains.cpp 2011-11-09 23:11:04.000000000 +0100
+@@ -1586,12 +1586,13 @@
+ // This is of the form /foo/bar/include/c++/4.5.2/
+ if (CxxIncludeRoot.back() == '/')
+ llvm::sys::path::remove_filename(CxxIncludeRoot); // remove the /
++ llvm::sys::path::remove_filename(CxxIncludeRoot); // remove the g++-v4
++ llvm::sys::path::remove_filename(CxxIncludeRoot); // remove the include
+ StringRef Version = llvm::sys::path::filename(CxxIncludeRoot);
+ llvm::sys::path::remove_filename(CxxIncludeRoot); // remove the version
+- llvm::sys::path::remove_filename(CxxIncludeRoot); // remove the c++
+- llvm::sys::path::remove_filename(CxxIncludeRoot); // remove the include
++ llvm::sys::path::remove_filename(CxxIncludeRoot); // remove the ARCH
+ GccInstallPath = CxxIncludeRoot.str();
+- GccInstallPath.append("/lib/gcc/");
++ GccInstallPath.append("/");
+ GccInstallPath.append(CXX_INCLUDE_ARCH);
+ GccInstallPath.append("/");
+ GccInstallPath.append(Version);