summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-10-05 08:41:29 +0000
committerMike Frysinger <vapier@gentoo.org>2010-10-05 08:41:29 +0000
commitecb9b1a729f1a112d197a9e73527510c977d6253 (patch)
treeb569002fa798c9f79804e21a6f08bd2265d8e94e /sys-devel/sparse
parentVersion bump (diff)
downloadgentoo-2-ecb9b1a729f1a112d197a9e73527510c977d6253.tar.gz
gentoo-2-ecb9b1a729f1a112d197a9e73527510c977d6253.tar.bz2
gentoo-2-ecb9b1a729f1a112d197a9e73527510c977d6253.zip
Clean up ebuilds a bit and make sure compilation happens in src_compile.
(Portage version: 2.2_rc86/cvs/Linux x86_64)
Diffstat (limited to 'sys-devel/sparse')
-rw-r--r--sys-devel/sparse/ChangeLog6
-rw-r--r--sys-devel/sparse/sparse-0.4.2.ebuild27
-rw-r--r--sys-devel/sparse/sparse-9999.ebuild27
3 files changed, 21 insertions, 39 deletions
diff --git a/sys-devel/sparse/ChangeLog b/sys-devel/sparse/ChangeLog
index 892a5675adab..8fc880ec4b0f 100644
--- a/sys-devel/sparse/ChangeLog
+++ b/sys-devel/sparse/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-devel/sparse
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/sparse/ChangeLog,v 1.30 2010/03/02 17:45:26 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/sparse/ChangeLog,v 1.31 2010/10/05 08:41:29 vapier Exp $
+
+ 05 Oct 2010; Mike Frysinger <vapier@gentoo.org> sparse-0.4.2.ebuild,
+ sparse-9999.ebuild:
+ Clean up ebuilds a bit and make sure compilation happens in src_compile.
02 Mar 2010; Doug Goldstein <cardoe@gentoo.org> sparse-0.4.2.ebuild,
sparse-9999.ebuild:
diff --git a/sys-devel/sparse/sparse-0.4.2.ebuild b/sys-devel/sparse/sparse-0.4.2.ebuild
index 3989ac722979..7e28ced9663b 100644
--- a/sys-devel/sparse/sparse-0.4.2.ebuild
+++ b/sys-devel/sparse/sparse-0.4.2.ebuild
@@ -1,22 +1,21 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/sparse/sparse-0.4.2.ebuild,v 1.2 2010/03/02 17:45:26 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/sparse/sparse-0.4.2.ebuild,v 1.3 2010/10/05 08:41:29 vapier Exp $
EAPI="2"
-if [[ ${PV} = *9999* ]]; then
+inherit eutils multilib flag-o-matic toolchain-funcs
+if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="git://git.kernel.org/pub/scm/devel/sparse/sparse.git"
- GIT_ECLASS="git"
+ inherit git
fi
-inherit eutils multilib flag-o-matic ${GIT_ECLASS}
-
DESCRIPTION="C semantic parser"
HOMEPAGE="http://sparse.wiki.kernel.org/index.php/Main_Page"
-if [[ ${PV} = *9999* ]]; then
+if [[ ${PV} == "9999" ]] ; then
SRC_URI=""
- KEYWORDS=""
+ #KEYWORDS=""
else
SRC_URI="mirror://kernel/software/devel/sparse/dist/${P}.tar.bz2"
KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
@@ -26,26 +25,16 @@ LICENSE="OSL-1.1"
SLOT="0"
IUSE=""
-DEPEND=""
-RDEPEND=""
-
src_prepare() {
sed -i \
-e '/^PREFIX=/s:=.*:=/usr:' \
-e "/^LIBDIR=/s:/lib:/$(get_libdir):" \
Makefile || die
append-flags -fno-strict-aliasing
-}
-
-src_configure() {
- :
-}
-
-src_compile() {
- :
+ export MAKEOPTS+=" V=1 CC=$(tc-getCC)"
}
src_install() {
- emake DESTDIR="${D}" install || die "make install failed"
+ emake DESTDIR="${D}" install || die
dodoc FAQ README
}
diff --git a/sys-devel/sparse/sparse-9999.ebuild b/sys-devel/sparse/sparse-9999.ebuild
index 453d62fbbe0e..d375721bc7ba 100644
--- a/sys-devel/sparse/sparse-9999.ebuild
+++ b/sys-devel/sparse/sparse-9999.ebuild
@@ -1,22 +1,21 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/sparse/sparse-9999.ebuild,v 1.4 2010/03/02 17:45:26 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/sparse/sparse-9999.ebuild,v 1.5 2010/10/05 08:41:29 vapier Exp $
EAPI="2"
-if [[ ${PV} = *9999* ]]; then
+inherit eutils multilib flag-o-matic toolchain-funcs
+if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="git://git.kernel.org/pub/scm/devel/sparse/sparse.git"
- GIT_ECLASS="git"
+ inherit git
fi
-inherit eutils multilib flag-o-matic ${GIT_ECLASS}
-
DESCRIPTION="C semantic parser"
HOMEPAGE="http://sparse.wiki.kernel.org/index.php/Main_Page"
-if [[ ${PV} = *9999* ]]; then
+if [[ ${PV} == "9999" ]] ; then
SRC_URI=""
- KEYWORDS=""
+ #KEYWORDS=""
else
SRC_URI="mirror://kernel/software/devel/sparse/dist/${P}.tar.bz2"
KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
@@ -26,26 +25,16 @@ LICENSE="OSL-1.1"
SLOT="0"
IUSE=""
-DEPEND=""
-RDEPEND=""
-
src_prepare() {
sed -i \
-e '/^PREFIX=/s:=.*:=/usr:' \
-e "/^LIBDIR=/s:/lib:/$(get_libdir):" \
Makefile || die
append-flags -fno-strict-aliasing
-}
-
-src_configure() {
- :
-}
-
-src_compile() {
- :
+ export MAKEOPTS+=" V=1 CC=$(tc-getCC)"
}
src_install() {
- emake DESTDIR="${D}" install || die "make install failed"
+ emake DESTDIR="${D}" install || die
dodoc FAQ README
}