summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ostrow <dostrow@gentoo.org>2005-04-07 01:16:20 +0000
committerDaniel Ostrow <dostrow@gentoo.org>2005-04-07 01:16:20 +0000
commit3f531913b526f093a84b2d60c49a93287c03585f (patch)
tree06f9def7aa0b8a240e9e7be1807c83fcefada23d /sys-devel/make
parentDelete the glibc-compat dir since its useless to us #87739. (diff)
downloadgentoo-2-3f531913b526f093a84b2d60c49a93287c03585f.tar.gz
gentoo-2-3f531913b526f093a84b2d60c49a93287c03585f.tar.bz2
gentoo-2-3f531913b526f093a84b2d60c49a93287c03585f.zip
Add patch for ppc64 hardened
(Portage version: 2.0.51.19)
Diffstat (limited to 'sys-devel/make')
-rw-r--r--sys-devel/make/ChangeLog7
-rw-r--r--sys-devel/make/files/make-3.80-ppc64-hardened-clock_gettime.patch12
-rw-r--r--sys-devel/make/make-3.80-r1.ebuild7
3 files changed, 21 insertions, 5 deletions
diff --git a/sys-devel/make/ChangeLog b/sys-devel/make/ChangeLog
index 859ef4b47e11..9fb014f13357 100644
--- a/sys-devel/make/ChangeLog
+++ b/sys-devel/make/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-devel/make
-# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/make/ChangeLog,v 1.21 2004/10/10 03:57:29 vapier Exp $
+# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/make/ChangeLog,v 1.22 2005/04/07 01:16:20 dostrow Exp $
+
+ 06 Apr 2005; Daniel Ostrow <dostrow@gentoo.org> make-3.80-r1.ebuild:
+ Add patch for ppc64 hardened
*make-3.80-r1 (09 Oct 2004)
diff --git a/sys-devel/make/files/make-3.80-ppc64-hardened-clock_gettime.patch b/sys-devel/make/files/make-3.80-ppc64-hardened-clock_gettime.patch
new file mode 100644
index 000000000000..84d4c29930f4
--- /dev/null
+++ b/sys-devel/make/files/make-3.80-ppc64-hardened-clock_gettime.patch
@@ -0,0 +1,12 @@
+--- file.c.orig 2005-04-03 19:48:57.000000000 +0000
++++ file.c 2005-04-03 19:50:12.000000000 +0000
+@@ -576,7 +576,7 @@
+ only one-second resolution. The code below should work, but it's
+ not worth the hassle of debugging it on hosts where it fails. */
+ #if FILE_TIMESTAMP_HI_RES
+-# if HAVE_CLOCK_GETTIME && defined CLOCK_REALTIME
++# if HAVE_CLOCK_GETTIME && defined CLOCK_REALTIME && !defined(__PPC64__)
+ {
+ struct timespec timespec;
+ if (clock_gettime (CLOCK_REALTIME, &timespec) == 0)
+
diff --git a/sys-devel/make/make-3.80-r1.ebuild b/sys-devel/make/make-3.80-r1.ebuild
index d0a68d58d493..19c94a928e1f 100644
--- a/sys-devel/make/make-3.80-r1.ebuild
+++ b/sys-devel/make/make-3.80-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/make/make-3.80-r1.ebuild,v 1.2 2004/11/15 19:02:21 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/make/make-3.80-r1.ebuild,v 1.3 2005/04/07 01:16:20 dostrow Exp $
inherit gnuconfig eutils flag-o-matic
@@ -11,7 +11,7 @@ SRC_URI="ftp://ftp.gnu.org/gnu/make/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 s390 sh sparc x86"
-IUSE="nls static build uclibc"
+IUSE="nls static build uclibc hardened"
DEPEND="virtual/libc
nls? ( sys-devel/gettext )"
@@ -21,6 +21,7 @@ src_unpack() {
unpack ${A}
cd ${S}
epatch ${FILESDIR}/${PV}-memory.patch
+ (use ppc64 && use hardened) && epatch ${FILESDIR}/make-3.80-ppc64-hardened-clock_gettime.patch
# Detect mips and uclibc systems properly
gnuconfig_update
}