summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2011-10-03 13:36:01 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2011-10-03 13:36:01 +0000
commit2cd823c71c220655bbf7ac479950dcb4be287b8b (patch)
tree46af803625bce66daabbe289b32a80c9850d60cf /sys-devel/llvm/llvm-2.9-r2.ebuild
parentUpdate tarball, repacked by upstream. Manage all configure switches. (diff)
downloadgentoo-2-2cd823c71c220655bbf7ac479950dcb4be287b8b.tar.gz
gentoo-2-2cd823c71c220655bbf7ac479950dcb4be287b8b.tar.bz2
gentoo-2-2cd823c71c220655bbf7ac479950dcb4be287b8b.zip
Rename alltargets USE flag to multitarget, bug #382307
(Portage version: 2.2.0_alpha60/cvs/Linux x86_64)
Diffstat (limited to 'sys-devel/llvm/llvm-2.9-r2.ebuild')
-rw-r--r--sys-devel/llvm/llvm-2.9-r2.ebuild10
1 files changed, 4 insertions, 6 deletions
diff --git a/sys-devel/llvm/llvm-2.9-r2.ebuild b/sys-devel/llvm/llvm-2.9-r2.ebuild
index b2837b3d4b5b..27543d5cd22b 100644
--- a/sys-devel/llvm/llvm-2.9-r2.ebuild
+++ b/sys-devel/llvm/llvm-2.9-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-2.9-r2.ebuild,v 1.1 2011/05/23 11:43:47 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-2.9-r2.ebuild,v 1.2 2011/10/03 13:36:01 voyageur Exp $
EAPI="3"
inherit eutils flag-o-matic multilib toolchain-funcs
@@ -12,14 +12,12 @@ SRC_URI="http://llvm.org/releases/${PV}/${P}.tgz"
LICENSE="UoI-NCSA"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
-IUSE="alltargets debug +libffi llvm-gcc ocaml test udis86 vim-syntax"
+IUSE="debug +libffi llvm-gcc multitarget ocaml test udis86 vim-syntax"
DEPEND="dev-lang/perl
>=sys-devel/make-3.79
>=sys-devel/flex-2.5.4
- >=sys-devel/bison-1.28
- !~sys-devel/bison-1.85
- !~sys-devel/bison-1.875
+ >=sys-devel/bison-1.875d
|| ( >=sys-devel/gcc-3.0 >=sys-devel/gcc-apple-4.2.1 )
|| ( >=sys-devel/binutils-2.18 >=sys-devel/binutils-apple-3.2.3 )
libffi? ( dev-util/pkgconfig
@@ -95,7 +93,7 @@ src_configure() {
$(use_enable debug assertions)
$(use_enable debug expensive-checks)"
- if use alltargets; then
+ if use multitarget; then
CONF_FLAGS="${CONF_FLAGS} --enable-targets=all"
else
CONF_FLAGS="${CONF_FLAGS} --enable-targets=host-only"