summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2013-06-10 22:26:20 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2013-06-10 22:26:20 +0000
commit3c0934066d9439250f1fbdff275cdad4213a2b5f (patch)
treec22c94a1cf122ab7c77e0e7beff3316b22d99352 /sys-devel/llvm/llvm-2.8-r2.ebuild
parent3.3_rc bump (diff)
downloadgentoo-2-3c0934066d9439250f1fbdff275cdad4213a2b5f.tar.gz
gentoo-2-3c0934066d9439250f1fbdff275cdad4213a2b5f.tar.bz2
gentoo-2-3c0934066d9439250f1fbdff275cdad4213a2b5f.zip
Allow 2.8 compilation with gcc 4.7, add epatch_user to 2.8/2.9
(Portage version: 2.2.0_alpha179/cvs/Linux x86_64, signed Manifest commit with key C74525F2)
Diffstat (limited to 'sys-devel/llvm/llvm-2.8-r2.ebuild')
-rw-r--r--sys-devel/llvm/llvm-2.8-r2.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/sys-devel/llvm/llvm-2.8-r2.ebuild b/sys-devel/llvm/llvm-2.8-r2.ebuild
index 5d56e499ae4b..c90203623035 100644
--- a/sys-devel/llvm/llvm-2.8-r2.ebuild
+++ b/sys-devel/llvm/llvm-2.8-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-2.8-r2.ebuild,v 1.9 2013/01/03 23:29:51 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-2.8-r2.ebuild,v 1.10 2013/06/10 22:26:20 voyageur Exp $
EAPI="4"
inherit eutils multilib toolchain-funcs
@@ -84,6 +84,12 @@ src_prepare() {
epatch "${FILESDIR}"/${PN}-2.8-darwin8.patch
# Upstream backport, r117774
epatch "${FILESDIR}"/${P}-alignof.patch
+
+ # Additional unistd.h include for GCC 4.7
+ epatch "${FILESDIR}"/${PN}-2.9-gcc4.7.patch
+
+ # User patches
+ epatch_user
}
src_configure() {