summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2004-06-15 03:27:17 +0000
committerAron Griffis <agriffis@gentoo.org>2004-06-15 03:27:17 +0000
commitf72edd1e811157cf993de906bb77201ad806a435 (patch)
treebd7abd331bab7539b2ea6741ebf826a085b9a007 /sys-devel/libperl
parentApplying new patch to fix copy/paste problem with HTML formatting (Manifest r... (diff)
downloadgentoo-2-f72edd1e811157cf993de906bb77201ad806a435.tar.gz
gentoo-2-f72edd1e811157cf993de906bb77201ad806a435.tar.bz2
gentoo-2-f72edd1e811157cf993de906bb77201ad806a435.zip
Fix use invocation
Diffstat (limited to 'sys-devel/libperl')
-rw-r--r--sys-devel/libperl/ChangeLog6
-rw-r--r--sys-devel/libperl/libperl-5.8.2.ebuild16
-rw-r--r--sys-devel/libperl/libperl-5.8.3.ebuild16
3 files changed, 21 insertions, 17 deletions
diff --git a/sys-devel/libperl/ChangeLog b/sys-devel/libperl/ChangeLog
index beafdc7dda08..ad53624b1fab 100644
--- a/sys-devel/libperl/ChangeLog
+++ b/sys-devel/libperl/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-devel/libperl
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/libperl/ChangeLog,v 1.30 2004/06/09 20:16:04 rac Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/libperl/ChangeLog,v 1.31 2004/06/15 03:27:17 agriffis Exp $
+
+ 14 Jun 2004; Aron Griffis <agriffis@gentoo.org> libperl-5.8.2.ebuild,
+ libperl-5.8.3.ebuild:
+ Fix use invocation
09 Jun 2004; Robert Coie <rac@gentoo.org> +files/libperl-5.8.4-noksh.patch,
libperl-5.8.4.ebuild:
diff --git a/sys-devel/libperl/libperl-5.8.2.ebuild b/sys-devel/libperl/libperl-5.8.2.ebuild
index 05a484e59004..6d4543168625 100644
--- a/sys-devel/libperl/libperl-5.8.2.ebuild
+++ b/sys-devel/libperl/libperl-5.8.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/libperl/libperl-5.8.2.ebuild,v 1.11 2004/03/09 00:33:16 rac Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/libperl/libperl-5.8.2.ebuild,v 1.12 2004/06/15 03:27:17 agriffis Exp $
# The basic theory based on comments from Daniel Robbins <drobbins@gentoo.org>.
#
@@ -98,7 +98,7 @@ PDEPEND=">=dev-lang/perl-${PV}"
pkg_setup() {
# I think this should rather be displayed if you *have* 'threads'
# in USE if it could break things ...
- if [ -n "`use threads`" ]
+ if use threads
then
ewarn ""
ewarn "PLEASE NOTE: You are compiling perl-5.8 with"
@@ -142,7 +142,7 @@ src_compile() {
export LC_ALL="C"
local myconf=""
- if [ "`use threads`" ]
+ if use threads
then
einfo "using threads"
mythreading="-multi"
@@ -152,28 +152,28 @@ src_compile() {
myarch="${CHOST%%-*}-linux"
fi
- if [ "`use gdbm`" ]
+ if use gdbm
then
myconf="${myconf} -Di_gdbm"
fi
- if [ "`use berkdb`" ]
+ if use berkdb
then
myconf="${myconf} -Di_db -Di_ndbm"
else
myconf="${myconf} -Ui_db -Ui_ndbm"
fi
- if [ "`use mips`" ]
+ if use mips
then
# this is needed because gcc 3.3-compiled kernels will hang
# the machine trying to run this test - check with `Kumba
# <rac@gentoo.org> 2003.06.26
myconf="${myconf} -Dd_u32align"
fi
- if [ "`use sparc`" ]
+ if use sparc
then
myconf="${myconf} -Ud_longdbl"
fi
- if [ "`use sparc64`" ]
+ if use sparc64
then
myconf="${myconf} -Ud_longdbl"
fi
diff --git a/sys-devel/libperl/libperl-5.8.3.ebuild b/sys-devel/libperl/libperl-5.8.3.ebuild
index b1a802ddbe60..0f312d62d6cd 100644
--- a/sys-devel/libperl/libperl-5.8.3.ebuild
+++ b/sys-devel/libperl/libperl-5.8.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/libperl/libperl-5.8.3.ebuild,v 1.5 2004/04/25 07:57:27 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/libperl/libperl-5.8.3.ebuild,v 1.6 2004/06/15 03:27:17 agriffis Exp $
# The basic theory based on comments from Daniel Robbins <drobbins@gentoo.org>.
#
@@ -98,7 +98,7 @@ PDEPEND=">=dev-lang/perl-${PV}"
pkg_setup() {
# I think this should rather be displayed if you *have* 'threads'
# in USE if it could break things ...
- if [ -n "`use threads`" ]
+ if use threads
then
ewarn ""
ewarn "PLEASE NOTE: You are compiling perl-5.8 with"
@@ -142,7 +142,7 @@ src_compile() {
export LC_ALL="C"
local myconf=""
- if [ "`use threads`" ]
+ if use threads
then
einfo "using threads"
mythreading="-multi"
@@ -152,28 +152,28 @@ src_compile() {
myarch="${CHOST%%-*}-linux"
fi
- if [ "`use gdbm`" ]
+ if use gdbm
then
myconf="${myconf} -Di_gdbm"
fi
- if [ "`use berkdb`" ]
+ if use berkdb
then
myconf="${myconf} -Di_db -Di_ndbm"
else
myconf="${myconf} -Ui_db -Ui_ndbm"
fi
- if [ "`use mips`" ]
+ if use mips
then
# this is needed because gcc 3.3-compiled kernels will hang
# the machine trying to run this test - check with `Kumba
# <rac@gentoo.org> 2003.06.26
myconf="${myconf} -Dd_u32align"
fi
- if [ "`use sparc`" ]
+ if use sparc
then
myconf="${myconf} -Ud_longdbl"
fi
- if [ "`use sparc64`" ]
+ if use sparc64
then
myconf="${myconf} -Ud_longdbl"
fi