summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2014-03-14 05:52:45 +0000
committerMike Frysinger <vapier@gentoo.org>2014-03-14 05:52:45 +0000
commitf8df8dbbf66d82e7d81f626f72955a85f1889214 (patch)
treeb7e7b5bfb11fdb79e17bc0c55871002a75978653 /sys-devel/gdb
parentMark alpha/ia64/m68k/ppc64/s390 stable #501528. (diff)
downloadgentoo-2-f8df8dbbf66d82e7d81f626f72955a85f1889214.tar.gz
gentoo-2-f8df8dbbf66d82e7d81f626f72955a85f1889214.tar.bz2
gentoo-2-f8df8dbbf66d82e7d81f626f72955a85f1889214.zip
Add epatch_user support.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
Diffstat (limited to 'sys-devel/gdb')
-rw-r--r--sys-devel/gdb/ChangeLog6
-rw-r--r--sys-devel/gdb/gdb-7.7.ebuild3
-rw-r--r--sys-devel/gdb/gdb-9999.ebuild3
3 files changed, 9 insertions, 3 deletions
diff --git a/sys-devel/gdb/ChangeLog b/sys-devel/gdb/ChangeLog
index 1c95b7440a0d..ed3c42e66bc6 100644
--- a/sys-devel/gdb/ChangeLog
+++ b/sys-devel/gdb/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-devel/gdb
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/ChangeLog,v 1.263 2014/03/14 05:46:37 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/ChangeLog,v 1.264 2014/03/14 05:52:45 vapier Exp $
+
+ 14 Mar 2014; Mike Frysinger <vapier@gentoo.org> gdb-7.7.ebuild,
+ gdb-9999.ebuild:
+ Add epatch_user support.
14 Mar 2014; Mike Frysinger <vapier@gentoo.org> gdb-7.6.2.ebuild:
Mark alpha/ia64/m68k/ppc64/s390 stable #501528.
diff --git a/sys-devel/gdb/gdb-7.7.ebuild b/sys-devel/gdb/gdb-7.7.ebuild
index d8ca55c4ac55..4ae7ee475b41 100644
--- a/sys-devel/gdb/gdb-7.7.ebuild
+++ b/sys-devel/gdb/gdb-7.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/gdb-7.7.ebuild,v 1.4 2014/03/09 00:04:37 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/gdb-7.7.ebuild,v 1.5 2014/03/14 05:52:45 vapier Exp $
EAPI="4"
PYTHON_COMPAT=( python{2_7,3_3} )
@@ -73,6 +73,7 @@ S=${WORKDIR}/${PN}-${MY_PV}
src_prepare() {
[[ -n ${RPM} ]] && rpm_spec_epatch "${WORKDIR}"/gdb.spec
use vanilla || [[ -n ${PATCH_VER} ]] && EPATCH_SUFFIX="patch" epatch "${WORKDIR}"/patch
+ epatch_user
strip-linguas -u bfd/po opcodes/po
}
diff --git a/sys-devel/gdb/gdb-9999.ebuild b/sys-devel/gdb/gdb-9999.ebuild
index 14655f445118..aec14c4ad5c8 100644
--- a/sys-devel/gdb/gdb-9999.ebuild
+++ b/sys-devel/gdb/gdb-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/gdb-9999.ebuild,v 1.24 2014/03/09 00:04:37 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/gdb-9999.ebuild,v 1.25 2014/03/14 05:52:45 vapier Exp $
EAPI="4"
PYTHON_COMPAT=( python{2_7,3_3} )
@@ -73,6 +73,7 @@ S=${WORKDIR}/${PN}-${MY_PV}
src_prepare() {
[[ -n ${RPM} ]] && rpm_spec_epatch "${WORKDIR}"/gdb.spec
use vanilla || [[ -n ${PATCH_VER} ]] && EPATCH_SUFFIX="patch" epatch "${WORKDIR}"/patch
+ epatch_user
strip-linguas -u bfd/po opcodes/po
}