summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2010-03-05 16:25:26 +0000
committerFabian Groffen <grobian@gentoo.org>2010-03-05 16:25:26 +0000
commit1d445c763ed6501b34ce430709269666f41cc352 (patch)
tree6a0ae7437f5ae8c04ab0b39cbfcce7e29ef00cae /sys-devel/gdb-apple/gdb-apple-1346.ebuild
parentMove package from dev-util to dev-vcs, bug 56967. (diff)
downloadgentoo-2-1d445c763ed6501b34ce430709269666f41cc352.tar.gz
gentoo-2-1d445c763ed6501b34ce430709269666f41cc352.tar.bz2
gentoo-2-1d445c763ed6501b34ce430709269666f41cc352.zip
Convert to EAPI=3
(Portage version: 2.2.00.15738-prefix/cvs/Darwin powerpc)
Diffstat (limited to 'sys-devel/gdb-apple/gdb-apple-1346.ebuild')
-rw-r--r--sys-devel/gdb-apple/gdb-apple-1346.ebuild14
1 files changed, 5 insertions, 9 deletions
diff --git a/sys-devel/gdb-apple/gdb-apple-1346.ebuild b/sys-devel/gdb-apple/gdb-apple-1346.ebuild
index 37f5707b64df..b5738d48bda0 100644
--- a/sys-devel/gdb-apple/gdb-apple-1346.ebuild
+++ b/sys-devel/gdb-apple/gdb-apple-1346.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb-apple/gdb-apple-1346.ebuild,v 1.1 2010/03/04 21:32:45 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb-apple/gdb-apple-1346.ebuild,v 1.2 2010/03/05 16:25:26 grobian Exp $
+
+EAPI="3"
inherit eutils flag-o-matic
@@ -22,10 +24,7 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/gdb-${PV}/src
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
+src_prepare() {
epatch "${FILESDIR}"/${PN}-768-texinfo.patch
[[ ${CHOST} == *-darwin8 ]] && epatch "${FILESDIR}"/${PN}-1344-darwin8.patch
@@ -33,18 +32,15 @@ src_unpack() {
sed -e 's/-Wno-long-double//' -i gdb/config/*/macosx.mh
}
-src_compile() {
+src_configure() {
replace-flags -O? -O2
econf \
--disable-werror \
$(use_enable nls) \
|| die
- emake || die
}
src_install() {
- local ED=${ED-${D}}
-
emake DESTDIR="${D}" libdir=/nukeme includedir=/nukeme install || die
rm -R "${D}"/nukeme || die
rm -Rf "${ED}"/usr/${CHOST} || die