summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Loeser <halcy0n@gentoo.org>2009-05-09 21:26:13 +0000
committerMark Loeser <halcy0n@gentoo.org>2009-05-09 21:26:13 +0000
commite13d1c0b25ea641820aa8a3a72d04cb3c664b450 (patch)
tree5f3d05674869049db6bb42a800502cd2146927d4 /sys-devel/gcc
parentAdding the gcc runtime library exception, which is needed for >=gcc-4.4 (diff)
downloadgentoo-2-e13d1c0b25ea641820aa8a3a72d04cb3c664b450.tar.gz
gentoo-2-e13d1c0b25ea641820aa8a3a72d04cb3c664b450.tar.bz2
gentoo-2-e13d1c0b25ea641820aa8a3a72d04cb3c664b450.zip
Remove a bunch of old versions, and fix some licenses; bug #174474
(Portage version: 2.2_rc33/cvs/Linux i686)
Diffstat (limited to 'sys-devel/gcc')
-rw-r--r--sys-devel/gcc/ChangeLog8
-rw-r--r--sys-devel/gcc/gcc-4.2.4-r1.ebuild4
-rw-r--r--sys-devel/gcc/gcc-4.3.0.ebuild65
-rw-r--r--sys-devel/gcc/gcc-4.3.1-r1.ebuild66
-rw-r--r--sys-devel/gcc/gcc-4.3.1.ebuild66
-rw-r--r--sys-devel/gcc/gcc-4.3.2-r2.ebuild83
-rw-r--r--sys-devel/gcc/gcc-4.3.2-r3.ebuild4
-rw-r--r--sys-devel/gcc/gcc-4.3.2-r4.ebuild4
-rw-r--r--sys-devel/gcc/gcc-4.3.2.ebuild71
-rw-r--r--sys-devel/gcc/gcc-4.3.3-r2.ebuild4
-rw-r--r--sys-devel/gcc/gcc-4.4.0.ebuild4
11 files changed, 17 insertions, 362 deletions
diff --git a/sys-devel/gcc/ChangeLog b/sys-devel/gcc/ChangeLog
index d80147f4e169..8edaf4adaffa 100644
--- a/sys-devel/gcc/ChangeLog
+++ b/sys-devel/gcc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-devel/gcc
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.705 2009/05/07 23:58:32 halcy0n Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.706 2009/05/09 21:26:12 halcy0n Exp $
+
+ 09 May 2009; Mark Loeser <halcy0n@gentoo.org> gcc-4.2.4-r1.ebuild,
+ -gcc-4.3.0.ebuild, -gcc-4.3.1.ebuild, -gcc-4.3.1-r1.ebuild,
+ -gcc-4.3.2.ebuild, -gcc-4.3.2-r2.ebuild, gcc-4.3.2-r3.ebuild,
+ gcc-4.3.2-r4.ebuild, gcc-4.3.3-r2.ebuild, gcc-4.4.0.ebuild:
+ Remove a bunch of old versions, and fix some licenses; bug #174474
07 May 2009; Mark Loeser <halcy0n@gentoo.org> gcc-4.4.0.ebuild,
metadata.xml:
diff --git a/sys-devel/gcc/gcc-4.2.4-r1.ebuild b/sys-devel/gcc/gcc-4.2.4-r1.ebuild
index 5d2d275e8a03..cb4af9d2cbec 100644
--- a/sys-devel/gcc/gcc-4.2.4-r1.ebuild
+++ b/sys-devel/gcc/gcc-4.2.4-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.2.4-r1.ebuild,v 1.3 2009/05/03 00:21:52 halcy0n Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.2.4-r1.ebuild,v 1.4 2009/05/09 21:26:13 halcy0n Exp $
PATCH_VER="1.1"
UCLIBC_VER="1.0"
@@ -15,7 +15,7 @@ inherit toolchain
DESCRIPTION="The GNU Compiler Collection. Includes C/C++, java compilers, pie+ssp extensions, Haj Ten Brugge runtime bounds checking"
-LICENSE="GPL-2 LGPL-2.1"
+LICENSE="GPL-3 LGPL-2.1 libgcc libstdc++"
KEYWORDS="~alpha ~amd64 ~arm hppa ~ia64 ~ppc ~ppc64 ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
RDEPEND=">=sys-libs/zlib-1.1.4
diff --git a/sys-devel/gcc/gcc-4.3.0.ebuild b/sys-devel/gcc/gcc-4.3.0.ebuild
deleted file mode 100644
index 265a0da7909e..000000000000
--- a/sys-devel/gcc/gcc-4.3.0.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.3.0.ebuild,v 1.9 2009/05/03 00:21:52 halcy0n Exp $
-
-PATCH_VER="1.2"
-UCLIBC_VER="1.0"
-
-ETYPE="gcc-compiler"
-
-# whether we should split out specs files for multiple {PIE,SSP}-by-default
-# and vanilla configurations.
-SPLIT_SPECS=no #${SPLIT_SPECS-true} hard disable until #106690 is fixed
-
-inherit toolchain
-
-DESCRIPTION="The GNU Compiler Collection. Includes C/C++, java compilers, pie+ssp extensions, Haj Ten Brugge runtime bounds checking"
-
-LICENSE="GPL-2 LGPL-2.1"
-KEYWORDS="" #~amd64 ~ppc ~ppc64 ~x86 ~ia64
-
-RDEPEND=">=sys-libs/zlib-1.1.4
- >=sys-devel/gcc-config-1.4
- virtual/libiconv
- >=dev-libs/gmp-4.2.1
- >=dev-libs/mpfr-2.3
- !build? (
- gcj? (
- gtk? (
- x11-libs/libXt
- x11-libs/libX11
- x11-libs/libXtst
- x11-proto/xproto
- x11-proto/xextproto
- >=x11-libs/gtk+-2.2
- x11-libs/pango
- )
- >=media-libs/libart_lgpl-2.1
- app-arch/zip
- app-arch/unzip
- )
- >=sys-libs/ncurses-5.2-r2
- nls? ( sys-devel/gettext )
- )"
-DEPEND="${RDEPEND}
- test? ( sys-devel/autogen dev-util/dejagnu )
- >=sys-apps/texinfo-4.2-r4
- >=sys-devel/bison-1.875
- sys-devel/flex
- ppc? ( >=${CATEGORY}/binutils-2.17 )
- ppc64? ( >=${CATEGORY}/binutils-2.17 )
- >=${CATEGORY}/binutils-2.15.94"
-PDEPEND=">=sys-devel/gcc-config-1.4"
-if [[ ${CATEGORY} != cross-* ]] ; then
- PDEPEND="${PDEPEND} elibc_glibc? ( >=sys-libs/glibc-2.6 )"
-fi
-
-src_unpack() {
- gcc_src_unpack
-
- use vanilla && return 0
-
- [[ ${CHOST} == ${CTARGET} ]] && epatch "${FILESDIR}"/gcc-spec-env.patch
-
- [[ ${CTARGET} == *-softfloat-* ]] && epatch "${FILESDIR}"/4.0.2/gcc-4.0.2-softfloat.patch
-}
diff --git a/sys-devel/gcc/gcc-4.3.1-r1.ebuild b/sys-devel/gcc/gcc-4.3.1-r1.ebuild
deleted file mode 100644
index eeba5d8a8348..000000000000
--- a/sys-devel/gcc/gcc-4.3.1-r1.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.3.1-r1.ebuild,v 1.3 2009/05/03 00:21:52 halcy0n Exp $
-
-PATCH_VER="1.1"
-UCLIBC_VER="1.0"
-
-ETYPE="gcc-compiler"
-
-# whether we should split out specs files for multiple {PIE,SSP}-by-default
-# and vanilla configurations.
-SPLIT_SPECS=no #${SPLIT_SPECS-true} hard disable until #106690 is fixed
-
-inherit toolchain
-
-DESCRIPTION="The GNU Compiler Collection. Includes C/C++, java compilers, pie+ssp extensions, Haj Ten Brugge runtime bounds checking"
-
-LICENSE="GPL-2 LGPL-2.1"
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-
-RDEPEND=">=sys-libs/zlib-1.1.4
- >=sys-devel/gcc-config-1.4
- virtual/libiconv
- >=dev-libs/gmp-4.2.1
- >=dev-libs/mpfr-2.3
- !build? (
- gcj? (
- gtk? (
- x11-libs/libXt
- x11-libs/libX11
- x11-libs/libXtst
- x11-proto/xproto
- x11-proto/xextproto
- >=x11-libs/gtk+-2.2
- x11-libs/pango
- )
- >=media-libs/libart_lgpl-2.1
- app-arch/zip
- app-arch/unzip
- )
- >=sys-libs/ncurses-5.2-r2
- nls? ( sys-devel/gettext )
- )"
-DEPEND="${RDEPEND}
- test? ( sys-devel/autogen dev-util/dejagnu )
- >=sys-apps/texinfo-4.2-r4
- >=sys-devel/bison-1.875
- sys-devel/flex
- amd64? ( >=sys-libs/glibc-2.7-r2 )
- ppc? ( >=${CATEGORY}/binutils-2.17 )
- ppc64? ( >=${CATEGORY}/binutils-2.17 )
- >=${CATEGORY}/binutils-2.15.94"
-PDEPEND=">=sys-devel/gcc-config-1.4"
-if [[ ${CATEGORY} != cross-* ]] ; then
- PDEPEND="${PDEPEND} elibc_glibc? ( >=sys-libs/glibc-2.6 )"
-fi
-
-src_unpack() {
- gcc_src_unpack
-
- use vanilla && return 0
-
- [[ ${CHOST} == ${CTARGET} ]] && epatch "${FILESDIR}"/gcc-spec-env.patch
-
- [[ ${CTARGET} == *-softfloat-* ]] && epatch "${FILESDIR}"/4.0.2/gcc-4.0.2-softfloat.patch
-}
diff --git a/sys-devel/gcc/gcc-4.3.1.ebuild b/sys-devel/gcc/gcc-4.3.1.ebuild
deleted file mode 100644
index 04711ad1d228..000000000000
--- a/sys-devel/gcc/gcc-4.3.1.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.3.1.ebuild,v 1.6 2009/05/03 00:21:52 halcy0n Exp $
-
-PATCH_VER="1.0"
-UCLIBC_VER="1.0"
-
-ETYPE="gcc-compiler"
-
-# whether we should split out specs files for multiple {PIE,SSP}-by-default
-# and vanilla configurations.
-SPLIT_SPECS=no #${SPLIT_SPECS-true} hard disable until #106690 is fixed
-
-inherit toolchain
-
-DESCRIPTION="The GNU Compiler Collection. Includes C/C++, java compilers, pie+ssp extensions, Haj Ten Brugge runtime bounds checking"
-
-LICENSE="GPL-2 LGPL-2.1"
-KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-
-RDEPEND=">=sys-libs/zlib-1.1.4
- >=sys-devel/gcc-config-1.4
- virtual/libiconv
- >=dev-libs/gmp-4.2.1
- >=dev-libs/mpfr-2.3
- !build? (
- gcj? (
- gtk? (
- x11-libs/libXt
- x11-libs/libX11
- x11-libs/libXtst
- x11-proto/xproto
- x11-proto/xextproto
- >=x11-libs/gtk+-2.2
- x11-libs/pango
- )
- >=media-libs/libart_lgpl-2.1
- app-arch/zip
- app-arch/unzip
- )
- >=sys-libs/ncurses-5.2-r2
- nls? ( sys-devel/gettext )
- )"
-DEPEND="${RDEPEND}
- test? ( sys-devel/autogen dev-util/dejagnu )
- >=sys-apps/texinfo-4.2-r4
- >=sys-devel/bison-1.875
- sys-devel/flex
- amd64? ( >=sys-libs/glibc-2.7-r2 )
- ppc? ( >=${CATEGORY}/binutils-2.17 )
- ppc64? ( >=${CATEGORY}/binutils-2.17 )
- >=${CATEGORY}/binutils-2.15.94"
-PDEPEND=">=sys-devel/gcc-config-1.4"
-if [[ ${CATEGORY} != cross-* ]] ; then
- PDEPEND="${PDEPEND} elibc_glibc? ( >=sys-libs/glibc-2.6 )"
-fi
-
-src_unpack() {
- gcc_src_unpack
-
- use vanilla && return 0
-
- [[ ${CHOST} == ${CTARGET} ]] && epatch "${FILESDIR}"/gcc-spec-env.patch
-
- [[ ${CTARGET} == *-softfloat-* ]] && epatch "${FILESDIR}"/4.0.2/gcc-4.0.2-softfloat.patch
-}
diff --git a/sys-devel/gcc/gcc-4.3.2-r2.ebuild b/sys-devel/gcc/gcc-4.3.2-r2.ebuild
deleted file mode 100644
index 672edd146f00..000000000000
--- a/sys-devel/gcc/gcc-4.3.2-r2.ebuild
+++ /dev/null
@@ -1,83 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.3.2-r2.ebuild,v 1.7 2009/05/03 00:21:52 halcy0n Exp $
-
-PATCH_VER="1.5"
-UCLIBC_VER="1.0"
-
-ETYPE="gcc-compiler"
-
-# Hardened gcc 4 stuff
-PIE_VER="10.1.5"
-PIE_GCC_VER="4.3.2"
-SPECS_VER="0.9.4"
-SPECS_GCC_VER="4.3.2"
-
-# arch/libc configurations known to be stable or untested with {PIE,SSP,FORTIFY}-by-default
-PIE_GLIBC_STABLE="x86 amd64 ~ppc ~ppc64 ~arm ~sparc"
-PIE_UCLIBC_STABLE="x86 arm"
-#SSP_STABLE="amd64 x86 ppc ppc64 ~arm ~sparc"
-#SSP_UCLIBC_STABLE=""
-
-# whether we should split out specs files for multiple {PIE,SSP}-by-default
-# and vanilla configurations.
-SPLIT_SPECS=no #${SPLIT_SPECS-true} hard disable until #106690 is fixed
-
-inherit toolchain
-
-DESCRIPTION="The GNU Compiler Collection. Includes C/C++, java compilers, pie+ssp extensions, Haj Ten Brugge runtime bounds checking"
-
-LICENSE="GPL-2 LGPL-2.1"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
-
-RDEPEND=">=sys-libs/zlib-1.1.4
- >=sys-devel/gcc-config-1.4
- virtual/libiconv
- >=dev-libs/gmp-4.2.1
- >=dev-libs/mpfr-2.3
- !build? (
- gcj? (
- gtk? (
- x11-libs/libXt
- x11-libs/libX11
- x11-libs/libXtst
- x11-proto/xproto
- x11-proto/xextproto
- >=x11-libs/gtk+-2.2
- x11-libs/pango
- )
- >=media-libs/libart_lgpl-2.1
- app-arch/zip
- app-arch/unzip
- )
- >=sys-libs/ncurses-5.2-r2
- nls? ( sys-devel/gettext )
- )"
-DEPEND="${RDEPEND}
- test? ( sys-devel/autogen dev-util/dejagnu )
- >=sys-apps/texinfo-4.2-r4
- >=sys-devel/bison-1.875
- sys-devel/flex
- amd64? (
- >=sys-libs/glibc-2.7-r2
- multilib? (
- gcj? ( app-emulation/emul-linux-x86-xlibs )
- )
- )
- ppc? ( >=${CATEGORY}/binutils-2.17 )
- ppc64? ( >=${CATEGORY}/binutils-2.17 )
- >=${CATEGORY}/binutils-2.15.94"
-PDEPEND=">=sys-devel/gcc-config-1.4"
-if [[ ${CATEGORY} != cross-* ]] ; then
- PDEPEND="${PDEPEND} elibc_glibc? ( >=sys-libs/glibc-2.6 )"
-fi
-
-src_unpack() {
- gcc_src_unpack
-
- use vanilla && return 0
-
- [[ ${CHOST} == ${CTARGET} ]] && epatch "${FILESDIR}"/gcc-spec-env.patch
-
- [[ ${CTARGET} == *-softfloat-* ]] && epatch "${FILESDIR}"/4.3.2/gcc-4.3.2-softfloat.patch
-}
diff --git a/sys-devel/gcc/gcc-4.3.2-r3.ebuild b/sys-devel/gcc/gcc-4.3.2-r3.ebuild
index de028f462dc9..1187488d3c30 100644
--- a/sys-devel/gcc/gcc-4.3.2-r3.ebuild
+++ b/sys-devel/gcc/gcc-4.3.2-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.3.2-r3.ebuild,v 1.11 2009/05/03 00:21:52 halcy0n Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.3.2-r3.ebuild,v 1.12 2009/05/09 21:26:13 halcy0n Exp $
PATCH_VER="1.6"
UCLIBC_VER="1.0"
@@ -27,7 +27,7 @@ inherit toolchain
DESCRIPTION="The GNU Compiler Collection. Includes C/C++, java compilers, pie+ssp extensions, Haj Ten Brugge runtime bounds checking"
-LICENSE="GPL-2 LGPL-2.1"
+LICENSE="GPL-3 LGPL-2.1 libgcc libstdc++"
KEYWORDS="alpha amd64 ~arm ~hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~x86-fbsd"
RDEPEND=">=sys-libs/zlib-1.1.4
diff --git a/sys-devel/gcc/gcc-4.3.2-r4.ebuild b/sys-devel/gcc/gcc-4.3.2-r4.ebuild
index e4aaa7de5e67..50e2dcdb74bf 100644
--- a/sys-devel/gcc/gcc-4.3.2-r4.ebuild
+++ b/sys-devel/gcc/gcc-4.3.2-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.3.2-r4.ebuild,v 1.2 2009/05/03 00:21:52 halcy0n Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.3.2-r4.ebuild,v 1.3 2009/05/09 21:26:12 halcy0n Exp $
PATCH_VER="1.7"
UCLIBC_VER="1.0"
@@ -27,7 +27,7 @@ inherit toolchain
DESCRIPTION="The GNU Compiler Collection. Includes C/C++, java compilers, pie+ssp extensions, Haj Ten Brugge runtime bounds checking"
-LICENSE="GPL-2 LGPL-2.1"
+LICENSE="GPL-3 LGPL-2.1 libgcc libstdc++"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
RDEPEND=">=sys-libs/zlib-1.1.4
diff --git a/sys-devel/gcc/gcc-4.3.2.ebuild b/sys-devel/gcc/gcc-4.3.2.ebuild
deleted file mode 100644
index 7fbdb661e6f9..000000000000
--- a/sys-devel/gcc/gcc-4.3.2.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.3.2.ebuild,v 1.10 2009/05/03 00:21:52 halcy0n Exp $
-
-PATCH_VER="1.2"
-UCLIBC_VER="1.0"
-
-ETYPE="gcc-compiler"
-
-# whether we should split out specs files for multiple {PIE,SSP}-by-default
-# and vanilla configurations.
-SPLIT_SPECS=no #${SPLIT_SPECS-true} hard disable until #106690 is fixed
-
-inherit toolchain
-
-DESCRIPTION="The GNU Compiler Collection. Includes C/C++, java compilers, pie+ssp extensions, Haj Ten Brugge runtime bounds checking"
-
-LICENSE="GPL-2 LGPL-2.1"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86"
-
-RDEPEND=">=sys-libs/zlib-1.1.4
- >=sys-devel/gcc-config-1.4
- virtual/libiconv
- >=dev-libs/gmp-4.2.1
- >=dev-libs/mpfr-2.3
- !build? (
- gcj? (
- gtk? (
- x11-libs/libXt
- x11-libs/libX11
- x11-libs/libXtst
- x11-proto/xproto
- x11-proto/xextproto
- >=x11-libs/gtk+-2.2
- x11-libs/pango
- )
- >=media-libs/libart_lgpl-2.1
- app-arch/zip
- app-arch/unzip
- )
- >=sys-libs/ncurses-5.2-r2
- nls? ( sys-devel/gettext )
- )"
-DEPEND="${RDEPEND}
- test? ( sys-devel/autogen dev-util/dejagnu )
- >=sys-apps/texinfo-4.2-r4
- >=sys-devel/bison-1.875
- sys-devel/flex
- amd64? (
- >=sys-libs/glibc-2.7-r2
- multilib? (
- gcj? ( app-emulation/emul-linux-x86-xlibs )
- )
- )
- ppc? ( >=${CATEGORY}/binutils-2.17 )
- ppc64? ( >=${CATEGORY}/binutils-2.17 )
- >=${CATEGORY}/binutils-2.15.94"
-PDEPEND=">=sys-devel/gcc-config-1.4"
-if [[ ${CATEGORY} != cross-* ]] ; then
- PDEPEND="${PDEPEND} elibc_glibc? ( >=sys-libs/glibc-2.6 )"
-fi
-
-src_unpack() {
- gcc_src_unpack
-
- use vanilla && return 0
-
- [[ ${CHOST} == ${CTARGET} ]] && epatch "${FILESDIR}"/gcc-spec-env.patch
-
- [[ ${CTARGET} == *-softfloat-* ]] && epatch "${FILESDIR}"/4.3.2/gcc-4.3.2-softfloat.patch
-}
diff --git a/sys-devel/gcc/gcc-4.3.3-r2.ebuild b/sys-devel/gcc/gcc-4.3.3-r2.ebuild
index 3524c2f9f27b..fcfcc9cfc3aa 100644
--- a/sys-devel/gcc/gcc-4.3.3-r2.ebuild
+++ b/sys-devel/gcc/gcc-4.3.3-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.3.3-r2.ebuild,v 1.3 2009/05/03 19:36:55 halcy0n Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.3.3-r2.ebuild,v 1.4 2009/05/09 21:26:12 halcy0n Exp $
GENTOO_PATCH_EXCLUDE="69_all_gcc43-pr39013.patch" #262567
@@ -27,7 +27,7 @@ inherit toolchain
DESCRIPTION="The GNU Compiler Collection. Includes C/C++, java compilers, pie+ssp extensions, Haj Ten Brugge runtime bounds checking"
-LICENSE="GPL-2 LGPL-2.1"
+LICENSE="GPL-3 LGPL-2.1 libgcc libstdc++"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
RDEPEND=">=sys-libs/zlib-1.1.4
diff --git a/sys-devel/gcc/gcc-4.4.0.ebuild b/sys-devel/gcc/gcc-4.4.0.ebuild
index 2591a68d26d4..04df4f802b50 100644
--- a/sys-devel/gcc/gcc-4.4.0.ebuild
+++ b/sys-devel/gcc/gcc-4.4.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.4.0.ebuild,v 1.2 2009/05/07 23:58:32 halcy0n Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.4.0.ebuild,v 1.3 2009/05/09 21:26:12 halcy0n Exp $
PATCH_VER="1.0"
UCLIBC_VER="1.0"
@@ -25,7 +25,7 @@ inherit toolchain
DESCRIPTION="The GNU Compiler Collection. Includes C/C++, java compilers, pie+ssp extensions, Haj Ten Brugge runtime bounds checking"
-LICENSE="GPL-2 LGPL-2.1"
+LICENSE="GPL-3 LGPL-2.1 libgcc libstdc++ gcc-runtime-library-exception-3.1"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
RDEPEND=">=sys-libs/zlib-1.1.4