summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-07-18 05:08:21 +0000
committerMike Frysinger <vapier@gentoo.org>2006-07-18 05:08:21 +0000
commitb3a73164025f3dbc1676bf52ecdb9ae2d0d1d6c3 (patch)
treee4844c1e103f09959b218d997fe018ec558ee501 /sys-devel/gcc
parentAdd ~x86-fbsd keyword. (diff)
downloadgentoo-2-b3a73164025f3dbc1676bf52ecdb9ae2d0d1d6c3.tar.gz
gentoo-2-b3a73164025f3dbc1676bf52ecdb9ae2d0d1d6c3.tar.bz2
gentoo-2-b3a73164025f3dbc1676bf52ecdb9ae2d0d1d6c3.zip
add some more support for USE=vanilla
(Portage version: 2.1.1_pre2-r8)
Diffstat (limited to 'sys-devel/gcc')
-rw-r--r--sys-devel/gcc/gcc-4.0.2-r3.ebuild4
-rw-r--r--sys-devel/gcc/gcc-4.0.3.ebuild4
-rw-r--r--sys-devel/gcc/gcc-4.1.0-r1.ebuild4
-rw-r--r--sys-devel/gcc/gcc-4.1.1.ebuild4
-rw-r--r--sys-devel/gcc/gcc-4.2.0_alpha20060715.ebuild4
5 files changed, 15 insertions, 5 deletions
diff --git a/sys-devel/gcc/gcc-4.0.2-r3.ebuild b/sys-devel/gcc/gcc-4.0.2-r3.ebuild
index da8f712c3144..8e429fb19df8 100644
--- a/sys-devel/gcc/gcc-4.0.2-r3.ebuild
+++ b/sys-devel/gcc/gcc-4.0.2-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.0.2-r3.ebuild,v 1.16 2006/06/30 02:48:38 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.0.2-r3.ebuild,v 1.17 2006/07/18 05:08:21 vapier Exp $
PATCH_VER="1.6"
PATCH_GCC_VER="4.0.2"
@@ -60,6 +60,8 @@ fi
src_unpack() {
gcc_src_unpack
+ use vanilla && return 0
+
[[ ${CHOST} == ${CTARGET} ]] && epatch "${FILESDIR}"/gcc-spec-env.patch
# Fix cross-compiling
diff --git a/sys-devel/gcc/gcc-4.0.3.ebuild b/sys-devel/gcc/gcc-4.0.3.ebuild
index 01426e9bcdcc..fd1e6e7e2811 100644
--- a/sys-devel/gcc/gcc-4.0.3.ebuild
+++ b/sys-devel/gcc/gcc-4.0.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.0.3.ebuild,v 1.9 2006/06/30 02:48:38 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.0.3.ebuild,v 1.10 2006/07/18 05:08:21 vapier Exp $
PATCH_VER="1.3"
UCLIBC_VER="1.0"
@@ -55,6 +55,8 @@ fi
src_unpack() {
gcc_src_unpack
+ use vanilla && return 0
+
[[ ${CHOST} == ${CTARGET} ]] && epatch "${FILESDIR}"/gcc-spec-env.patch
# Fix cross-compiling
diff --git a/sys-devel/gcc/gcc-4.1.0-r1.ebuild b/sys-devel/gcc/gcc-4.1.0-r1.ebuild
index 953611cd2f6a..29e11d849455 100644
--- a/sys-devel/gcc/gcc-4.1.0-r1.ebuild
+++ b/sys-devel/gcc/gcc-4.1.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.1.0-r1.ebuild,v 1.9 2006/06/30 02:48:38 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.1.0-r1.ebuild,v 1.10 2006/07/18 05:08:21 vapier Exp $
PATCH_VER="1.7"
UCLIBC_VER="1.1"
@@ -50,6 +50,8 @@ fi
src_unpack() {
gcc_src_unpack
+ use vanilla && return 0
+
[[ ${CHOST} == ${CTARGET} ]] && epatch "${FILESDIR}"/gcc-spec-env.patch
# Fix cross-compiling
diff --git a/sys-devel/gcc/gcc-4.1.1.ebuild b/sys-devel/gcc/gcc-4.1.1.ebuild
index a9e90031d8c2..82a25e21f08f 100644
--- a/sys-devel/gcc/gcc-4.1.1.ebuild
+++ b/sys-devel/gcc/gcc-4.1.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.1.1.ebuild,v 1.14 2006/06/30 02:48:38 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.1.1.ebuild,v 1.15 2006/07/18 05:08:21 vapier Exp $
PATCH_VER="1.6"
UCLIBC_VER="1.0"
@@ -50,6 +50,8 @@ fi
src_unpack() {
gcc_src_unpack
+ use vanilla && return 0
+
[[ ${CHOST} == ${CTARGET} ]] && epatch "${FILESDIR}"/gcc-spec-env.patch
# Fix cross-compiling
diff --git a/sys-devel/gcc/gcc-4.2.0_alpha20060715.ebuild b/sys-devel/gcc/gcc-4.2.0_alpha20060715.ebuild
index a03651103061..9cfd73659bbb 100644
--- a/sys-devel/gcc/gcc-4.2.0_alpha20060715.ebuild
+++ b/sys-devel/gcc/gcc-4.2.0_alpha20060715.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.2.0_alpha20060715.ebuild,v 1.1 2006/07/15 23:06:55 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.2.0_alpha20060715.ebuild,v 1.2 2006/07/18 05:08:21 vapier Exp $
ETYPE="gcc-compiler"
@@ -48,6 +48,8 @@ pkg_setup() {
src_unpack() {
gcc_src_unpack
+ use vanilla && return 0
+
# Fix cross-compiling
epatch "${FILESDIR}"/4.1.0/gcc-4.1.0-cross-compile.patch
}