summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Loeser <halcy0n@gentoo.org>2006-04-29 21:49:35 +0000
committerMark Loeser <halcy0n@gentoo.org>2006-04-29 21:49:35 +0000
commit78ed19ee36f95cfd4c9c0e18267b4128cb85cedc (patch)
tree0814ed2acd1a95bf0d8e82ea243a7905640084b4 /sys-devel/gcc
parentneed eutils for epatch (diff)
downloadgentoo-2-78ed19ee36f95cfd4c9c0e18267b4128cb85cedc.tar.gz
gentoo-2-78ed19ee36f95cfd4c9c0e18267b4128cb85cedc.tar.bz2
gentoo-2-78ed19ee36f95cfd4c9c0e18267b4128cb85cedc.zip
Weekly 4.2 snapshot bump
(Portage version: 2.1_pre10)
Diffstat (limited to 'sys-devel/gcc')
-rw-r--r--sys-devel/gcc/ChangeLog8
-rw-r--r--sys-devel/gcc/files/digest-gcc-4.2.0_alpha200604293
-rw-r--r--sys-devel/gcc/gcc-4.2.0_alpha20060429.ebuild66
3 files changed, 76 insertions, 1 deletions
diff --git a/sys-devel/gcc/ChangeLog b/sys-devel/gcc/ChangeLog
index e081783e24e8..99e4c7cff7b8 100644
--- a/sys-devel/gcc/ChangeLog
+++ b/sys-devel/gcc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-devel/gcc
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.531 2006/04/28 05:54:52 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.532 2006/04/29 21:49:35 halcy0n Exp $
+
+*gcc-4.2.0_alpha20060429 (29 Apr 2006)
+
+ 29 Apr 2006; Mark Loeser <halcy0n@gentoo.org>
+ -gcc-4.2.0_alpha20060422.ebuild, +gcc-4.2.0_alpha20060429.ebuild:
+ Weekly 4.2 snapshot bump
28 Apr 2006; Markus Rothe <corsair@gentoo.org> gcc-3.4.6-r1.ebuild:
Stable on ppc64
diff --git a/sys-devel/gcc/files/digest-gcc-4.2.0_alpha20060429 b/sys-devel/gcc/files/digest-gcc-4.2.0_alpha20060429
new file mode 100644
index 000000000000..6408b9284409
--- /dev/null
+++ b/sys-devel/gcc/files/digest-gcc-4.2.0_alpha20060429
@@ -0,0 +1,3 @@
+MD5 c3476f0eae95270950febe6e62b8fb57 gcc-4.2-20060429.tar.bz2 38937587
+RMD160 ad3cf968fbb52cd342983169a088b913f31f8684 gcc-4.2-20060429.tar.bz2 38937587
+SHA256 b3019252e3e4ed37e605b6e3d4c956e7b842174ca037de63a41577d026fac4ac gcc-4.2-20060429.tar.bz2 38937587
diff --git a/sys-devel/gcc/gcc-4.2.0_alpha20060429.ebuild b/sys-devel/gcc/gcc-4.2.0_alpha20060429.ebuild
new file mode 100644
index 000000000000..e8624e105b46
--- /dev/null
+++ b/sys-devel/gcc/gcc-4.2.0_alpha20060429.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.2.0_alpha20060429.ebuild,v 1.1 2006/04/29 21:49:35 halcy0n Exp $
+
+ETYPE="gcc-compiler"
+
+inherit toolchain
+
+DESCRIPTION="The GNU Compiler Collection. Includes C/C++, java compilers, pie+ssp extensions, Haj Ten Brugge runtime bounds checking"
+
+LICENSE="GPL-2 LGPL-2.1"
+KEYWORDS="-* ~x86 ~amd64"
+
+RDEPEND=">=sys-libs/zlib-1.1.4
+ || ( app-admin/eselect-compiler >=sys-devel/gcc-config-1.3.12-r4 )
+ virtual/libiconv
+ fortran? (
+ dev-libs/gmp
+ dev-libs/mpfr
+ )
+ !build? (
+ gcj? (
+ gtk? (
+ || ( ( x11-libs/libXt x11-libs/libX11 x11-libs/libXtst x11-proto/xproto x11-proto/xextproto ) virtual/x11 )
+ >=x11-libs/gtk+-2.2
+ x11-libs/pango
+ )
+ >=media-libs/libart_lgpl-2.1
+ )
+ >=sys-libs/ncurses-5.2-r2
+ nls? ( sys-devel/gettext )
+ )"
+if [[ ${CATEGORY} != cross-* ]] ; then
+ RDEPEND="${RDEPEND} elibc_glibc? (
+ hppa? ( >=sys-libs/glibc-2.3.4 ) !hppa? ( >=sys-libs/glibc-2.3.6 )
+ )"
+fi
+DEPEND="${RDEPEND}
+ >=sys-apps/texinfo-4.2-r4
+ >=sys-devel/bison-1.875
+ >=${CATEGORY}/binutils-2.16.1"
+
+PDEPEND="|| ( app-admin/eselect-compiler sys-devel/gcc-config )
+ x86? ( !nocxx? ( !elibc_uclibc? ( !build? ( =virtual/libstdc++-3.3 ) ) ) )"
+
+pkg_setup() {
+ if [[ -z ${I_PROMISE_TO_SUPPLY_PATCHES_WITH_BUGS} ]] ; then
+ die "Please \`export I_PROMISE_TO_SUPPLY_PATCHES_WITH_BUGS=1\` or define it in your make.conf if you want to use this ebuild. This is to try and cut down on people filing bugs for a compiler we do not currently support."
+ fi
+}
+
+src_unpack() {
+ gcc_src_unpack
+
+ # Fix cross-compiling
+ epatch "${FILESDIR}"/4.0.2/gcc-4.0.2-cross-compile.patch
+}
+
+pkg_postinst() {
+ toolchain_pkg_postinst
+
+ einfo "This gcc-4 ebuild is provided for your convenience, and the use"
+ einfo "of this compiler is not supported by the Gentoo Developers."
+ einfo "Please file bugs related to gcc-4 with upstream developers."
+ einfo "Compiler bugs should be filed at http://gcc.gnu.org/bugzilla/"
+}