summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-10-02 11:54:06 +0000
committerMike Frysinger <vapier@gentoo.org>2006-10-02 11:54:06 +0000
commit7f378fc3fe706f77828226576e480d78ea4b455c (patch)
tree31190cab29f46fde52c7e3d46a93e66f2fc293b7 /sys-devel/gcc-config
parentfixed some QA Issues; thanks to Robert Buchholz on bug #149798 (diff)
downloadgentoo-2-7f378fc3fe706f77828226576e480d78ea4b455c.tar.gz
gentoo-2-7f378fc3fe706f77828226576e480d78ea4b455c.tar.bz2
gentoo-2-7f378fc3fe706f77828226576e480d78ea4b455c.zip
Bump to make sure everyone is using gcc-config-1 wrappers and not eselect.
(Portage version: 2.1.2_pre2)
Diffstat (limited to 'sys-devel/gcc-config')
-rw-r--r--sys-devel/gcc-config/ChangeLog8
-rw-r--r--sys-devel/gcc-config/files/digest-gcc-config-1.3.13-r41
-rw-r--r--sys-devel/gcc-config/gcc-config-1.3.13-r4.ebuild51
3 files changed, 59 insertions, 1 deletions
diff --git a/sys-devel/gcc-config/ChangeLog b/sys-devel/gcc-config/ChangeLog
index d3354a53055e..f16ff048c3ec 100644
--- a/sys-devel/gcc-config/ChangeLog
+++ b/sys-devel/gcc-config/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-devel/gcc-config
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/ChangeLog,v 1.130 2006/07/03 18:57:51 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/ChangeLog,v 1.131 2006/10/02 11:54:06 vapier Exp $
+
+*gcc-config-1.3.13-r4 (02 Oct 2006)
+
+ 02 Oct 2006; Mike Frysinger <vapier@gentoo.org>
+ -gcc-config-1.3.13-r3.ebuild, +gcc-config-1.3.13-r4.ebuild:
+ Bump to make sure everyone is using gcc-config-1 wrappers and not eselect.
*gcc-config-1.3.13-r3 (03 Jul 2006)
diff --git a/sys-devel/gcc-config/files/digest-gcc-config-1.3.13-r4 b/sys-devel/gcc-config/files/digest-gcc-config-1.3.13-r4
new file mode 100644
index 000000000000..8b137891791f
--- /dev/null
+++ b/sys-devel/gcc-config/files/digest-gcc-config-1.3.13-r4
@@ -0,0 +1 @@
+
diff --git a/sys-devel/gcc-config/gcc-config-1.3.13-r4.ebuild b/sys-devel/gcc-config/gcc-config-1.3.13-r4.ebuild
new file mode 100644
index 000000000000..9ccdd2960f97
--- /dev/null
+++ b/sys-devel/gcc-config/gcc-config-1.3.13-r4.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/gcc-config-1.3.13-r4.ebuild,v 1.1 2006/10/02 11:54:06 vapier Exp $
+
+inherit toolchain-funcs multilib
+
+# Version of .c wrapper to use
+W_VER="1.4.7"
+
+DESCRIPTION="Utility to change the gcc compiler being used"
+HOMEPAGE="http://www.gentoo.org/"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="!app-admin/eselect-compiler"
+
+S=${WORKDIR}
+
+src_compile() {
+ $(tc-getCC) -O2 -Wall -o wrapper \
+ "${FILESDIR}"/wrapper-${W_VER}.c || die "compile wrapper"
+}
+
+src_install() {
+ newbin "${FILESDIR}"/${PN}-${PV} ${PN} || die "install gcc-config"
+ sed -i \
+ -e "s:PORTAGE-VERSION:${PVR}:g" \
+ -e "s:GENTOO_LIBDIR:$(get_libdir):g" \
+ "${D}"/usr/bin/${PN}
+
+ exeinto /usr/$(get_libdir)/misc
+ newexe wrapper gcc-config || die "install wrapper"
+}
+
+pkg_postinst() {
+ # Do we have a valid multi ver setup ?
+ if gcc-config --get-current-profile &>/dev/null ; then
+ # We not longer use the /usr/include/g++-v3 hacks, as
+ # it is not needed ...
+ [[ -L ${ROOT}/usr/include/g++ ]] && rm -f "${ROOT}"/usr/include/g++
+ [[ -L ${ROOT}/usr/include/g++-v3 ]] && rm -f "${ROOT}"/usr/include/g++-v3
+ [[ ${ROOT} = "/" ]] && gcc-config $(/usr/bin/gcc-config --get-current-profile)
+ fi
+
+ # Make sure old versions dont exist #79062
+ rm -f "${ROOT}"/usr/sbin/gcc-config
+}