summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2014-01-18 19:52:02 +0000
committerMike Frysinger <vapier@gentoo.org>2014-01-18 19:52:02 +0000
commitd6f051458da1026f8eaf6dc34ec08c0db4ecb74c (patch)
treef5d692b13131bd919a32871e1ffd8a4bf86fa0d3 /sys-devel/crossdev
parentStable for alpha, wrt bug #486368 (diff)
downloadgentoo-2-d6f051458da1026f8eaf6dc34ec08c0db4ecb74c.tar.gz
gentoo-2-d6f051458da1026f8eaf6dc34ec08c0db4ecb74c.tar.bz2
gentoo-2-d6f051458da1026f8eaf6dc34ec08c0db4ecb74c.zip
Version bump.
(Portage version: 2.2.8/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
Diffstat (limited to 'sys-devel/crossdev')
-rw-r--r--sys-devel/crossdev/ChangeLog7
-rw-r--r--sys-devel/crossdev/crossdev-20140118.ebuild35
2 files changed, 41 insertions, 1 deletions
diff --git a/sys-devel/crossdev/ChangeLog b/sys-devel/crossdev/ChangeLog
index 087683dc268f..d4da261aebd6 100644
--- a/sys-devel/crossdev/ChangeLog
+++ b/sys-devel/crossdev/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/crossdev
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/crossdev/ChangeLog,v 1.108 2014/01/18 19:51:08 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/crossdev/ChangeLog,v 1.109 2014/01/18 19:52:02 vapier Exp $
+
+*crossdev-20140118 (18 Jan 2014)
+
+ 18 Jan 2014; Mike Frysinger <vapier@gentoo.org> +crossdev-20140118.ebuild:
+ Version bump.
18 Jan 2014; Mike Frysinger <vapier@gentoo.org> crossdev-20131107.ebuild:
Stabilize for all.
diff --git a/sys-devel/crossdev/crossdev-20140118.ebuild b/sys-devel/crossdev/crossdev-20140118.ebuild
new file mode 100644
index 000000000000..0d991cd1ccc3
--- /dev/null
+++ b/sys-devel/crossdev/crossdev-20140118.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/crossdev/crossdev-20140118.ebuild,v 1.1 2014/01/18 19:52:02 vapier Exp $
+
+EAPI="4"
+
+if [[ ${PV} == "99999999" ]] ; then
+ EGIT_REPO_URI="git://git.overlays.gentoo.org/proj/crossdev.git"
+ inherit git-2
+ SRC_URI=""
+ #KEYWORDS=""
+else
+ SRC_URI="mirror://gentoo/${P}.tar.xz
+ http://dev.gentoo.org/~vapier/dist/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+fi
+
+DESCRIPTION="Gentoo Cross-toolchain generator"
+HOMEPAGE="http://www.gentoo.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND=">=sys-apps/portage-2.1
+ app-shells/bash
+ !sys-devel/crossdev-wrappers"
+DEPEND="app-arch/xz-utils"
+
+src_install() {
+ default
+ if [[ "${PV}" == "99999999" ]] ; then
+ sed -i "s:@CDEVPV@:${EGIT_VERSION}:" "${ED}"/usr/bin/crossdev || die
+ fi
+}