summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2013-11-07 20:37:57 +0000
committerMike Frysinger <vapier@gentoo.org>2013-11-07 20:37:57 +0000
commit531cda5d01a5081fb67842d8824c660214de8779 (patch)
tree33049a7780477352c6e06accca5ded66726cd06c /sys-devel/crossdev
parentStabilize for all. (diff)
downloadgentoo-2-531cda5d01a5081fb67842d8824c660214de8779.tar.gz
gentoo-2-531cda5d01a5081fb67842d8824c660214de8779.tar.bz2
gentoo-2-531cda5d01a5081fb67842d8824c660214de8779.zip
Version bump.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key FB7C4156)
Diffstat (limited to 'sys-devel/crossdev')
-rw-r--r--sys-devel/crossdev/ChangeLog7
-rw-r--r--sys-devel/crossdev/crossdev-20131107.ebuild35
2 files changed, 41 insertions, 1 deletions
diff --git a/sys-devel/crossdev/ChangeLog b/sys-devel/crossdev/ChangeLog
index 0216e2640494..925f60c3772d 100644
--- a/sys-devel/crossdev/ChangeLog
+++ b/sys-devel/crossdev/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/crossdev
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/crossdev/ChangeLog,v 1.105 2013/10/11 19:15:56 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/crossdev/ChangeLog,v 1.106 2013/11/07 20:37:57 vapier Exp $
+
+*crossdev-20131107 (07 Nov 2013)
+
+ 07 Nov 2013; Mike Frysinger <vapier@gentoo.org> +crossdev-20131107.ebuild:
+ Version bump.
*crossdev-20131011 (11 Oct 2013)
diff --git a/sys-devel/crossdev/crossdev-20131107.ebuild b/sys-devel/crossdev/crossdev-20131107.ebuild
new file mode 100644
index 000000000000..907bb865855e
--- /dev/null
+++ b/sys-devel/crossdev/crossdev-20131107.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/crossdev/crossdev-20131107.ebuild,v 1.1 2013/11/07 20:37:57 vapier Exp $
+
+EAPI="4"
+
+if [[ ${PV} == "99999999" ]] ; then
+ EGIT_REPO_URI="git://git.overlays.gentoo.org/proj/crossdev.git"
+ inherit git-2
+ SRC_URI=""
+ #KEYWORDS=""
+else
+ SRC_URI="mirror://gentoo/${P}.tar.xz
+ http://dev.gentoo.org/~vapier/dist/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+fi
+
+DESCRIPTION="Gentoo Cross-toolchain generator"
+HOMEPAGE="http://www.gentoo.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND=">=sys-apps/portage-2.1
+ app-shells/bash
+ !sys-devel/crossdev-wrappers"
+DEPEND="app-arch/xz-utils"
+
+src_install() {
+ default
+ if [[ "${PV}" == "99999999" ]] ; then
+ sed -i "s:@CDEVPV@:${EGIT_VERSION}:" "${ED}"/usr/bin/crossdev || die
+ fi
+}