summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-09-07 11:12:14 +0000
committerMichał Górny <mgorny@gentoo.org>2014-09-07 11:12:14 +0000
commit038dea8228cad8354f363f3d840dc2f13b9cf771 (patch)
tree2a0b2afa09bcc08e16ca124479da3e8a1d35e266 /sys-devel/clang/clang-3.5.0-r100.ebuild
parentVersion bump, bug #522188. (diff)
downloadgentoo-2-038dea8228cad8354f363f3d840dc2f13b9cf771.tar.gz
gentoo-2-038dea8228cad8354f363f3d840dc2f13b9cf771.tar.bz2
gentoo-2-038dea8228cad8354f363f3d840dc2f13b9cf771.zip
Version bump, bug #522188.
(Portage version: 2.2.12/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'sys-devel/clang/clang-3.5.0-r100.ebuild')
-rw-r--r--sys-devel/clang/clang-3.5.0-r100.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/sys-devel/clang/clang-3.5.0-r100.ebuild b/sys-devel/clang/clang-3.5.0-r100.ebuild
new file mode 100644
index 000000000000..01f9b5639be8
--- /dev/null
+++ b/sys-devel/clang/clang-3.5.0-r100.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/clang/clang-3.5.0-r100.ebuild,v 1.1 2014/09/07 11:12:14 mgorny Exp $
+
+EAPI=5
+
+inherit multilib-build
+
+DESCRIPTION="C language family frontend for LLVM (meta-ebuild)"
+HOMEPAGE="http://clang.llvm.org/"
+SRC_URI=""
+
+LICENSE="UoI-NCSA"
+SLOT="0/3.5"
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE="debug multitarget python +static-analyzer"
+
+RDEPEND="~sys-devel/llvm-${PV}[clang(-),debug=,multitarget?,python?,static-analyzer,${MULTILIB_USEDEP}]"
+
+# Please keep this package around since it's quite likely that we'll
+# return to separate LLVM & clang ebuilds when the cmake build system
+# is complete.
+
+pkg_postinst() {
+ if has_version ">=dev-util/ccache-3.1.9-r2" ; then
+ #add ccache links as clang might get installed after ccache
+ "${EROOT}"/usr/bin/ccache-config --install-links
+ fi
+}
+
+pkg_postrm() {
+ if has_version ">=dev-util/ccache-3.1.9-r2" && [[ -z ${REPLACED_BY_VERSION} ]]; then
+ # --remove-links would remove all links, --install-links updates them
+ "${EROOT}"/usr/bin/ccache-config --install-links
+ fi
+}