summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2014-09-18 17:36:44 +0000
committerChristoph Junghans <ottxor@gentoo.org>2014-09-18 17:36:44 +0000
commit4f9abc8009b56b8f1ff3d7168b6078cbca57bf40 (patch)
tree7fe58f417e361927a07d5f9d4c20022f3008ce00 /sys-devel/byfl
parentdev-python/sclapp: Fix homepage URL (diff)
downloadgentoo-2-4f9abc8009b56b8f1ff3d7168b6078cbca57bf40.tar.gz
gentoo-2-4f9abc8009b56b8f1ff3d7168b6078cbca57bf40.tar.bz2
gentoo-2-4f9abc8009b56b8f1ff3d7168b6078cbca57bf40.zip
version bump
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key C2000586)
Diffstat (limited to 'sys-devel/byfl')
-rw-r--r--sys-devel/byfl/ChangeLog8
-rw-r--r--sys-devel/byfl/byfl-1.0.ebuild38
-rw-r--r--sys-devel/byfl/byfl-9999.ebuild30
3 files changed, 58 insertions, 18 deletions
diff --git a/sys-devel/byfl/ChangeLog b/sys-devel/byfl/ChangeLog
index 9c05fcbf68d4..ff0c85428673 100644
--- a/sys-devel/byfl/ChangeLog
+++ b/sys-devel/byfl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-devel/byfl
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/byfl/ChangeLog,v 1.5 2014/02/11 15:37:26 ottxor Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/byfl/ChangeLog,v 1.6 2014/09/18 17:36:44 ottxor Exp $
+
+*byfl-1.0 (18 Sep 2014)
+
+ 18 Sep 2014; Christoph Junghans <ottxor@gentoo.org> +byfl-1.0.ebuild,
+ byfl-9999.ebuild:
+ version bump
11 Feb 2014; Christoph Junghans <ottxor@gentoo.org> byfl-9999.ebuild:
llvm bug#18358 got fixed
diff --git a/sys-devel/byfl/byfl-1.0.ebuild b/sys-devel/byfl/byfl-1.0.ebuild
new file mode 100644
index 000000000000..c1aa64c0e044
--- /dev/null
+++ b/sys-devel/byfl/byfl-1.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/byfl/byfl-1.0.ebuild,v 1.1 2014/09/18 17:36:44 ottxor Exp $
+
+EAPI=5
+
+inherit autotools-utils flag-o-matic
+
+if [ "${PV}" = "9999" ]; then
+ EGIT_REPO_URI="git://github.com/losalamos/${PN^b}.git http://github.com/losalamos/${PN}.git"
+ inherit git-2
+ KEYWORDS=""
+ AUTOTOOLS_AUTORECONF=1
+ LLVM_VERSION="9999"
+else
+ LLVM_VERSION="3.5.0"
+ MY_P="${P}-llvm-${LLVM_VERSION}"
+ SRC_URI="https://github.com/losalamos/Byfl/releases/download/v${MY_P#${PN}}/${MY_P}.tar.gz"
+ KEYWORDS="~amd64"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+DESCRIPTION="Compiler-based Application Analysis"
+HOMEPAGE="https://github.com/losalamos/Byfl"
+
+SLOT="0"
+LICENSE="BSD"
+IUSE=""
+
+RDEPEND="~sys-devel/dragonegg-${LLVM_VERSION}
+ ~sys-devel/clang-${LLVM_VERSION}
+ ~sys-devel/llvm-${LLVM_VERSION}"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ append-cxxflags -std=c++11
+ autotools-utils_src_configure
+}
diff --git a/sys-devel/byfl/byfl-9999.ebuild b/sys-devel/byfl/byfl-9999.ebuild
index f90f99f1f1ef..98293b098afc 100644
--- a/sys-devel/byfl/byfl-9999.ebuild
+++ b/sys-devel/byfl/byfl-9999.ebuild
@@ -1,18 +1,23 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/byfl/byfl-9999.ebuild,v 1.5 2014/02/11 15:37:26 ottxor Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/byfl/byfl-9999.ebuild,v 1.6 2014/09/18 17:36:44 ottxor Exp $
EAPI=5
-inherit autotools-utils multilib
+inherit autotools-utils flag-o-matic
if [ "${PV}" = "9999" ]; then
EGIT_REPO_URI="git://github.com/losalamos/${PN^b}.git http://github.com/losalamos/${PN}.git"
inherit git-2
KEYWORDS=""
+ AUTOTOOLS_AUTORECONF=1
+ LLVM_VERSION="9999"
else
- SRC_URI="https://github.com/losalamos/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ LLVM_VERSION="3.5.0"
+ MY_P="${P}-llvm-${LLVM_VERSION}"
+ SRC_URI="https://github.com/losalamos/Byfl/releases/download/v${MY_P#${PN}}/${MY_P}.tar.gz"
KEYWORDS="~amd64"
+ S="${WORKDIR}/${MY_P}"
fi
DESCRIPTION="Compiler-based Application Analysis"
@@ -22,21 +27,12 @@ SLOT="0"
LICENSE="BSD"
IUSE=""
-RDEPEND=">=sys-devel/dragonegg-9999
- >=sys-devel/llvm-9999
- >=sys-devel/clang-9999"
+RDEPEND="~sys-devel/dragonegg-${LLVM_VERSION}
+ ~sys-devel/clang-${LLVM_VERSION}
+ ~sys-devel/llvm-${LLVM_VERSION}"
DEPEND="${RDEPEND}"
-src_prepare() {
- ln -s autoconf/configure.ac || die
- eaclocal -I autoconf/m4
- eautoconf
-}
-
src_configure() {
- local myeconfargs=(
- --enable-cxx11
- )
- autotools-utils_src_configure DRAGONEGG=/usr/$(get_libdir)/dragonegg.so
- MAKEOPTS+=" VERBOSE=1 LOPT=$(type -p opt)"
+ append-cxxflags -std=c++11
+ autotools-utils_src_configure
}