summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2002-10-14 18:36:36 +0000
committerMartin Schlemmer <azarah@gentoo.org>2002-10-14 18:36:36 +0000
commitf707586945baf4e81a636e765bf7f1700eded622 (patch)
tree58e3f9ea538655b303f90fda1db32731ec9c1486 /sys-devel/binutils
parentnew version (diff)
downloadgentoo-2-f707586945baf4e81a636e765bf7f1700eded622.tar.gz
gentoo-2-f707586945baf4e81a636e765bf7f1700eded622.tar.bz2
gentoo-2-f707586945baf4e81a636e765bf7f1700eded622.zip
cleanup
Diffstat (limited to 'sys-devel/binutils')
-rw-r--r--sys-devel/binutils/binutils-2.13.90.0.8.ebuild140
-rw-r--r--sys-devel/binutils/files/digest-binutils-2.13.90.0.81
2 files changed, 0 insertions, 141 deletions
diff --git a/sys-devel/binutils/binutils-2.13.90.0.8.ebuild b/sys-devel/binutils/binutils-2.13.90.0.8.ebuild
deleted file mode 100644
index 83252766c0c8..000000000000
--- a/sys-devel/binutils/binutils-2.13.90.0.8.ebuild
+++ /dev/null
@@ -1,140 +0,0 @@
-# Copyright 1999-2002 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils/binutils-2.13.90.0.8.ebuild,v 1.2 2002/10/14 18:35:00 azarah Exp $
-
-IUSE="nls bootstrap static build"
-
-# NOTE to Maintainer: ChangeLog states that it no longer use perl to build
-# the manpages, but seems this is incorrect ....
-
-inherit libtool flag-o-matic
-
-# Generate borked binaries. Bug #6730
-filter-flags "-fomit-frame-pointer"
-
-S=${WORKDIR}/${P}
-DESCRIPTION="Tools necessary to build programs"
-SRC_URI="ftp://ftp.kernel.org/pub/linux/devel/binutils/${P}.tar.bz2
- ftp://ftp.kernel.org/pub/linux/devel/binutils/test/${P}.tar.bz2"
-HOMEPAGE="http://sources.redhat.com/binutils/"
-
-SLOT="0"
-LICENSE="GPL-2|LGPL-2"
-KEYWORDS="~x86 ~ppc ~sparc ~sparc64 ~alpha"
-
-DEPEND="virtual/glibc
- >=sys-apps/portage-2.0.21
- nls? ( sys-devel/gettext )
- || ( sys-devel/perl
- ( !build? ( sys-devel/perl ) )
- ( !bootstrap? ( sys-devel/perl ) )
- )"
-# This is a hairy one. Basically depend on sys-devel/perl
-# if "build" or "bootstrap" not in USE.
-
-
-src_compile() {
-
- local myconf=""
- use nls && \
- myconf="${myconf} --without-included-gettext" || \
- myconf="${myconf} --disable-nls"
-
- # Fix /usr/lib/libbfd.la
- elibtoolize --portage
-
- ./configure --enable-shared \
- --enable-64-bit-bfd \
- --prefix=/usr \
- --mandir=/usr/share/man \
- --infodir=/usr/share/info \
- --host=${CHOST} \
- ${myconf} || die
-
- if [ "`use static`" ]
- then
- make headers -C bfd CFLAGS=-O || die
- emake -e LDFLAGS=-all-static || die
- else
- make headers -C bfd CFLAGS=-O || die
- emake || die
- fi
-
- if [ -z "`use build`" ]
- then
- if [ -z "`use bootstrap`" ]
- then
- #nuke the manpages to recreate them (only use this if we have perl)
- find . -name '*.1' -exec rm -f {} \; || :
- fi
- #make the info pages (makeinfo included with gcc is used)
- make info || die
- fi
-}
-
-src_install() {
-
- make prefix=${D}/usr \
- mandir=${D}/usr/share/man \
- infodir=${D}/usr/share/info \
- install || die
-
- insinto /usr/include
- doins include/libiberty.h
-
- #c++filt is included with gcc -- what are these GNU people thinking?
- #but not the manpage, so leave that!
- rm -f ${D}/usr/bin/c++filt #${D}/usr/share/man/man1/c++filt*
-
- # By default strip has a symlink going from /usr/${CHOST}/bin/strip to
- # /usr/bin/strip we should reverse it:
-
- rm ${D}/usr/${CHOST}/bin/strip; mv ${D}/usr/bin/strip ${D}/usr/${CHOST}/bin/strip
- # The strip symlink gets created in the loop below
-
- # By default ar, as, ld, nm, ranlib and strip are in two places; create
- # symlinks. This will reduce the size of the tbz2 significantly. We also
- # move all the stuff in /usr/bin to /usr/${CHOST}/bin and create the
- # appropriate symlinks. Things are cleaner that way.
- cd ${D}/usr/bin
- local x=""
- for x in * strip
- do
- if [ ! -e ../${CHOST}/bin/${x} ]
- then
- mv ${x} ../${CHOST}/bin/${x}
- else
- rm -f ${x}
- fi
- ln -s ../${CHOST}/bin/${x} ${x}
- done
-
- cd ${S}
- if [ -z "`use build`" ]
- then
- make prefix=${D}/usr \
- mandir=${D}/usr/share/man \
- infodir=${D}/usr/share/info \
- install-info || die
-
- dodoc COPYING* README
- docinto bfd
- dodoc bfd/ChangeLog* bfd/COPYING bfd/README bfd/PORTING bfd/TODO
- docinto binutils
- dodoc binutils/ChangeLog binutils/NEWS binutils/README
- docinto gas
- dodoc gas/ChangeLog* gas/CONTRIBUTORS gas/COPYING gas/NEWS gas/README*
- docinto gprof
- dodoc gprof/ChangeLog* gprof/TEST gprof/TODO
- docinto ld
- dodoc ld/ChangeLog* ld/README ld/NEWS ld/TODO
- docinto libiberty
- dodoc libiberty/ChangeLog* libiberty/COPYING.LIB libiberty/README
- docinto opcodes
- dodoc opcodes/ChangeLog*
- # Install pre-generated manpages .. currently we do not ...
- else
- rm -rf ${D}/usr/share/man
- fi
-}
-
diff --git a/sys-devel/binutils/files/digest-binutils-2.13.90.0.8 b/sys-devel/binutils/files/digest-binutils-2.13.90.0.8
deleted file mode 100644
index 67d74a4bf476..000000000000
--- a/sys-devel/binutils/files/digest-binutils-2.13.90.0.8
+++ /dev/null
@@ -1 +0,0 @@
-MD5 c920dbd382a7ab13a656d2bc3e97a968 binutils-2.13.90.0.8.tar.bz2 9600395