summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-05-27 09:56:36 +0000
committerTim Harder <radhermit@gentoo.org>2013-05-27 09:56:36 +0000
commit1954c401cae9ed04d3486d310a020cf8e8f20b58 (patch)
treecaa08e95d2e7eba033119b784c725bf5d9c224f1 /sys-devel/autogen
parentFix build with USE=c++0x and gcc-4.8.0 (bug 465590) (diff)
downloadgentoo-2-1954c401cae9ed04d3486d310a020cf8e8f20b58.tar.gz
gentoo-2-1954c401cae9ed04d3486d310a020cf8e8f20b58.tar.bz2
gentoo-2-1954c401cae9ed04d3486d310a020cf8e8f20b58.zip
Version bump and add static-libs use flag.
(Portage version: 2.2.0_alpha177/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'sys-devel/autogen')
-rw-r--r--sys-devel/autogen/ChangeLog7
-rw-r--r--sys-devel/autogen/autogen-5.17.4.ebuild36
2 files changed, 42 insertions, 1 deletions
diff --git a/sys-devel/autogen/ChangeLog b/sys-devel/autogen/ChangeLog
index b3e94aaed0f8..66eb0da960bc 100644
--- a/sys-devel/autogen/ChangeLog
+++ b/sys-devel/autogen/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/autogen
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/autogen/ChangeLog,v 1.96 2013/05/04 05:26:51 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/autogen/ChangeLog,v 1.97 2013/05/27 09:56:36 radhermit Exp $
+
+*autogen-5.17.4 (27 May 2013)
+
+ 27 May 2013; Tim Harder <radhermit@gentoo.org> +autogen-5.17.4.ebuild:
+ Version bump and add static-libs use flag.
04 May 2013; Mike Frysinger <vapier@gentoo.org> autogen-5.17.3.ebuild,
files/autogen-5.17.3-libintl.patch:
diff --git a/sys-devel/autogen/autogen-5.17.4.ebuild b/sys-devel/autogen/autogen-5.17.4.ebuild
new file mode 100644
index 000000000000..50cb17678206
--- /dev/null
+++ b/sys-devel/autogen/autogen-5.17.4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/autogen/autogen-5.17.4.ebuild,v 1.1 2013/05/27 09:56:36 radhermit Exp $
+
+EAPI="4"
+
+inherit eutils
+
+DESCRIPTION="Program and text file generation"
+HOMEPAGE="http://www.gnu.org/software/autogen/"
+SRC_URI="mirror://gnu/${PN}/rel${PV}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~arm-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="libopts static-libs"
+
+RDEPEND=">=dev-scheme/guile-1.8
+ dev-libs/libxml2"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ # suppress possibly incorrect -R flag
+ export ag_cv_test_ldflags=
+
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ prune_libtool_files
+
+ if ! use libopts ; then
+ rm "${ED}"/usr/share/autogen/libopts-*.tar.gz || die
+ fi
+}