summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2008-04-09 00:54:10 +0000
committerJeroen Roovers <jer@gentoo.org>2008-04-09 00:54:10 +0000
commite39f5adce1a460d7947e41df77e2919cb554e6b3 (patch)
tree87d72ccfe9a25610de47f6fbb5902ca6922463bb /sys-cluster
parentStable for HPPA (bug #216855). (diff)
downloadgentoo-2-e39f5adce1a460d7947e41df77e2919cb554e6b3.tar.gz
gentoo-2-e39f5adce1a460d7947e41df77e2919cb554e6b3.tar.bz2
gentoo-2-e39f5adce1a460d7947e41df77e2919cb554e6b3.zip
Stable for HPPA (maybe bug #216855). Many quoting issues fixed.
(Portage version: 2.1.5_rc2)
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/mpich/ChangeLog5
-rw-r--r--sys-cluster/mpich/mpich-1.2.7_p1.ebuild44
2 files changed, 26 insertions, 23 deletions
diff --git a/sys-cluster/mpich/ChangeLog b/sys-cluster/mpich/ChangeLog
index db502074514d..cdd9caa478a2 100644
--- a/sys-cluster/mpich/ChangeLog
+++ b/sys-cluster/mpich/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-cluster/mpich
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpich/ChangeLog,v 1.38 2008/02/07 10:58:54 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpich/ChangeLog,v 1.39 2008/04/09 00:54:10 jer Exp $
+
+ 09 Apr 2008; Jeroen Roovers <jer@gentoo.org> mpich-1.2.7_p1.ebuild:
+ Stable for HPPA (maybe bug #216855). Many quoting issues fixed.
07 Feb 2008; Raúl Porcel <armin76@gentoo.org> mpich-1.2.7_p1.ebuild:
Add ~alpha wrt #209024
diff --git a/sys-cluster/mpich/mpich-1.2.7_p1.ebuild b/sys-cluster/mpich/mpich-1.2.7_p1.ebuild
index eae801c25278..a041c712b993 100644
--- a/sys-cluster/mpich/mpich-1.2.7_p1.ebuild
+++ b/sys-cluster/mpich/mpich-1.2.7_p1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpich/mpich-1.2.7_p1.ebuild,v 1.14 2008/02/07 10:58:54 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpich/mpich-1.2.7_p1.ebuild,v 1.15 2008/04/09 00:54:10 jer Exp $
inherit autotools eutils
@@ -17,7 +17,7 @@ SRC_URI="ftp://ftp.mcs.anl.gov/pub/mpi/${MY_P}.tar.gz"
LICENSE="as-is"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ppc ppc64 x86"
+KEYWORDS="~alpha ~amd64 hppa ppc ppc64 x86"
IUSE="doc crypt"
RDEPEND="${DEPEND}
@@ -39,18 +39,18 @@ pkg_setup() {
src_unpack() {
unpack ${A}
- cd ${S}
+ cd "${S}"
grep -FrlZ '$(P) ' . | xargs -0 sed -i -e 's/\$(P)//'
# Fix broken romio
- epatch ${FILESDIR}/${PV}-fix-romio-sandbox-breakage.patch
- pushd ${S}/romio
+ epatch "${FILESDIR}"/${PV}-fix-romio-sandbox-breakage.patch
+ pushd "${S}"/romio
rm configure
eautoreconf
popd
- epatch ${FILESDIR}/${PV}-allow-fhs-afs.patch
- pushd ${S}/mpid/server
+ epatch "${FILESDIR}"/${PV}-allow-fhs-afs.patch
+ pushd "${S}"/mpid/server
rm configure
eautoreconf
popd
@@ -85,34 +85,34 @@ src_install() {
# to skip installation of man pages, uncomment following line
# export MPIINSTALL_OPTS=-noman
- ./bin/mpiinstall -echo -prefix=${D}/usr || die
+ ./bin/mpiinstall -echo -prefix="${D}"/usr || die
if use doc; then
dodir /usr/share/doc/${PF}
- mv ${D}/usr/doc/* ${D}/usr/share/doc/${PF}
+ mv "${D}"/usr/doc/* "${D}"/usr/share/doc/${PF}
fi
- rm -rf ${D}/usr/doc/
+ rm -rf "${D}"/usr/doc/
dodir /etc/mpich
- mv ${D}/usr/etc/* ${D}/etc/mpich/
- rmdir ${D}/usr/etc/
+ mv "${D}"/usr/etc/* "${D}"/etc/mpich/
+ rmdir "${D}"/usr/etc/
dodir /usr/share/${PN}
- mv ${D}/usr/examples ${D}/usr/share/${PN}/examples1
- mv ${D}/usr/share/examples ${D}/usr/share/${PN}/examples2
+ mv "${D}"/usr/examples "${D}"/usr/share/${PN}/examples1
+ mv "${D}"/usr/share/examples "${D}"/usr/share/${PN}/examples2
# rm -rf ${D}/usr/local
- rm -f ${D}/usr/man/mandesc
+ rm -f "${D}"/usr/man/mandesc
- mv ${D}/usr/share/{machines*,Makefile.sample} ${D}/usr/share/${PN}
+ mv "${D}"/usr/share/{machines*,Makefile.sample} "${D}"/usr/share/${PN}
dodoc COPYRIGHT README
use doc && \
- mv ${D}/usr/www ${D}/usr/share/doc/${PF}/html || \
- rm -rf ${D}/usr/www
+ mv "${D}"/usr/www "${D}"/usr/share/doc/${PF}/html || \
+ rm -rf "${D}"/usr/www
# Dont let users deinstall without portage
- rm ${D}/usr/sbin/mpiuninstall
+ rm "${D}"/usr/sbin/mpiuninstall
# We dont have a real DESTDIR, so we have to fix all the files
dosed /usr/bin/mpirun /usr/bin/mpiman /usr/sbin/tstmachines
@@ -135,13 +135,13 @@ src_install() {
dosed /usr/share/mpich/upshot/bin/upshot
# Fix datadir; mpich's build system screws it up even though we pass it
- grep -rl 'datadir=.*' ${D} \
+ grep -rl 'datadir=.*' "${D}" \
| xargs sed -i -e "s:datadir=.*:datadir=/usr/share/mpich:g"
# those are dangling symlinks
- rm -f ${D}/usr/share/mpich/examples2/mpirun
+ rm -f "${D}"/usr/share/mpich/examples2/mpirun
- mv ${D}/usr/man ${D}/usr/share/man
+ mv "${D}"/usr/man "${D}"/usr/share/man
#FIXME: Here, we should either clean the empty directories
# or use keepdir to make sure they stick around.