summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-11-10 08:51:46 +0000
committerIan Delaney <idella4@gentoo.org>2013-11-10 08:51:46 +0000
commitda3c4530d00141608118f2c04bc3a1219d855cd6 (patch)
tree2801453f1b52721ef882e7a4c4c0c13faa22b07f /sys-cluster
parentVersion bump (diff)
downloadgentoo-2-da3c4530d00141608118f2c04bc3a1219d855cd6.tar.gz
gentoo-2-da3c4530d00141608118f2c04bc3a1219d855cd6.tar.bz2
gentoo-2-da3c4530d00141608118f2c04bc3a1219d855cd6.zip
ditto 2013.2.9999, viable test phase added to the live
(Portage version: 2.2.0/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/swift/ChangeLog6
-rw-r--r--sys-cluster/swift/swift-2013.2.9999.ebuild24
-rw-r--r--sys-cluster/swift/swift-9999.ebuild12
3 files changed, 19 insertions, 23 deletions
diff --git a/sys-cluster/swift/ChangeLog b/sys-cluster/swift/ChangeLog
index 1d8468a64a7f..21950a94a383 100644
--- a/sys-cluster/swift/ChangeLog
+++ b/sys-cluster/swift/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-cluster/swift
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/swift/ChangeLog,v 1.18 2013/11/10 07:02:22 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/swift/ChangeLog,v 1.19 2013/11/10 08:51:46 idella4 Exp $
+
+ 10 Nov 2013; Ian Delaney <idella4@gentoo.org> swift-1.10.0.ebuild,
+ swift-2013.2.9999.ebuild, swift-9999.ebuild:
+ ditto 2013.2.9999, viable test phase added to the live
10 Nov 2013; Ian Delaney <idella4@gentoo.org> swift-1.10.0.ebuild,
swift-1.9.1.ebuild:
diff --git a/sys-cluster/swift/swift-2013.2.9999.ebuild b/sys-cluster/swift/swift-2013.2.9999.ebuild
index d8d7cc66c7bc..f254d9d57acf 100644
--- a/sys-cluster/swift/swift-2013.2.9999.ebuild
+++ b/sys-cluster/swift/swift-2013.2.9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/swift/swift-2013.2.9999.ebuild,v 1.2 2013/10/22 18:05:46 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/swift/swift-2013.2.9999.ebuild,v 1.3 2013/11/10 08:51:46 idella4 Exp $
EAPI=5
PYTHON_COMPAT=( python2_7 )
@@ -64,6 +64,12 @@ src_prepare() {
sed -i 's/xattr/pyxattr/g' "${S}/tools/pip-requires"
}
+src_test () {
+ # https://bugs.launchpad.net/swift/+bug/1249727
+ find . \( -name test_wsgi.py -o -name test_locale.py \) -delete || die
+ sh .unittests || die
+}
+
python_install() {
distutils-r1_python_install
keepdir /etc/swift
@@ -109,19 +115,3 @@ pkg_postinst() {
elog " * cd /etc/swift"
elog " * openssl req -new -x509 -nodes -out cert.crt -keyout cert.key"
}
-
-#src_install()
-#{
-# distutils_src_install
-#
-# dodir "/var/run/swift"
-#
-# if use proxy-server; then
-# newinitd "${FILESDIR}/swift-proxy-server.initd" swift-proxy-server
-# fi
-#
-# if use storage-server; then
-# newinitd "${FILESDIR}/swift-storage-server.initd" swift-storage-server
-# newconfd "${FILESDIR}/swift-storage-server.confd" swift-storage-server
-# fi
-#}
diff --git a/sys-cluster/swift/swift-9999.ebuild b/sys-cluster/swift/swift-9999.ebuild
index d72f0357f956..14b765134848 100644
--- a/sys-cluster/swift/swift-9999.ebuild
+++ b/sys-cluster/swift/swift-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/swift/swift-9999.ebuild,v 1.5 2013/09/12 04:55:07 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/swift/swift-9999.ebuild,v 1.6 2013/11/10 08:51:46 idella4 Exp $
EAPI=5
PYTHON_COMPAT=( python2_7 )
@@ -45,10 +45,6 @@ CONFIG_CHECK="~EXT3_FS_XATTR ~SQUASHFS_XATTR ~CIFS_XATTR ~JFFS2_FS_XATTR
~TMPFS_XATTR ~UBIFS_FS_XATTR ~EXT2_FS_XATTR ~REISERFS_FS_XATTR ~EXT4_FS_XATTR
~ZFS"
-src_test () {
- sh .unittests || die
-}
-
pkg_setup() {
enewuser swift
enewgroup swift
@@ -59,6 +55,12 @@ src_prepare() {
sed -i 's/xattr/pyxattr/g' "${S}/tools/pip-requires"
}
+src_test () {
+ # https://bugs.launchpad.net/swift/+bug/1249727
+ find . -name test_wsgi.py -delete || die
+ sh .unittests || die
+}
+
python_install() {
distutils-r1_python_install
keepdir /etc/swift