summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2010-06-19 20:12:41 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2010-06-19 20:12:41 +0000
commita6dee94883caf8176b4b087506802456203cac0d (patch)
treedb525a3c4c57f8a6459f8ae5ed566d020888d2c6 /sys-cluster
parentVersion bump. (diff)
downloadgentoo-2-a6dee94883caf8176b4b087506802456203cac0d.tar.gz
gentoo-2-a6dee94883caf8176b4b087506802456203cac0d.tar.bz2
gentoo-2-a6dee94883caf8176b4b087506802456203cac0d.zip
Adding init script. Thanks to Ultrabug <ultrabug@ultrabug.net>
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/csync2/ChangeLog6
-rw-r--r--sys-cluster/csync2/csync2-1.34-r1.ebuild4
-rwxr-xr-xsys-cluster/csync2/files/csync2.initd26
3 files changed, 34 insertions, 2 deletions
diff --git a/sys-cluster/csync2/ChangeLog b/sys-cluster/csync2/ChangeLog
index ae46cc6f5f72..97e17be4e23a 100644
--- a/sys-cluster/csync2/ChangeLog
+++ b/sys-cluster/csync2/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-cluster/csync2
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/csync2/ChangeLog,v 1.28 2010/06/17 20:08:04 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/csync2/ChangeLog,v 1.29 2010/06/19 20:12:41 xarthisius Exp $
+
+ 19 Jun 2010; Kacper Kowalik <xarthisius@gentoo.org> +files/csync2.initd,
+ csync2-1.34-r1.ebuild:
+ Adding init script. Thanks to Ultrabug <ultrabug@ultrabug.net>
*csync2-1.34-r1 (17 Jun 2010)
diff --git a/sys-cluster/csync2/csync2-1.34-r1.ebuild b/sys-cluster/csync2/csync2-1.34-r1.ebuild
index 838137324215..a5b7d4fcc75a 100644
--- a/sys-cluster/csync2/csync2-1.34-r1.ebuild
+++ b/sys-cluster/csync2/csync2-1.34-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/csync2/csync2-1.34-r1.ebuild,v 1.1 2010/06/17 20:08:04 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/csync2/csync2-1.34-r1.ebuild,v 1.2 2010/06/19 20:12:41 xarthisius Exp $
EAPI=2
@@ -47,6 +47,8 @@ src_install() {
dodir /var/lib/csync2/ || die
keepdir /var/lib/csync2/
+ newinitd "${FILESDIR}"/${PN}.initd ${PN} || die
+
dodoc AUTHORS ChangeLog INSTALL NEWS README TODO csync2_locheck.sh || die
}
diff --git a/sys-cluster/csync2/files/csync2.initd b/sys-cluster/csync2/files/csync2.initd
new file mode 100755
index 000000000000..55537be94a66
--- /dev/null
+++ b/sys-cluster/csync2/files/csync2.initd
@@ -0,0 +1,26 @@
+#!/sbin/runscript
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/csync2/files/csync2.initd,v 1.1 2010/06/19 20:12:41 xarthisius Exp $
+
+PIDFILE=/var/run/csync2.pid
+BINARY=/usr/sbin/csync2
+
+start() {
+ ebegin "Starting csync2"
+ start-stop-daemon --start --pidfile "${PIDFILE}" -m -x ${BINARY} -b -- -ii
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping csync2"
+ start-stop-daemon --stop --pidfile "${PIDFILE}"
+ eend $?
+}
+
+restart() {
+ ebegin "Restarting csync2"
+ svc_stop
+ svc_start
+ eend $?
+}