summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-07-15 07:06:30 +0000
committerJustin Lecher <jlec@gentoo.org>2010-07-15 07:06:30 +0000
commit6cf3c59da5d63c22afd6d7d7ce7f6ecac62cf048 (patch)
treee8a579a80a1729f2440b918eaa5ae55e5d1752f3 /sys-cluster
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-6cf3c59da5d63c22afd6d7d7ce7f6ecac62cf048.tar.gz
gentoo-2-6cf3c59da5d63c22afd6d7d7ce7f6ecac62cf048.tar.bz2
gentoo-2-6cf3c59da5d63c22afd6d7d7ce7f6ecac62cf048.zip
Version Bump and prefix support
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/maui/ChangeLog7
-rw-r--r--sys-cluster/maui/maui-3.3.ebuild50
2 files changed, 56 insertions, 1 deletions
diff --git a/sys-cluster/maui/ChangeLog b/sys-cluster/maui/ChangeLog
index 88e092c4bd08..d99eaebf0110 100644
--- a/sys-cluster/maui/ChangeLog
+++ b/sys-cluster/maui/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-cluster/maui
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/maui/ChangeLog,v 1.15 2010/03/24 22:30:13 jsbronder Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/maui/ChangeLog,v 1.16 2010/07/15 07:06:30 jlec Exp $
+
+*maui-3.3 (14 Jul 2010)
+
+ 14 Jul 2010; Justin Lecher <jlec@gentoo.org> +maui-3.3.ebuild:
+ Version Bump and prefix support
*maui-3.2.6_p21-r1 (24 Mar 2010)
diff --git a/sys-cluster/maui/maui-3.3.ebuild b/sys-cluster/maui/maui-3.3.ebuild
new file mode 100644
index 000000000000..85978d2cbeb5
--- /dev/null
+++ b/sys-cluster/maui/maui-3.3.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/maui/maui-3.3.ebuild,v 1.1 2010/07/15 07:06:30 jlec Exp $
+
+EAPI="3"
+
+inherit autotools eutils multilib
+
+DESCRIPTION="Maui Cluster Scheduler"
+HOMEPAGE="http://www.clusterresources.com/products/maui/"
+SRC_URI="http://www.clusterresources.com/downloads/maui/${P/_/}.tar.gz"
+
+IUSE=""
+SLOT="0"
+LICENSE="maui"
+KEYWORDS="~amd64 ~x86 ~amd64-linux"
+
+DEPEND="sys-cluster/torque"
+RDEPEND="${DEPEND}"
+
+RESTRICT="fetch mirror"
+
+S="${WORKDIR}/${P/_/}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/3.2.6_p21-autoconf-2.60-compat.patch
+ # http://www.supercluster.org/pipermail/mauiusers/2010-March/004174.html
+ epatch "${FILESDIR}"/maui-3.2.6_p21-pbs-nodefile.patch
+ sed -i \
+ -e "s~BUILDROOT=~BUILDROOT=${D}~" \
+ "${S}"/Makefile.in
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --with-spooldir="${EPREFIX}"/usr/spool/maui \
+ --with-pbs="${EPREFIX}"/usr/
+}
+
+src_install() {
+ emake install INST_DIR="${ED}/usr"
+ dodoc docs/README CHANGELOG || die
+ dohtml docs/mauidocs.html || die
+}
+
+pkg_nofetch() {
+ einfo "Please visit ${HOMEPAGE}, obtain the file"
+ einfo "${P/_/}.tar.gz and put it in ${DISTDIR}"
+}