summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Heim <phreak@gentoo.org>2006-08-27 10:25:21 +0000
committerChristian Heim <phreak@gentoo.org>2006-08-27 10:25:21 +0000
commit64c19905f97b2c7384e7f62544b04ebaacab5153 (patch)
treeff481a16abff5033f95204a2fd9d9bc3665155f2 /sys-cluster
parentstable on amd64 (diff)
downloadgentoo-2-64c19905f97b2c7384e7f62544b04ebaacab5153.tar.gz
gentoo-2-64c19905f97b2c7384e7f62544b04ebaacab5153.tar.bz2
gentoo-2-64c19905f97b2c7384e7f62544b04ebaacab5153.zip
Finally adding vzctl-3.0.11, finally fixing all --as-needed and rpath related issues we had in the past.
(Portage version: 2.1.1_rc1)
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/vzctl/ChangeLog8
-rw-r--r--sys-cluster/vzctl/files/digest-vzctl-3.0.116
-rw-r--r--sys-cluster/vzctl/vzctl-3.0.11.ebuild66
3 files changed, 79 insertions, 1 deletions
diff --git a/sys-cluster/vzctl/ChangeLog b/sys-cluster/vzctl/ChangeLog
index 3a86b150b9c5..910a8c984cd8 100644
--- a/sys-cluster/vzctl/ChangeLog
+++ b/sys-cluster/vzctl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-cluster/vzctl
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/vzctl/ChangeLog,v 1.30 2006/07/09 17:05:14 phreak Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/vzctl/ChangeLog,v 1.31 2006/08/27 10:25:21 phreak Exp $
+
+*vzctl-3.0.11 (27 Aug 2006)
+
+ 27 Aug 2006; Christian Heim <phreak@gentoo.org> +vzctl-3.0.11.ebuild:
+ Finally adding vzctl-3.0.11, finally fixing all --as-needed and rpath
+ related issues we had in the past.
09 Jul 2006; Christian Heim <phreak@gentoo.org> -vzctl-3.0.10.ebuild,
-vzctl-3.0.10-r1.ebuild:
diff --git a/sys-cluster/vzctl/files/digest-vzctl-3.0.11 b/sys-cluster/vzctl/files/digest-vzctl-3.0.11
new file mode 100644
index 000000000000..2bc6891b55ec
--- /dev/null
+++ b/sys-cluster/vzctl/files/digest-vzctl-3.0.11
@@ -0,0 +1,6 @@
+MD5 8e5a1e4126690ee7e843ccbd0ce9654c vzctl-3.0.11-patches.tar.bz2 10408
+RMD160 e5765b4a13c644206a2b14888e80b96e91f62dda vzctl-3.0.11-patches.tar.bz2 10408
+SHA256 91460d16c8c799de7080f498d0c6677b37c413bba35f8f928465e2f04aedf67e vzctl-3.0.11-patches.tar.bz2 10408
+MD5 a2f7500961047b971dc7cde761e5ed3f vzctl-3.0.11.tar.bz2 125685
+RMD160 af04926dc3971d4078e83333d015a9db49e63ff7 vzctl-3.0.11.tar.bz2 125685
+SHA256 03b255ba3cdc700178bb7d20af928ab3896ac799404866187f0293ed87a9aecb vzctl-3.0.11.tar.bz2 125685
diff --git a/sys-cluster/vzctl/vzctl-3.0.11.ebuild b/sys-cluster/vzctl/vzctl-3.0.11.ebuild
new file mode 100644
index 000000000000..3603cc3f0f85
--- /dev/null
+++ b/sys-cluster/vzctl/vzctl-3.0.11.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/vzctl/vzctl-3.0.11.ebuild,v 1.1 2006/08/27 10:25:21 phreak Exp $
+
+inherit eutils flag-o-matic multilib
+
+DESCRIPTION="OpenVZ VPS control utility"
+HOMEPAGE="http://openvz.org/"
+SRC_URI="http://download.openvz.org/utils/${PN}/${PV}/src/${P}.tar.bz2
+ http://dev.gentoo.org/~phreak/distfiles/${P}-patches.tar.bz2
+ http://dev.gentoo.org/~hollow/distfiles/${P}-patches.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="app-admin/logrotate
+ sys-apps/ed
+ net-firewall/iptables
+ sys-fs/vzquota
+ sys-apps/iproute2"
+
+DEPEND="${RDEPEND}"
+
+src_unpack() {
+ unpack ${A}
+
+ epatch "${WORKDIR}"/patches/*.patch
+}
+
+src_compile() {
+ append-flags -Wall -g2
+ emake CFLAGS="${CFLAGS}" || die
+}
+
+src_install() {
+ make DESTDIR="${D}" LIBDIR="/usr/$(get_libdir)/vzctl" install || die "make install failed"
+
+ # the get_libdir breaks stupid src/Makefile (all contained tools)
+ # so we have to create a env.d entry for vzctl's LDPATH
+ dodir /etc/env.d
+ echo "LDPATH=\"/usr/$(get_libdir)/vzctl\"" > "${D}"/etc/env.d/05vzctl
+
+ # Provide a symlink for vz.conf (part 1 of fixing #138462)
+ dosym /etc/vz/vz.conf /etc/conf.d/vz
+
+ # Install gentoo specific init script
+ rm -f "${D}"/etc/init.d/*
+ newinitd "${FILESDIR}"/vz-3.0.10.initd vz
+
+ dodoc "${WORKDIR}/patches/000_README"
+}
+
+pkg_postinst() {
+ if has_version "<3.0.10"; then
+ ewarn
+ ewarn "The location of some vzctl files have changed. Most notably,"
+ ewarn "VE configuration files and samples directory has changed from"
+ ewarn "/etc/vz to /etc/vz/conf. In order to be able to work with"
+ ewarn "your VEs, please do the following:"
+ ewarn
+ ewarn "bash# mv /etc/vz/[0-9]*.conf /etc/vz/conf/"
+ ewarn
+ fi
+}