summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2010-10-14 17:33:41 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2010-10-14 17:33:41 +0000
commit35fd47c071175ad26984c78b2451287514b73b8c (patch)
treeb5df0116421cb42fdcd3438ae76bd3206f39465b /sys-cluster
parentRemove old. (diff)
downloadgentoo-2-35fd47c071175ad26984c78b2451287514b73b8c.tar.gz
gentoo-2-35fd47c071175ad26984c78b2451287514b73b8c.tar.bz2
gentoo-2-35fd47c071175ad26984c78b2451287514b73b8c.zip
Respect LDFLAGS wrt bug 339197. Thanks to Diego for the report. Simplify ebuild, correct dependencies. Drop old.
(Portage version: 2.2_rc90/cvs/Linux x86_64)
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/pconsole/ChangeLog9
-rw-r--r--sys-cluster/pconsole/pconsole-1.0-r2.ebuild38
-rw-r--r--sys-cluster/pconsole/pconsole-1.0-r3.ebuild41
3 files changed, 49 insertions, 39 deletions
diff --git a/sys-cluster/pconsole/ChangeLog b/sys-cluster/pconsole/ChangeLog
index d73566b23919..b20b2e5bbd26 100644
--- a/sys-cluster/pconsole/ChangeLog
+++ b/sys-cluster/pconsole/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-cluster/pconsole
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/pconsole/ChangeLog,v 1.11 2010/06/02 06:44:10 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/pconsole/ChangeLog,v 1.12 2010/10/14 17:33:41 xarthisius Exp $
+
+*pconsole-1.0-r3 (14 Oct 2010)
+
+ 14 Oct 2010; Kacper Kowalik <xarthisius@gentoo.org>
+ -pconsole-1.0-r2.ebuild, +pconsole-1.0-r3.ebuild:
+ Respect LDFLAGS wrt bug 339197. Thanks to Diego for the report. Simplify
+ ebuild, correct dependencies. Drop old.
02 Jun 2010; Torsten Veller <tove@gentoo.org> metadata.xml:
Remove tantive from metadata.xml (#200343)
diff --git a/sys-cluster/pconsole/pconsole-1.0-r2.ebuild b/sys-cluster/pconsole/pconsole-1.0-r2.ebuild
deleted file mode 100644
index 3b8bde4fc115..000000000000
--- a/sys-cluster/pconsole/pconsole-1.0-r2.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/pconsole/pconsole-1.0-r2.ebuild,v 1.3 2009/10/13 18:46:17 haubi Exp $
-
-inherit autotools eutils
-
-DESCRIPTION="Tool for managing multiple xterms simultaneously."
-HOMEPAGE="http://www.heiho.net/pconsole/"
-SRC_URI="http://www.xs4all.nl/~walterj/pconsole/${P}.tar.gz"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE=""
-DEPEND="virtual/ssh"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- epatch ${FILESDIR}/${P}-exit-warn.patch || einfo "Never mind.."
- sed -i \
- -e "s:\(CCOPTS=\).*:\1'${CFLAGS}':g" \
- "${S}"/configure.in
- eautoreconf
-}
-
-src_install() {
- einstall bindir="${D}/usr/bin" || die "install failed"
- fperms 4111 /usr/bin/pconsole
- dodoc ChangeLog public_html/pconsole.html README.pconsole
-}
-
-pkg_postinst() {
- ewarn
- ewarn "Warning:"
- ewarn "pconsole installed with suid root!"
- ewarn
-}
diff --git a/sys-cluster/pconsole/pconsole-1.0-r3.ebuild b/sys-cluster/pconsole/pconsole-1.0-r3.ebuild
new file mode 100644
index 000000000000..581dc6cf825a
--- /dev/null
+++ b/sys-cluster/pconsole/pconsole-1.0-r3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/pconsole/pconsole-1.0-r3.ebuild,v 1.1 2010/10/14 17:33:41 xarthisius Exp $
+
+EAPI=2
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Tool for managing multiple xterms simultaneously."
+HOMEPAGE="http://www.heiho.net/pconsole/"
+SRC_URI="http://www.xs4all.nl/~walterj/pconsole/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="virtual/ssh"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-exit-warn.patch
+}
+
+src_compile() {
+ emake LFLAGS="${LDFLAGS}" CFLAGS="${CFLAGS}" \
+ CC="$(tc-getCC)" || die
+}
+
+src_install() {
+ dobin pconsole || die
+ fperms 4110 /usr/bin/pconsole || die
+ dodoc ChangeLog README.pconsole || die
+ dohtml public_html/pconsole.html || die
+}
+
+pkg_postinst() {
+ echo
+ ewarn "Warning:"
+ ewarn "pconsole installed with suid root!"
+ echo
+}