summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Heim <phreak@gentoo.org>2007-07-06 10:10:49 +0000
committerChristian Heim <phreak@gentoo.org>2007-07-06 10:10:49 +0000
commit264863169b638f8489816b18dc68708af38ad9b7 (patch)
treeead319726cc01b887856b4a061dc8ced5819004e /sys-cluster
parentOnly include alloca.h for gcc on glibc sytsems, #183295 thanks to Nathan Smith. (diff)
downloadgentoo-2-264863169b638f8489816b18dc68708af38ad9b7.tar.gz
gentoo-2-264863169b638f8489816b18dc68708af38ad9b7.tar.bz2
gentoo-2-264863169b638f8489816b18dc68708af38ad9b7.zip
Version bump, fixing the initscript to work with 2.6.9 based kernels (openvz-sources-023.*).
(Portage version: 2.1.3_rc6)
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/vzctl/ChangeLog8
-rw-r--r--sys-cluster/vzctl/files/digest-vzctl-3.0.183
-rw-r--r--sys-cluster/vzctl/vzctl-3.0.18.ebuild55
3 files changed, 65 insertions, 1 deletions
diff --git a/sys-cluster/vzctl/ChangeLog b/sys-cluster/vzctl/ChangeLog
index e269659a68eb..4c849bc3b841 100644
--- a/sys-cluster/vzctl/ChangeLog
+++ b/sys-cluster/vzctl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-cluster/vzctl
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/vzctl/ChangeLog,v 1.46 2007/07/06 09:17:20 phreak Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/vzctl/ChangeLog,v 1.47 2007/07/06 10:10:49 phreak Exp $
+
+*vzctl-3.0.18 (06 Jul 2007)
+
+ 06 Jul 2007; Christian Heim <phreak@gentoo.org> +vzctl-3.0.18.ebuild:
+ Version bump, fixing the initscript to work with 2.6.9 based kernels
+ (openvz-sources-023.*).
*vzctl-3.0.17 (06 Jul 2007)
diff --git a/sys-cluster/vzctl/files/digest-vzctl-3.0.18 b/sys-cluster/vzctl/files/digest-vzctl-3.0.18
new file mode 100644
index 000000000000..613109e369e5
--- /dev/null
+++ b/sys-cluster/vzctl/files/digest-vzctl-3.0.18
@@ -0,0 +1,3 @@
+MD5 a9284e668da669ed92e33abc39c70ca9 vzctl-3.0.18.tar.bz2 359655
+RMD160 9c7169e151c6384fd489df3dd6392d442706f46f vzctl-3.0.18.tar.bz2 359655
+SHA256 8610efa9a8327a1b6457eaa28b772ad753db5f23c2c18b25bb3ce0cf6a929e2f vzctl-3.0.18.tar.bz2 359655
diff --git a/sys-cluster/vzctl/vzctl-3.0.18.ebuild b/sys-cluster/vzctl/vzctl-3.0.18.ebuild
new file mode 100644
index 000000000000..812e03b87f78
--- /dev/null
+++ b/sys-cluster/vzctl/vzctl-3.0.18.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/vzctl/vzctl-3.0.18.ebuild,v 1.1 2007/07/06 10:10:49 phreak Exp $
+
+inherit bash-completion eutils
+
+DESCRIPTION="OpenVZ VE control utility"
+HOMEPAGE="http://openvz.org/"
+SRC_URI="http://download.openvz.org/utils/${PN}/${PV}/src/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc64 ~sparc ~x86"
+IUSE="bash-completion logrotate"
+
+RDEPEND="logrotate? ( app-admin/logrotate )
+ net-firewall/iptables
+ sys-apps/ed
+ sys-apps/iproute2
+ sys-fs/vzquota
+ virtual/cron"
+
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ econf --localstatedir=/var \
+ --enable-cron \
+ --enable-udev \
+ $(use_enable bash-completion bashcomp) \
+ $(use_enable logrotate) || die "econf failed!"
+
+ emake || die "emake failed!"
+}
+
+src_install() {
+ make DESTDIR="${D}" install install-gentoo || die "make install failed"
+
+ # install the bash-completion script into the right location
+ rm -rf "${D}"/etc/bash_completion.d
+ dobashcompletion "${S}"/etc/bash_completion.d/vzctl.sh vzctl
+}
+
+pkg_postinst() {
+ bash-completion_pkg_postinst
+ if has_version "<3.0.10"; then
+ ewarn
+ ewarn "The location of some vzctl files have changed. Most notably,"
+ ewarn "VE configuration files and samples directory has changed from"
+ ewarn "/etc/vz to /etc/vz/conf. In order to be able to work with"
+ ewarn "your VEs, please do the following:"
+ ewarn
+ ewarn "bash# mv /etc/vz/[0-9]*.conf /etc/vz/conf/"
+ ewarn
+ fi
+}