summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDanny van Dyk <kugelfang@gentoo.org>2005-07-05 22:21:59 +0000
committerDanny van Dyk <kugelfang@gentoo.org>2005-07-05 22:21:59 +0000
commit01262cc72308e64f0f1b007173464e6340af234e (patch)
treebc3d3995b4dccbfa1c9322dc2fff615fb7b927ce /sys-cluster
parent#97984: version bump (diff)
downloadgentoo-2-01262cc72308e64f0f1b007173464e6340af234e.tar.gz
gentoo-2-01262cc72308e64f0f1b007173464e6340af234e.tar.bz2
gentoo-2-01262cc72308e64f0f1b007173464e6340af234e.zip
Bumped to fix my own breakage. (BUG #95994)
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/lam-mpi/ChangeLog7
-rw-r--r--sys-cluster/lam-mpi/files/digest-lam-mpi-7.1.1-r11
-rw-r--r--sys-cluster/lam-mpi/lam-mpi-7.1.1-r1.ebuild69
3 files changed, 76 insertions, 1 deletions
diff --git a/sys-cluster/lam-mpi/ChangeLog b/sys-cluster/lam-mpi/ChangeLog
index 9d2d9e4ad81f..6c4a21dcca55 100644
--- a/sys-cluster/lam-mpi/ChangeLog
+++ b/sys-cluster/lam-mpi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-cluster/lam-mpi
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/lam-mpi/ChangeLog,v 1.34 2005/05/24 23:17:01 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/lam-mpi/ChangeLog,v 1.35 2005/07/05 22:21:59 kugelfang Exp $
+
+*lam-mpi-7.1.1-r1 (06 Jul 2005)
+
+ 06 Jul 2005; Danny van Dyk <kugelfang@gentoo.org> lam-mpi-7.1.1-r1.ebuild:
+ Bumped to circumvent my broken romio patch. Sorry :-/
24 May 2005; Donnie Berkholz <spyderous@gentoo.org>;
files/lam-mpi-7.1.1-shared-romio.patch:
diff --git a/sys-cluster/lam-mpi/files/digest-lam-mpi-7.1.1-r1 b/sys-cluster/lam-mpi/files/digest-lam-mpi-7.1.1-r1
new file mode 100644
index 000000000000..280f97bd3d73
--- /dev/null
+++ b/sys-cluster/lam-mpi/files/digest-lam-mpi-7.1.1-r1
@@ -0,0 +1 @@
+MD5 0a3eee53281884a063ce2c44793672b3 lam-7.1.1.tar.bz2 7589413
diff --git a/sys-cluster/lam-mpi/lam-mpi-7.1.1-r1.ebuild b/sys-cluster/lam-mpi/lam-mpi-7.1.1-r1.ebuild
new file mode 100644
index 000000000000..24175cb7bb5e
--- /dev/null
+++ b/sys-cluster/lam-mpi/lam-mpi-7.1.1-r1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/lam-mpi/lam-mpi-7.1.1-r1.ebuild,v 1.1 2005/07/05 22:21:59 kugelfang Exp $
+
+inherit fortran
+
+IUSE="crypt"
+
+MY_P=${P/-mpi}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="the LAM MPI parallel computing environment"
+SRC_URI="http://www.lam-mpi.org/download/files/${MY_P}.tar.bz2"
+HOMEPAGE="http://www.lam-mpi.org"
+
+DEPEND="virtual/libc"
+# we need ssh if we want to use it instead of rsh
+RDEPEND="${DEPEND}
+ crypt? ( net-misc/openssh )
+ !crypt? ( net-misc/netkit-rsh )
+ !sys-cluster/mpich"
+
+SLOT="6"
+KEYWORDS="amd64 ~x86 ~sparc ppc64 ~ppc"
+LICENSE="as-is"
+
+src_unpack() {
+ unpack ${A}
+
+ # Taken out for the moment. I'll address this as soon as possible.
+ # Seems like romio needs (all?) ADIOI libraries built as shared libs
+ # as well.
+ # Danny van Dyk <kugelfang@gentoo.org> 2005/07/06
+ #epatch ${FILESDIR}/${P}-shared-romio.patch
+ cd ${S}/romio/util/
+ sed -i "s|docdir=\"\$datadir/lam/doc\"|docdir=\"${D}/usr/share/doc/${PF}\"|" romioinstall.in
+}
+
+src_compile() {
+
+ local myconf
+
+ if use crypt; then
+ myconf="${myconf} --with-rsh=ssh"
+ else
+ myconf="${myconf} --with-rsh=rsh"
+ fi
+
+ econf \
+ --sysconfdir=/etc/lam-mpi \
+ --enable-shared \
+ --with-threads=posix \
+ ${myconf} || die
+
+ # sometimes parallel doesn't finish since it gets ahead of itself :)
+
+ emake -j1 || die
+}
+
+src_install () {
+
+ make DESTDIR="${D}" install || die
+
+ # There are a bunch more tex docs we could make and install too,
+ # but they might be replicated in the pdf.
+ dodoc README HISTORY LICENSE VERSION
+ cd ${S}/doc
+ dodoc {user,install}.pdf
+}